Linux - [SOLVED] Compilation error - DBUS?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
BLKMGK Offline
Donor
Posts: 1,736
Joined: Jul 2006
Reputation: 4
Location: USA Virginia
Post: #1
Blew up my working Linux install, loaded from scratch, ran into a compilation error I couldn't get around and other OS issues. Frustrated I grabbed a spare machine that was working, did a git pull, compiled, SAME error. Searched and not seeing anyone else complaining and it's been going on for two days with additional code being added so I thought I'd ask. Error looks familiar but am frustrated and not able to find the error via searching. Angel

Ubuntu 10.10 base (other machine was updated 12.04 though) Both machines are running x64 Linux with the current 10.10 has a running older compiled XBMC onboard.
This is ION1 hardware.

git Rev.: 20130922-6d2989c

make clean doesn't fix this
git clean -xfd && git reset --hard && git pull --rebase also had no effect

Steps to compile are: ./bootstrap; ./configure; ./make -j4 (using just make has no effect)
uname -r produces -> 2.6.32-51-generic Kernel on 12.04 machine had been updated to 3.10xx

Error seen at console is:

Code:
CPP     lib/UnrarXLib/crc.o
LogindUPowerSyscall.cpp: In member function âvoid CLogindUPowerSyscall::InhibitDelayLock()â:
LogindUPowerSyscall.cpp:282: error: âDBUS_TYPE_UNIX_FDâ was not declared in this scope
make[1]: *** [LogindUPowerSyscall.o] Error 1
make: *** [xbmc/powermanagement/linux/powermanagement_linux.a] Error 2
make: *** Waiting for unfinished jobs....

XBMC config can be found here -> http://pastebin.com/1TnWnGc8

Thoughts? I've not tried rolling back as I've not done that since SVN days and I often got myself into trouble when I did. If someone would like me to roll back revs and find where it broke just please give me the Git commands and I'll be happy to do it. there's an older source compile working on this machine so it's not DOA but I'd like to keep up with the codebase. This box is going to be swapped ASAP for something that can do THD bitstreaming so I'm in no way screaming and crying but am more puzzled and frustrated. Confused

Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
(This post was last modified: 2013-10-19 09:19 by BLKMGK.)
find quote
fritsch Offline
Team-XBMC Member
Posts: 4,269
Joined: Aug 2011
Reputation: 107
Location: Karlsruhe
Post: #2
http://forum.xbmc.org/showthread.php?tid=171593
find quote
BLKMGK Offline
Donor
Posts: 1,736
Joined: Jul 2006
Reputation: 4
Location: USA Virginia
Post: #3
Oh geez, thank you! I knew I'd seen this before and that looks mighty familiar. Weird thing is that this machine compiled just fine previously and now fails after simply sitting for awhile. I'll try the suggestions from that thread!


Aaaaand - libdbus-1-dev is already installed and is the latest version. d'oh! Is this an issue with 10.10 being depracted? If so I can wait on this box and just build for the haswell future box. However having gotten the SAME errors on a fresh 12.04lts install previously I'm pretty confused.

EDIT Moron mode in ful effect - there's a patch listed in that thread. Working on it...

Code:
sudo apt-get install libdbus-1-dev
[sudo] password for user: blahdblah
Reading package lists... Done
Building dependency tree
Reading state information... Done
libdbus-1-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
(This post was last modified: 2013-09-22 23:45 by BLKMGK.)
find quote
BLKMGK Offline
Donor
Posts: 1,736
Joined: Jul 2006
Reputation: 4
Location: USA Virginia
Post: #4
Okay bottom line now that I've read the other thread fully (ahem)...

Ubuntu apparently bumped a revision on libdbus-1-dev but it's not correct. The 10.x series of Ubuntu seem to have this issue and there are some functions missing or not defined properly. Possible to work around it patching XBMC but that will put me out of synch it looks like and I don't want that - been there done that. Ubuntu 10.x is no longer supported so no help there. Does this sound like I've understood this properly?

Later distro should fix this I think however my other box was blown away, formatted, 12.04 Ubuntu installed, and it still FAILS. I'm not sure what's up with that since it obviously works for others. I pull some build dependencies from the Team-XBMC repo but otherwise that box pulled from standard Ubuntu repos so I'm puzzled. I'll dig into this more as time allows, I do have a Mint based box that was still compiling last I checked, maybe I'll see how it differs!

Short of patching XBMC I'm not sure how to go. I really hate Unity so perhaps on the box that's now idle I'll install Mint and see how it plays. Are the Devs on straight normal Ubuntu 12.x? Have they moved to 64bit now?

Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
find quote
fritsch Offline
Team-XBMC Member
Posts: 4,269
Joined: Aug 2011
Reputation: 107
Location: Karlsruhe
Post: #5
Not sure about "the devs". I am currently running Ubuntu raring 13.04 64 bit on all my dev systems, despite OpenELEC on the dedicated media center pc.
find quote
wsnipex Offline
Team-XBMC packaging monkey
Posts: 3,120
Joined: Jun 2011
Reputation: 76
Post: #6
all ubuntu versions >=12.04 work fine and don't show this problem and we provide builds on our PPAs for all of them.
find quote
BLKMGK Offline
Donor
Posts: 1,736
Joined: Jul 2006
Reputation: 4
Location: USA Virginia
Post: #7
Well, my Mint 14 box compiled with no issues but the 12.04 box I built failed to compile. A shame that the older software is running into this issue and it's odd that the 12.04 box, which was up to date, ran into problems. I'm honestly no fan of Unity so when I get some new Haswell hardware onboard (NUC i3 or i5 most likely) I'll throw Mint in the latest flavor on it and see how it goes. Appreciate the input, glad to see I'm not the only one with the issue at least!

Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
find quote
fritsch Offline
Team-XBMC Member
Posts: 4,269
Joined: Aug 2011
Reputation: 107
Location: Karlsruhe
Post: #8
Don't compare apples with bananas.

Act sane and check installed -deb versions, e.g. dpkg -l |grep dbus | pastebinit and so on. You upgraded your system I am totall not sure, if some old lib got stuck while doing so.
find quote
fritsch Offline
Team-XBMC Member
Posts: 4,269
Joined: Aug 2011
Reputation: 107
Location: Karlsruhe
Post: #9
To add, as wsnipex pointed out. For all version >= 12.04 we have a ppa - there is no need to build yourself. Self building is an advanced task. On thing to note: our ubuntu packages are build with pbuilder on launchpad - they exactly use _your_ 12.04 environment.

So - if it builds there, it must build for you. If it does not - you have a problem on your machine, not related to xbmc (e.g. missing, wrong lib version).
find quote
BLKMGK Offline
Donor
Posts: 1,736
Joined: Jul 2006
Reputation: 4
Location: USA Virginia
Post: #10
The 12.04 box was a fresh load, no upgrade and it failed. I've been building XBMC from source for at least three years now so no thanks on the PPA. I've taken that box offline and am using an older machine - that also won't compile and crashes with the same error. I'll have to look again to see what's on it. That box used to compile fine when it was taken offline, with no changes since it no longer compiles <shrug>

Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
find quote
spiff Offline
Retired Developer
Posts: 12,386
Joined: Nov 2003
Post: #11
it will compile now. we added conditional use of the code that breaks old builds (it won't be able to inhibit the desktop lock but other than that).
find quote
BLKMGK Offline
Donor
Posts: 1,736
Joined: Jul 2006
Reputation: 4
Location: USA Virginia
Post: #12
(2013-10-08 11:20)spiff Wrote:  it will compile now. we added conditional use of the code that breaks old builds (it won't be able to inhibit the desktop lock but other than that).

Thank you! I can confirm that this is working now and I'm able to compile on both Mint 14 and on my Ubuntu 10.04 box - MUCH appreciated! I do intend to upgrade hardware as soon as I can decide upon a suitable platform (Haswell almost certainly) and will do a fresh software install with something more up to date at that time. Likely Mint again :-)

Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
find quote