Linux - Radeon OSS with vdpau (howto)

  Thread Rating:
  • 19 Votes - 4.79 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
sa1x Offline
Junior Member
Posts: 4
Joined: Apr 2014
Reputation: 0
Post: #2536
Have one problem with this guide: getting 100% cpu load, extream slow xbmc menu and xbmc is crashing when starting a video.
Got an A4-3400 so cpu should not hit 100. Somehow I guess it has something to do with X not realy using the radeon oss.
Happens with both offical beta ppa and wsnipex ppa - also tested the linux headers from fritsch.

Xorg.0.log: http://paste.ubuntu.com/7274083/

Any idea?
find quote
fritsch Offline
Team-XBMC Member
Posts: 4,284
Joined: Aug 2011
Reputation: 107
Location: Karlsruhe
Post: #2537
Provide all the logs, the first post wants.
find quote
sa1x Offline
Junior Member
Posts: 4
Joined: Apr 2014
Reputation: 0
Post: #2538
Oh sorry here the missing logs

dmesg
http://paste.ubuntu.com/7274335/
xbmc.log
http://paste.ubuntu.com/7274336/
vdpauinfo
http://paste.ubuntu.com/7274338/
dpkg
http://paste.ubuntu.com/7274346/
find quote
fritsch Offline
Team-XBMC Member
Posts: 4,284
Joined: Aug 2011
Reputation: 107
Location: Karlsruhe
Post: #2539
You don't have any Audio devices. Did you do the useradd command? Are you member of the audio group? What does id show?

What does aplay -L show?
find quote
sa1x Offline
Junior Member
Posts: 4
Joined: Apr 2014
Reputation: 0
Post: #2540
shit, fealing stupid now...
i checked the history, guess the usermod command i copied got swallows by the adduser password promt...

thanks for this realy fast help
find quote
fritsch Offline
Team-XBMC Member
Posts: 4,284
Joined: Aug 2011
Reputation: 107
Location: Karlsruhe
Post: #2541
Workaround for "I want to boot with my AVR and TV off"

1.) Boot with the TV AVR powered on, make sure everything is working
2.) Copy the currently in use EDID into a file
2a) Find out which device is connected
Code:
for f in /sys/class/drm/card*; do echo $f && cat $f/enabled; done

Sample Output:
Quote:/sys/class/drm/card0-DP-1
disabled
/sys/class/drm/card0-HDMI-A-1
enabled
/sys/class/drm/card0-VGA-1
disabled

2b) copy firmware somewhere, make sure use the correctly connected head (in that case card0-HDMI-A-1)
Code:
sudo mkdir -p /lib/firmware/edid
sudo cp /sys/class/drm/card0-HDMI-A-1/edid /lib/firmware/edid/edid.bin

3) edit /etc/default/grub
and add to the existing GRUB_CMDLINE_LINUX_DEFAULT drm_kms_helper.edid_firmware=HDMI-A-1:edid/edid.bin:

Make sure to get the HDMI-A-1 string correct in both the forced enable and the workaround.
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi='!Windows 2012' drm_kms_helper.edid_firmware=HDMI-A-1:edid/edid.bin video=HDMI-A-1:e"
(This post was last modified: Yesterday 13:31 by fritsch.)
find quote
pyrodex Offline
Senior Member
Posts: 215
Joined: Jan 2011
Reputation: 1
Post: #2542
(Yesterday 13:30)fritsch Wrote:  Workaround for "I want to boot with my AVR and TV off"

1.) Boot with the TV AVR powered on, make sure everything is working
2.) Copy the currently in use EDID into a file
2a) Find out which device is connected
Code:
for f in /sys/class/drm/card*; do echo $f && cat $f/enabled; done

Sample Output:
Quote:/sys/class/drm/card0-DP-1
disabled
/sys/class/drm/card0-HDMI-A-1
enabled
/sys/class/drm/card0-VGA-1
disabled

2b) copy firmware somewhere, make sure use the correctly connected head (in that case card0-HDMI-A-1)
Code:
sudo mkdir -p /lib/firmware/edid
sudo cp /sys/class/drm/card0-HDMI-A-1/edid /lib/firmware/edid/edid.bin

3) edit /etc/default/grub
and add to the existing GRUB_CMDLINE_LINUX_DEFAULT drm_kms_helper.edid_firmware=HDMI-A-1:edid/edid.bin:

Make sure to get the HDMI-A-1 string correct in both the forced enable and the workaround.
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi='!Windows 2012' drm_kms_helper.edid_firmware=HDMI-A-1:edid/edid.bin video=HDMI-A-1:e"

fritsch thanks for this little tidbit and I was curious if this could help me remove my HDMI Detective Plus from my configuration since I tend to leave the HTPCs on in idle and shut down the surrounding components. On my TV configuration which is merely a samsung into the HTPC I get video after a reboot of the HTPC with the TV off but when I power up the TV to use it I don't get audio. I tried rebooting the system with the TV on and the EDID in place but still get video and no audio. Any help or thoughts here? Logs below:

dmesg:
http://paste.ubuntu.com/7275899/
xbmc.log:
http://paste.ubuntu.com/7275900/
Xorg.0.log:
http://paste.ubuntu.com/7275901/
vdpauinfo:
http://paste.ubuntu.com/7275902/
dpkg w/mesa:
http://paste.ubuntu.com/7275903/

Den: Ubuntu 14.04 | AMD A6-3500 | Gotham w/MythTV | Panasonic VT25 50" | Denon AVR-991 | Harmony One | 5.1 Surround Sound
Bedroom: Ubuntu 14.04 | AMD A6-3500 | Gotham w/MythTV | Samsung UN32F6300AF 32" | Harmony 650
NAS: Ubuntu 14.04 | 32TB on Areca 1880 | SMB | Sickbeard | CouchPotato | MySQL DB (XBMC) | MythTV 0.27+fixes w/ 2x HDHomeRun Prime 3CC
find quote
fritsch Offline
Team-XBMC Member
Posts: 4,284
Joined: Aug 2011
Reputation: 107
Location: Karlsruhe
Post: #2543
Nope. No idea - works for me (with Samsung TV).

Edit: Same issue on my second test system. So handle with care :-)
(This post was last modified: Yesterday 16:26 by fritsch.)
find quote
pyrodex Offline
Senior Member
Posts: 215
Joined: Jan 2011
Reputation: 1
Post: #2544
Ironically after removing the EDID and keeping the HDMI straight to the HTPC it worked so far after multiple reboots with the TV being off. I am going to play with it for a few days and see what happens.

Ideally it makes the configuration much easier so maybe worth it.

Den: Ubuntu 14.04 | AMD A6-3500 | Gotham w/MythTV | Panasonic VT25 50" | Denon AVR-991 | Harmony One | 5.1 Surround Sound
Bedroom: Ubuntu 14.04 | AMD A6-3500 | Gotham w/MythTV | Samsung UN32F6300AF 32" | Harmony 650
NAS: Ubuntu 14.04 | 32TB on Areca 1880 | SMB | Sickbeard | CouchPotato | MySQL DB (XBMC) | MythTV 0.27+fixes w/ 2x HDHomeRun Prime 3CC
find quote
deivid Offline
Junior Member
Posts: 12
Joined: Feb 2014
Reputation: 0
Post: #2545
(Yesterday 11:07)sa1x Wrote:  Have one problem with this guide: getting 100% cpu load, extream slow xbmc menu and xbmc is crashing when starting a video.
Got an A4-3400 so cpu should not hit 100. Somehow I guess it has something to do with X not realy using the radeon oss.
Happens with both offical beta ppa and wsnipex ppa - also tested the linux headers from fritsch.

Xorg.0.log: http://paste.ubuntu.com/7274083/

Any idea?

This happened to me when I had no libglamor0, try running
Code:
apt-get install libglamor0=0.6.0-0ubuntu4
and paste the output of
Code:
dpkg -l | grep vdpau
find quote
Post Reply