Linux - Radeon OSS with vdpau (howto)

  Thread Rating:
  • 23 Votes - 4.65 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
fritsch Offline
Team-XBMC Developer
Posts: 5,444
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #2821
Minimal Debug Log with that one https://dl.dropboxusercontent.com/u/5572...lannad.mkv please
find quote
ixbeemce Offline
Junior Member
Posts: 35
Joined: Nov 2013
Reputation: 0
Post: #2822
(2014-05-17 19:29)fritsch Wrote:  Minimal Debug Log with that one https://dl.dropboxusercontent.com/u/5572...lannad.mkv please

http://paste.ubuntu.com/7479575/
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,444
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #2823
Can you play from a non NTFS drive?

Log looks good.
find quote
ixbeemce Offline
Junior Member
Posts: 35
Joined: Nov 2013
Reputation: 0
Post: #2824
(2014-05-17 20:02)fritsch Wrote:  Can you play from a non NTFS drive?

Log looks good.

http://paste.ubuntu.com/7479677/
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,444
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #2825
Looks again good. Watch the Codec Screen (o) and see if there is something that shows your issue.
(This post was last modified: 2014-05-17 20:32 by fritsch.)
find quote
kriticar Offline
Junior Member
Posts: 13
Joined: Mar 2014
Reputation: 0
Post: #2826
(2014-05-17 15:26)fritsch Wrote:  Skins should be fix, when this one goes in: https://github.com/xbmc/xbmc/pull/4731

But yeah - Alpha window has started.

Looks like Amber skin has updated and now the problem has gone.
all I can say is that I am still veeery satisfied with this howto. Big Grin

Regards.
find quote
mochour Offline
Junior Member
Posts: 23
Joined: Jan 2014
Reputation: 0
Post: #2827
Hi,

I face everyday crashes of xbmc with xbmc_crashlog always ending with following entries:

17:11:58 T:140116655859456 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
17:29:24 T:140118224725952 WARNING: Previous line repeats 9774 times.
17:29:24 T:140118224725952 NOTICE: CVDPAU::OnResetDevice event
17:29:24 T:140116655859456 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
17:29:25 T:140116639074048 WARNING: Previous line repeats 3 times.
17:29:25 T:140116639074048 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer

It seems like misconfigured ALSA, but I can not figure out what is wrong. In the dmesg there are complaints on ELD, but I do not see connection.

[390369.833375] [drm] ib test on ring 5 succeeded
[390370.112938] HDMI ATI/AMD: no speaker allocation for ELD
[390370.413390] HDMI ATI/AMD: no speaker allocation for ELD
[390370.714008] HDMI ATI/AMD: no speaker allocation for ELD
[390371.014448] HDMI ATI/AMD: no speaker allocation for ELD
[390371.314966] HDMI ATI/AMD: no speaker allocation for ELD
[390371.615491] HDMI ATI/AMD: no speaker allocation for ELD
[390371.915992] HDMI ATI/AMD: no speaker allocation for ELD
[390372.216505] HDMI ATI/AMD: no speaker allocation for ELD

Can anyone help me with the issue?
Thanks
M
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,444
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #2828
Provide what the howto wants. I will silently ignore such posts in the future.
find quote
Jan0sh Offline
Member
Posts: 59
Joined: Jun 2011
Reputation: 0
Post: #2829
(2014-05-19 18:04)mochour Wrote:  Hi,
[...]
Can anyone help me with the issue?
Thanks
M

Do post the required logfiles from post one.
Do not truncate logfiles.

Are the files you played saved localy or streamed?
find quote
mochour Offline
Junior Member
Posts: 23
Joined: Jan 2014
Reputation: 0
Post: #2830
xbmc@galadriel:~$ dmesg | pastebinit
http://paste.ubuntu.com/7489960/
xbmc@galadriel:~$ cat ~/.xbmc/temp/xbmc.log | pastebinit
http://paste.ubuntu.com/7489967/
xbmc@galadriel:~$ cat /var/log/Xorg.0.log | pastebinit
http://paste.ubuntu.com/7489968/
xbmc@galadriel:~$ DISPLAY=:0 vdpauinfo | pastebinit
http://paste.ubuntu.com/7489971/
xbmc@galadriel:~$ cat xbmc_crashlog-20140519_172926.log | pastebinit
http://paste.ubuntu.com/7489975/
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,444
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #2831
Not a Debug Log - but try with the kernel I linked in the second post (at the end).
find quote
mochour Offline
Junior Member
Posts: 23
Joined: Jan 2014
Reputation: 0
Post: #2832
(2014-05-19 18:09)Jan0sh Wrote:  
(2014-05-19 18:04)mochour Wrote:  Hi,
[...]
Can anyone help me with the issue?
Thanks
M

Do post the required logfiles from post one.
Do not truncate logfiles.

Are the files you played saved localy or streamed?

The files are played localy, but I think that major problem is with TV broadcasting, using vdr 2.0.3 and following plugins:
ii vdr-plugin-vnsiserver 1:0.9.4-14trusty amd64 VDR-Network-Streaming-Interface - PVR API:1.9.0
ii xbmc-pvr-vdr-vnsi 1.9.8-14trusty amd64 XBMC PVR Addon VDR Vnsi - PVR API:1.9.0

(2014-05-19 21:49)fritsch Wrote:  Not a Debug Log - but try with the kernel I linked in the second post (at the end).

As the crash happens once a day I'll switch debug on and post the log tomorrow.

(2014-05-19 21:49)fritsch Wrote:  Not a Debug Log - but try with the kernel I linked in the second post (at the end).

I already tried the kernel that fritch suggested, but with no success. Same problems as with current one 3.13.11-03131102-generic.

Anzway, I'll install the kernel again and enable debug mode during tomorrow.
(This post was last modified: 2014-05-19 22:00 by mochour.)
find quote
mochour Offline
Junior Member
Posts: 23
Joined: Jan 2014
Reputation: 0
Post: #2833
Hi,

I'v updated kernel to 3.14.2-amdfixes5+ and switch debug on. Here is the result, hopefully helps.

Regards
H

xbmc@galadriel:~$ cat xbmc_crashlog-20140520_130708.log | pastebinit
http://paste.ubuntu.com/7493141/
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,444
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #2834
sudo apt-get install gdb

then we should get a backtrace

Quote:13:06:06 T:140140722763520 WARNING: Previous line repeats 908 times.
13:06:06 T:140140722763520 DEBUG: CVideoReferenceClock: Received RandR event 89
13:06:06 T:140140722763520 DEBUG: CVideoReferenceClock: Detected refreshrate: 0 hertz
13:06:07 T:140140622116608 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer

I suggest updating to the fernetmenta ppa mentioned in the first post or at least on 13.1b2 ... which fixes some of those issues.
find quote
mochour Offline
Junior Member
Posts: 23
Joined: Jan 2014
Reputation: 0
Post: #2835
Ok. All is done.

xbmc@galadriel:~$ type gdb
gdb is /usr/bin/gdb


ii xbmc 2:13.1~git20140519.0730-gotham~beta2-0trusty all XBMC Media Center (arch-independent data package)
ii xbmc-bin 2:13.1~git20140519.0730-gotham~beta2-0trusty amd64 XBMC Media Center (binary data package)

Should I switch the debug on again?
(This post was last modified: 2014-05-20 17:52 by mochour.)
find quote
Post Reply