Linux - Radeon OSS with vdpau (howto)

  Thread Rating:
  • 19 Votes - 4.79 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
tomtomme Offline
Member
Posts: 55
Joined: Feb 2012
Reputation: 0
Post: #2206
from first post:
Quote:- The same speed as with the fglrx implementation (currently awaiting rebuild - should be in 10.0.3 + patch)

sounds great Smile
but what does "+patch" mean here? Is this included in mesa 10.0.3 or 10.1 or 10.2? If not where can non-ubuntu users find this patch?
and which "rebuild"? Of mesa or gotham and when will it be rebuild?

sry if I am too impatient Angel


and for the openSUSE HowTo another small update, see:
http://forum.xbmc.org/showthread.php?tid...pid1546145

##### Recent CHANGES ######
- removed vlc repo as it was only needed for libdvdcss2, that can better be downloaded seperately from the added links to avoid mixing vlc and packman repos
- tumbleweed mesa repo (vovochka404) now on 10.1
- do "sudo zypper dup" after every repo change or if you want regular updates (do not use apper in combo with tumbleweed), and recompile xbmc from the new branch (new code below) to get the beta
######################

Fusion E-350, 4 GB RAM, SSD, openSUSE Tumbleweed 64bit KDE, Mesa-10.1, Kernel 3.13, XBMC FernetMenta-Git
(This post was last modified: 2014-03-08 14:58 by tomtomme.)
find quote
adolchristin Offline
Junior Member
Posts: 19
Joined: Feb 2012
Reputation: 0
Post: #2207
I'd just like to thank all the devs for their hard work; I've got radeon + mesa + vdpau + xbmc gotham beta 99% functional! My last little issue is that when I stop a video xbmc when using vdpau hardware acceleration xbmc crashes. If I switch to software rendering everything is fine. I'm running xbmc through xinit so it immediately restarts but I'd still like to correct this issue. Below are pastes to all the relevant information I could think of. If more is needed just let me know and I'll provide it.

dmesg - http://bpaste.net/show/186571/
cat /var/log/Xorg.0.log - http://bpaste.net/show/186572/
vdpauinfo - http://bpaste.net/show/186573/
pacman -Qi mesa-git - http://bpaste.net/show/186574/
pacman -Qi xbmc-devel - http://bpaste.net/show/186581/
cat ~/.xbmc/temp/xbmc.old.log - http://bpaste.net/show/186576/
cat ~/.xbmc/temp/xbmc.log - http://bpaste.net/show/186577/
cat ~/xbmc_crashlog-20140308_142435.log - http://bpaste.net/show/186579/
uname -a - http://bpaste.net/show/186580/

Edit: I actually just found this in my dmesg and it doesn't seem to be in the one I pasted above:

[ 3119.106484] traps: xbmc.bin[1658] trap invalid opcode ip:7fbf44159770 sp:7fffa4845f38 error:0

The above seems to correpsond to the crash.
(This post was last modified: 2014-03-09 21:49 by adolchristin.)
find quote
deivid Offline
Junior Member
Posts: 13
Joined: Feb 2014
Reputation: 0
Post: #2208
When I play files, sometimes the video signal is lost for 1 second ('No signal' displays on tv, but show continues playing) then fixes itself. Kind of annoying for some files (TV can take up to 5 seconds to 'discover' HDMI signal) because I have to stop it and start it (if something happens)
Any clue?
http://paste.ubuntu.com/7058038/
http://paste.ubuntu.com/7058037/
http://paste.ubuntu.com/7058039/
http://paste.ubuntu.com/7058040/

Btw: debug.sh
Code:
#!/bin/bash
dmesg | pastebinit > "log" &
cat ~/.xbmc/temp/xbmc.log | pastebinit >> "log" &
cat /var/log/Xorg.0.log | pastebinit>> "log" &
DISPLAY=:0 vdpauinfo | pastebinit>> "log" &
dpkg -l |grep mesa | pastebinit>> "log" &
echo "Wait, then check log file"
wait

EDIT: Do I need to add another repo for the kernel? (Currently running my own 3.13, but I can see only 3.11 on the repos)
(This post was last modified: 2014-03-08 23:17 by deivid.)
find quote
nmsaraujo Offline
Junior Member
Posts: 3
Joined: Oct 2013
Reputation: 0
Post: #2209
Hello all,

currently I am running XBMC over ASUS E45M1-Deluxe, that I use as HTPC, with LiveTV, with TVHeadend.

Everything works ok, except a few tv channels that I can not watch, because I can only see green squares. I can not find a relationship between the channel enconding, or any other thing. In fact, if I run XBMC on windows8.1, I can watch this channels without issues, what leaves to think that this may be related with the codec that XBMC is using.

Does someone already experienced(and get a solution) for something like this?

Thank you all for your attention and good job.

DMESG: http://paste.ubuntu.com/7057930/
FILE xbmc.log: http://paste.ubuntu.com/7057932/
FILE Xorg.0.log: http://paste.ubuntu.com/7057934/
VDPAUINFO: http://paste.ubuntu.com/7057935/
MESA PKGS: http://paste.ubuntu.com/7057936/
ERROR LOG, WHEN PLAYING CHANNEL: http://paste.ubuntu.com/7057961/
(This post was last modified: 2014-03-09 19:24 by nmsaraujo.)
find quote
polo_joe Offline
Junior Member
Posts: 5
Joined: Aug 2012
Reputation: 0
Post: #2210
I'm testing latest openelec beta 3.95.1 on fusion e350.

I have micro video stutters with 1080i50 livetv and with 720p50 as well. Audio is also stuttering.

http://sprunge.us/ASfe

Any hints?
find quote
fritsch Offline
Team-XBMC Developer
Posts: 4,371
Joined: Aug 2011
Reputation: 109
Location: Karlsruhe
Post: #2211
I will be offline until start of next week. So - if you don't get replies - this thread is not dead - just got caught by real life :-) You can meet me at cebit in Hannover.
find quote
Kamerat Offline
Junior Member
Posts: 5
Joined: Oct 2012
Reputation: 0
Location: Oslo
Post: #2212
(2013-12-11 17:16)johnodon Wrote:  Looking for some guidance...

I have followed the guide on the first page to the letter, but, I am doing all of this in an ESXi VM with PCI passthrough (Radeon HD6450). The issue I am having is that all output is still being sent to the VMware graphic adapter (ESXi console) rather than the Radeon card (TV). As far as I can tell, both modules are being loaded but the default video adapter is set to the virtual one.

FYI...XBMCbuntu works out of the box in an ESXi VM. The main install menu is sent to the ESXi console but all subsequent output is piped to the Radeon card once you select to Install XBMCbuntu.

Any thoughts?

...

Didn't see your post before now. Sad XBMCbuntu is working out of the box because it's using Catalyst. To get the OSS driver working you have to patch the kernel so it can load your graphic card bios of your harddrive: https://communities.vmware.com/message/2326762#2326762
find quote
laric Offline
Donor
Posts: 95
Joined: May 2012
Reputation: 1
Post: #2213
...
(This post was last modified: 2014-03-11 12:52 by laric.)
find quote
phlepper Offline
Junior Member
Posts: 2
Joined: May 2010
Reputation: 0
Post: #2214
Just wanted to say "Thanks!"

I followed the instructions last night to set up Radeon with my Zotac Nano AD10 (with Radeon HD 6310). Worked perfectly. Note the only variation was that I installed Gotham via xbmc-team/unstable versus the instructions...

I couldn't get qvdpauinfo output to work as referenced in the debugging section. But now that I'm re-reading, I think that was a typo and should be "qvdpautest" versus info?

I'll try that tonight (at work now). But via the 'o' option while playing video, I can clearly see that it is using hardware acceleration and my two cores are running around 40% during 1080i playback.

I did not change anything for the de-interlacing (yet). Should I? I see information about using Bob, Weave, and Temporal, but I really don't know the difference and when I should use this (or which one)? Any thoughts would be appreciated.

Great work on the instructions!

Thanks,
phlepper
find quote
Endeavour79 Offline
Junior Member
Posts: 31
Joined: Oct 2013
Reputation: 0
Location: Sydney, Australia
Post: #2215
I am running on Zotac AD12 and didn't need to change anything, Follow the instructions and you should be good.
find quote
gfisher Offline
Senior Member
Posts: 193
Joined: Feb 2012
Reputation: 3
Post: #2216
@phlepper
Play the 1080i vid, move mouse to get timeline.
Click movie reel.
At menu set deinterlace >> auto,
Method >> temporal
Scroll down, set default for all vids.
Temporal is motion adaptive deinterlacing from what I read. PQ is quite nice. Bob is lower quality, but if your GPU chokes try that.
find quote
tomn Offline
Junior Member
Posts: 10
Joined: Dec 2013
Reputation: 0
Post: #2217
Hi,

Im currently using the Alpha version from the wsnipex/xbmc-fernetmenta-master' PPA and want to upgrade to the latest beta But im not sure what PPA to use:

do i need ppa:team-xbmc/unstable or do i still need to use ppa:wsnipex/xbmc-fernetmenta-master

Thanks!
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 2,689
Joined: Jul 2010
Reputation: 55
Location: Munich
Post: #2218
You would downgrade. wsnipex/xbmc-fernetmenta-master is 14.0 alpha
find quote
tomn Offline
Junior Member
Posts: 10
Joined: Dec 2013
Reputation: 0
Post: #2219
thanks for your reply, ppa:team-xbmc/unstable it is!
find quote
adolchristin Offline
Junior Member
Posts: 19
Joined: Feb 2012
Reputation: 0
Post: #2220
So I've been debugging a bit more and it appears that with vdpau radeon and arch linux 64 xbmc will crash if I stop playback. If i allow the video to end without stopping there is no crash. Is anyone else seeing this issue? I'm using xbmc-beta from AUR which is built from Gotham Beta1.
find quote
Post Reply