External HDD doesn't remount with boot up

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
ArtVandalay7 Offline
Senior Member
Posts: 102
Joined: Sep 2009
Reputation: 0
Post: #1
Hello! Recently made the jump from XBMC on Xbox to Linux-based HTPC and am loving it! My main problem is I have a 2 TB external HD plugged directly into a USB port on the back of the media center (Silverstone Micro ATX case) and it will not see the drive on startup without me power cycling the drive. Any ideas as to why XBMC can't see the drive? (Drive is powered on). Thanks for any help!
find quote
mayoman Offline
Fan
Posts: 455
Joined: Dec 2012
Reputation: 14
Post: #2
Linux issue, not XBMC. You need to force Linux to mount it on startup.
How to depends on the Linux distro and version you are running.
For Example, I'm running Lubuntu 12.10. In this case in the Lubuntu desktop go to settings -> disk. Select the USB drive (assuming its mounted at the time). Clicking on the "more actions" (Gears) icon gives me the option to force mount it on startup.
find quote
ArtVandalay7 Offline
Senior Member
Posts: 102
Joined: Sep 2009
Reputation: 0
Post: #3
I can't seem to find that...I'm running 12.10 as well...
(This post was last modified: 2013-10-05 20:17 by ArtVandalay7.)
find quote
mayoman Offline
Fan
Posts: 455
Joined: Dec 2012
Reputation: 14
Post: #4
Sorry, I'm not using an English language desktop so I translated/guessed incorrectly...Blush
"Settings" described above should be "Preferences" -> then to drives or disks

Though I just did a check here with a USB drive and it mounted automatically on boot for me...
find quote
doug piston Offline
Junior Member
Posts: 47
Joined: Sep 2013
Reputation: 1
Post: #5
http://myubuntublog.wordpress.com/2009/0...e-at-boot/
find quote
ArtVandalay7 Offline
Senior Member
Posts: 102
Joined: Sep 2009
Reputation: 0
Post: #6
I have no experience with Linux before building the media center so the code is a little above my head for the moment. I went into XBMCbuntu and Ubuntu desktops and I couldn't find any setting to mount the drive, however...
find quote
uNiversal Offline
Out of Memory
Posts: 5,434
Joined: Oct 2012
Reputation: 136
Location: Binary pulsar
Post: #7
try this http://forum.xbmc.org/showthread.php?tid...pid1221362
find quote