Support Thread for MediaCodec

  Thread Rating:
  • 4 Votes - 3.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,479
Joined: Feb 2008
Reputation: 64
Post: #31
so... I assume that MediaCodec is working now ?


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Memphiz Offline
Team-XBMC Developer
Posts: 10,621
Joined: Feb 2011
Reputation: 112
Location: germany
Post: #32
Didn't test it latly but you remember the issue i've got with my ainol novo7 crystal 2? (iirc there was a render format missing half planar yuv2 or something). So i guess this might be still a issue ... (can't test atm)

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
ibazzi Offline
Junior Member
Posts: 8
Joined: Nov 2012
Reputation: 0
Post: #33
(2013-10-21 09:36)davilla Wrote:  so... I assume that MediaCodec is working now ?

Try the latest nightly build, MediaCodec works perfect.

Thanks for the great job.Big Grin
find quote
dhead Offline
Donor
Posts: 601
Joined: May 2010
Reputation: 2
Post: #34
Is this thread missing clarification at the first post, which SOC doesn't support MediaCodec hw rendering ? (Allwinner? Amlogic?), or maybe al SOC should support it ?
I'm guessing that disabling MediaCodec hw rendering in XBMC settings will enable MediaCodec sw rendering and this is supported by all SOC.

Please correct me if wrong and add it to the first post so users would know what devices to test and attached their logs as I feel this currently not clear enough.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,479
Joined: Feb 2008
Reputation: 64
Post: #35
(2013-10-21 10:07)Memphiz Wrote:  Didn't test it latly but you remember the issue i've got with my ainol novo7 crystal 2? (iirc there was a render format missing half planar yuv2 or something). So i guess this might be still a issue ... (can't test atm)

nv12 was added, if you need yuv2 or some other flavor, let me know the details. It's running a whitelist for surface render, everything else goes via GLES rendering.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,479
Joined: Feb 2008
Reputation: 64
Post: #36
(2013-10-21 15:19)dhead Wrote:  Is this thread missing clarification at the first post, which SOC doesn't support MediaCodec hw rendering ? (Allwinner? Amlogic?), or maybe al SOC should support it ?
I'm guessing that disabling MediaCodec hw rendering in XBMC settings will enable MediaCodec sw rendering and this is supported by all SOC.

Please correct me if wrong and add it to the first post so users would know what devices to test and attached their logs as I feel this currently not clear enough.

MediaCodec has been changed to always do hw decode, gles render for all devices not qualified for surface rendering. Right now, the only device that qualifies for surface rendering is any NVidia T3 or above. There is no way for users to alter the whitelist except by building from source. This is by design as only those that can build and install can retrieve the logcat needed for close examination.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
pmoreira1 Offline
Junior Member
Posts: 10
Joined: Jun 2013
Reputation: 0
Post: #37
Just tried the nightlie xbmc-20131020-96410e2-master-armeabi-v7a in a stock 4.2.2 ROM in MK809II and it works perfectly.
In a full 1080p movie only 22 drop frames. I will keep on testing and giving my feedback.
Keep up the good work.
find quote
dhead Offline
Donor
Posts: 601
Joined: May 2010
Reputation: 2
Post: #38
Thanks Davilla, that clear it.
find quote
Koying Online
Team-XBMC Member
Posts: 1,801
Joined: Sep 2008
Reputation: 36
Location: Brussels, Belgium
Post: #39
As discussed, this is what you get with a qpel/gmc mp4 on nvidia: http://pastebin.com/bj8sQVcp
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,479
Joined: Feb 2008
Reputation: 64
Post: #40
sample ?


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Koying Online
Team-XBMC Member
Posts: 1,801
Joined: Sep 2008
Reputation: 36
Location: Brussels, Belgium
Post: #41
http://www.auby.no/files/video_tests/xvi...matrix.mkv
find quote
Koying Online
Team-XBMC Member
Posts: 1,801
Joined: Sep 2008
Reputation: 36
Location: Brussels, Belgium
Post: #42
Crash on Minix X7 sw: http://pastebin.com/E6nJd7wz
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,479
Joined: Feb 2008
Reputation: 64
Post: #43
that one is very odd


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
arghness Offline
Junior Member
Posts: 11
Joined: Nov 2013
Reputation: 0
Post: #44
With MediaCodec enabled on a Galaxy S3 (i9300 with Samsung stock Android 4.1.2), I get a green bar at the bottom of the screen and "shadows" of the image in other places on the screen with a few videos. It doesn't crash though.

One such example video is http://download.wavetlan.com/SVV/Media/H...w11222.mp4 and the issue that I see is visible here: http://tinypic.com/r/106bn8o/5

This decodes okay with MediaCodec disabled (I'm not sure if it's using libstagefright or just using software), and also with hardware decoding on DicePlayer for Android.
find quote
s7mx1 Offline
Senior Member
Posts: 264
Joined: Dec 2007
Reputation: 4
Post: #45
MediaCodec missing NV12 64x32 tiled color format support

http://forum.xbmc.org/showthread.php?tid=178324
find quote
Post Reply