RaspBMC Kodi/XBMC test builds

  Thread Rating:
  • 12 Votes - 4.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
feuille_de_lune Offline
Junior Member
Posts: 35
Joined: Jul 2014
Reputation: 0
Post: #1426
(2014-09-10 20:21)miappa Wrote:  Updated Helix build, Kodi/XBMC master from Sep 10 + newclock4 commits.

Kodi/XBMC Master:
Master changelog

Newclock4 additions:
• [egl] Treat unknown display aspect ratio as square pixel
• [dvdplayer] Fix for timestamp correction when no audio or no video
• Squash: don't update originaldts when marked as invalid
• Fix wrongly used CFile::Exists() for directories instead of CDirectory::Exists()
• [posix] Implement new PosixFile (alternative)

GPU firmware from Sep 10 included:
• Add config option hdmi_blanking to allow hdmi output to be disabled when framebuffer is blanked
• Keep built files out of source tree to avoid tainted builds

To install Kodi/XBMC build, SSH to Pi:
Code:
wget -O kodi-14-20140910-nc4.tar.gz http://goo.gl/3IXgVJ --no-check-certificate
pv kodi-14-20140910-nc4.tar.gz | tar xzf - -C /home/pi/.upgrade
sudo cp /home/pi/.upgrade/kodi-14-20140910-nc4/{fixup_x.dat,start_x.elf} /boot
ln -sfn /home/pi/.upgrade/kodi-14-20140910-nc4/xbmc-bcm /home/pi/.xbmc-current
sudo reboot

I failed a boot because a failed NFS mount. I tried to play some media with dvdplayer (hifiberry digi inside). And I have 2 problems.
-> no passthrough on my optical output
-> video freeze quite quickly. No input work (nor keyboard neither remote apps). It just comes faster with HD content (about 5 minutes in SD and about 5 seconds in HD)

there are logs when it freezes :
Code:
22:31:30 9901.721680 T:2790065216  NOTICE: Creating InputStream
22:31:30 9901.799805 T:2790065216  NOTICE: Creating Demuxer
22:31:35 9906.922852 T:2790065216  NOTICE: Opening stream: 0 source: 256
22:31:35 9906.922852 T:2790065216  NOTICE: Creating video codec with codec id: 13 720x304
22:31:35 9906.936523 T:2764178496  NOTICE: Thread VideoReferenceClock start, auto delete: false
22:31:35 9906.936523 T:2790065216  NOTICE: Creating video thread
22:31:35 9906.937500 T:2790065216  NOTICE: Opening stream: 1 source: 256
22:31:35 9906.937500 T:2790065216  NOTICE: Finding audio codec for: 86017
22:31:35 9906.938477 T:2790065216  NOTICE: Creating audio thread
22:31:35 9906.947266 T:2747401280  NOTICE: Thread DVDPlayerAudio start, auto delete: false
22:31:35 9906.947266 T:2747401280  NOTICE: running thread: CDVDPlayerAudio::Process()
22:31:35 9906.947266 T:2755789888  NOTICE: Thread DVDPlayerVideo start, auto delete: false
22:31:35 9906.948242 T:2755789888  NOTICE: running thread: video_thread
22:31:35 9906.950195 T:2747401280  NOTICE: Creating audio stream (codec id: 86017, channels: 2, sample rate: 48000, no pass-through)
22:31:35 9906.968750 T:2755789888  NOTICE:  fps: 23.976024, pwidth: 720, pheight: 304, dwidth: 720, dheight: 304
22:31:35 9906.969727 T:2755789888  NOTICE: Display resolution DESKTOP : 1920x1080 (1920x1080) @ 24.00 - Full Screen (16)
22:37:09 10240.740234 T:2747401280   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
22:37:25 10256.471680 T:3038195712   ERROR: Previous line repeats 9 times.
22:37:25 10256.471680 T:3038195712  NOTICE: CDVDPlayer::CloseFile()
22:37:25 10256.471680 T:3038195712  NOTICE: DVDPlayer: waiting for threads to exit
22:37:25 10256.480469 T:2790065216  NOTICE: CDVDPlayer::OnExit()
22:37:25 10256.481445 T:2790065216  NOTICE: Closing stream player 1
22:37:25 10256.481445 T:2790065216  NOTICE: Waiting for audio thread to exit
22:37:25 10256.658203 T:2747401280  NOTICE: thread end: CDVDPlayerAudio::OnExit()
22:37:25 10256.659180 T:2790065216  NOTICE: Closing audio device
22:37:26 10257.662109 T:2790065216  NOTICE: Deleting audio codec
22:37:26 10257.663086 T:2790065216  NOTICE: Closing stream player 2
22:37:26 10257.663086 T:2790065216  NOTICE: waiting for video thread to exit
find quote
miappa Offline
Posting Freak
Posts: 925
Joined: Dec 2012
Reputation: 73
Post: #1427
Latest build (and previous builds too) runs very well for me on my 2 Pi´s so my guess is that your problems are specific to your setup.
Perhaps the hifiberry, but it could be something else too.
Have you tried without the hifiberry and see if that works better?
If you still have problems without the hifiberry, first thing to check is the voltage.

Also, always post full logs and always enable debug logging.
And do not paste logs here, use a pastebin site and post link here.
find quote
feuille_de_lune Offline
Junior Member
Posts: 35
Joined: Jul 2014
Reputation: 0
Post: #1428
(2014-09-12 11:13)miappa Wrote:  Latest build (and previous builds too) runs very well for me on my 2 Pi´s so my guess is that your problems are specific to your setup.
Perhaps the hifiberry, but it could be something else too.
Have you tried without the hifiberry and see if that works better?
If you still have problems without the hifiberry, first thing to check is the voltage.

Also, always post full logs and always enable debug logging.
And do not paste logs here, use a pastebin site and post link here.

It plays well with omxplayer. When I want to use dvdplayer, I force it via GUI settings. Smile
I don't think that it's a voltage problem because I don't have to reboot RPI, just restart XBMC application. I'll do some debug mode at home this evening.
Other information, my NFS mount (system level) is seen by Kodi application as a local storage.
find quote
miappa Offline
Posting Freak
Posts: 925
Joined: Dec 2012
Reputation: 73
Post: #1429
Oh, forgot to mention, the one Pi I tested DVDPlayer after your test on the previous build has been using DVDPlayer as default since then, so it does work for me.
But I don´t use passthrough or hifiberry.
Do some testes with and without hifiberry (and with passtrhoughenabled/disabled), always a start.
(This post was last modified: 2014-09-12 11:25 by miappa.)
find quote
feuille_de_lune Offline
Junior Member
Posts: 35
Joined: Jul 2014
Reputation: 0
Post: #1430
I'll take some time to do that. I hope to do something complete. Too many things to do in a few days.
I'll do this as fast as I can.
find quote
miappa Offline
Posting Freak
Posts: 925
Joined: Dec 2012
Reputation: 73
Post: #1431
Updated Helix build, Kodi/XBMC master from Sep 10 + newclock4 commits.

Kodi/XBMC Master:
• Same as last build

Newclock4 additions:
Disable textbox autoscrolling while on screensaver
• [mmal] Add MMAL decoder and MMAL renderer for Raspberry Pi
• [mmal] Allow mmal codec for dvd stills
• [mmal] Add AC_SUBST

GPU firmware from Sep 10 included

Regarding mmal and openmax, explained by popcornmix:
Quote:I've created a PR for the dvdplayer/mmal acceleration. Probably too late for Helix, but you never know.
This was provoked by the resurrection of the openmax acceleration to support tegra (https://github.com/xbmc/xbmc/pull/5348).

I had been hijacking that (with permission from davilla who considered it dead) for the current mmal acceleration.
This meant I had to go through renaming files and adding new make variables, defines and format enums.

So upshot is we now call accelerated dvdplayer "mmal acceleration" rather than "openmax acceleration", and there's a small chance that something will have broken in the process.

To install Kodi/XBMC build, SSH to Pi:
Code:
wget -O kodi-14-20140912-nc4.tar.gz http://goo.gl/x7yccg --no-check-certificate
pv kodi-14-20140912-nc4.tar.gz | tar xzf - -C /home/pi/.upgrade
sudo cp /home/pi/.upgrade/kodi-14-20140912-nc4/{fixup_x.dat,start_x.elf} /boot
ln -sfn /home/pi/.upgrade/kodi-14-20140912-nc4/xbmc-bcm /home/pi/.xbmc-current
sudo reboot

See post #1 for more info
(This post was last modified: Today 18:56 by miappa.)
find quote
eikman2k Offline
Junior Member
Posts: 14
Joined: Feb 2013
Reputation: 0
Post: #1432
Use the Latest Version 12.09.2014 but after some Time I Play HD Movies The Audio Stops anf then the Movie Freezes, and my Pi reakts on nothing, need Hardreset

Is there any Solution for this Problem?
find quote
miappa Offline
Posting Freak
Posts: 925
Joined: Dec 2012
Reputation: 73
Post: #1433
Updated Helix build, Kodi/XBMC master from Sep 18 + newclock4 commits.

Kodi/XBMC Master:
Master changelog
[ffmpeg] bump to 2.4

Newclock4 additions:
• Disable textbox autoscrolling while on screensaver: updated to only affect Dim and Black
• [mmal] squash: UnInit before second configuration
• [PiSink] Initial dual audio support
• [omxplayer] Only enable audio clock master when A/V sync method is set to audio clock
• [rbp] Enable vsync handler all the time

GPU firmware from Sep 16 included:
See here
+ fix for missing files


To install Kodi/XBMC build, SSH to Pi:
Code:
wget -O kodi-14-20140918-nc4.tar.gz http://goo.gl/jvrgR6 --no-check-certificate
pv kodi-14-20140918-nc4.tar.gz | tar xzf - -C /home/pi/.upgrade
sudo cp /home/pi/.upgrade/kodi-14-20140918-nc4/{fixup_x.dat,start_x.elf} /boot
ln -sfn /home/pi/.upgrade/kodi-14-20140918-nc4/xbmc-bcm /home/pi/.xbmc-current
sudo reboot

See post #1 for more info
find quote
Post Reply