RaspBMC Kodi/XBMC test builds

  Thread Rating:
  • 12 Votes - 4.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
henryperu77 Offline
Junior Member
Posts: 13
Joined: Jan 2013
Reputation: 0
Post: #1456
the m3u refresh all the time, witht the new url of the .ts files
find quote
Milhouse Online
Team-Kodi Member
Posts: 4,067
Joined: Jan 2011
Reputation: 92
Post: #1457
Obviously I'm testing them wrong and have no idea what I'm doing, I'll give up then. Smile

Edit: I'd originally downloaded the m3u and had been testing that. Testing with the m3u url in VLC still results in video and intermittent audio - lots of "lost" audio buffers according to the codec statistics dialog. There is frequent stuttering/buffering of video (20Mb/s connection).

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: Today 02:44 by Milhouse.)
find quote
henryperu77 Offline
Junior Member
Posts: 13
Joined: Jan 2013
Reputation: 0
Post: #1458
ahh? are you being sarcastic? :O I really need some help Sad
find quote
Milhouse Online
Team-Kodi Member
Posts: 4,067
Joined: Jan 2011
Reputation: 92
Post: #1459
(Today 02:41)henryperu77 Wrote:  ahh? are you being sarcastic? :O I really need some help Sad

No not really Smile I don't use video ts streams so don't really know how they work!

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
henryperu77 Offline
Junior Member
Posts: 13
Joined: Jan 2013
Reputation: 0
Post: #1460
you said its maybe a ffmpeg 2.4.1 problem..., it is possible to update it on raspbmc? and use the one included on kodi for windows..
find quote
Milhouse Online
Team-Kodi Member
Posts: 4,067
Joined: Jan 2011
Reputation: 92
Post: #1461
OK I've had another go at this....

I created a file called "test.m3u" and pasted the url location of the first m3u (https://ott.totalplay.com.mx/TPHLSWeb/M3...40&f=.m3u8), so that the file contains just the url.

If I now play this file using all acceleration options (omx-h264 is shown in the Codec OSD) it plays absolutely fine in OpenELEC #1001 - continuous smooth streaming of audio and video.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
henryperu77 Offline
Junior Member
Posts: 13
Joined: Jan 2013
Reputation: 0
Post: #1462
So its a raspbmc problem :O
find quote
miappa Offline
Posting Freak
Posts: 935
Joined: Dec 2012
Reputation: 73
Post: #1463
(Today 03:18)henryperu77 Wrote:  So its a raspbmc problem :O

Probably not.
I have tested this with Kodi on three different platforms (OSX, iOS and Raspbmc) and they all behave the same for me (plays ≈4 seconds of each).
It did behave somewhat better with VLC, but the sources doesn´t seem to be very good though.

I also tried wha Milhouse tested last (and I oly pasted the URL, nothing else) and it did NOT work for me on iOS and OSX (plays ≈4 seconds). Not at home so cannot test on Raspbmc now, but Im pretty sure it will behave the same.
All tested on latest nightly.

If anyone is interested, here is a debug log from OSX playing the m3u that henryperu77 provided, then my own test-m3u with only 1 URL in it: http://pastebin.com/8s6ygaRj

Anyway, I see the problem, but on several platforms... however I have no idea if the problem is the m3u´s, the sources or Kodi(?).
find quote
Post Reply