XBMC v12.2 crashing on OS X 10.9 Mavericks

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Memphiz Offline
Team-XBMC Developer
Posts: 10,673
Joined: Feb 2011
Reputation: 112
Location: germany
Post: #76
http://forum.xbmc.org/showthread.php?tid...pid1567022 <- try this.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
volcom45 Offline
Junior Member
Posts: 7
Joined: Oct 2013
Reputation: 0
Post: #77
(2013-12-10 20:34)Memphiz Wrote:  http://forum.xbmc.org/showthread.php?tid...pid1567022 <- try this.

Does this need to be installed fresh? I'm getting all sorts of dependancy errors and can't seem to get into mashup or any of the places I was running into these issues.. I'll keep trying a few more things and report back, looking at that thread, that looks exactly like my issues and you have me very hopeful! Smile
Thx for the reply, Memphiz!

Update: Oh man Memphiz, I did a fresh install with this build you pointed me at and all is well! For the first time, all the 1080 titles that were all glitches are playing perfectly normal! You are absolutely the man!! Smile Thanks so much for helping figure this out, it's been driving me crazy. Will this change be pushed out soon to the nightly x64 build? It sure gets a green light from me and confirmation that graphics issues are resolved. Thank you thank you!!
(This post was last modified: 2013-12-11 05:37 by volcom45.)
find quote
Memphiz Offline
Team-XBMC Developer
Posts: 10,673
Joined: Feb 2011
Reputation: 112
Location: germany
Post: #78
Need some more feedback before this gets pushed to the nightlies. Keep it in the linked thread please so i don't need to run from thread to thread all the time ...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
trevezani Offline
Junior Member
Posts: 1
Joined: Dec 2013
Reputation: 0
Post: #79
The sound of upnp doesn't work in Mavericks.
find quote
Ned Scott Offline
Team-XBMC Wiki Guy
Posts: 19,922
Joined: Jan 2011
Reputation: 247
Location: Arizona, USA
Post: #80
(2013-12-17 04:03)trevezani Wrote:  The sound of upnp doesn't work in Mavericks.

Can you elaborate on what you mean?

You can make easy links to the XBMC wiki using double brackets around common XBMC words: [[debug log]] = debug log, [[Video library]] = Video library, [[SMB]] = SMB , [[userdata]] = userdata, etc
find quote
Gigantur Offline
Senior Member
Posts: 112
Joined: Dec 2012
Reputation: 0
Location: Melbourne, Australia
Post: #81
Sample.mkv now plays fine for me, without artifacts, on mavericks intel 2013 mac mini
find quote
dvandriesen Offline
Member
Posts: 58
Joined: Nov 2012
Reputation: 0
Post: #82
For what its worth after updating tonight to 10.9.1 that was pushed the mouse doesnt allow you to close out again or anything on the lower part of the screen. Just a heads up to all.
find quote
dvandriesen Offline
Member
Posts: 58
Joined: Nov 2012
Reputation: 0
Post: #83
Same with he 12/17 nightly cant stand stupid auto update on my mac the lastest was working for me it works just no mouse on the lower half.
find quote
Memphiz Offline
Team-XBMC Developer
Posts: 10,673
Joined: Feb 2011
Reputation: 112
Location: germany
Post: #84
@dvandriesen - mhhh are you sure? I can't reproduce the probelm on my 10.9.1 macmini.

What hardware do you use - does hitting cmd+f twice fix it? (e.x. going to windowed mode and back to fullscreen)

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
dvandriesen Offline
Member
Posts: 58
Joined: Nov 2012
Reputation: 0
Post: #85
@Memphiz 10.9.1 Hackintosh mini. On bring up of xbmc it comes in windowed mode and is white screen with tons of artifacts. If i do cmd+f goes full screen but cannot use the lower screen.

****Reinstalled the 12.3 DEC 1st fix again and seems to work could have been a bad install or some setting must have gotten changed after update.*******
(This post was last modified: 2013-12-19 03:16 by dvandriesen.)
find quote
turk6883 Offline
Junior Member
Posts: 1
Joined: Jan 2014
Reputation: 0
Post: #86
im running 10.9.1 on a macbook air and nomatter what i do xbmc will crash out, it was working but i had not added any add ons once i added mash up it just keeps crashing when i open it, i had installed a newer nightly version that was working, but i didnt have any of my addons now i have tried a couple of builds in this thread and i keep getting crash reports either as soon as it opens, or after clicking on an addon


i have a copy of the crash report i can send if it will help... this makes me really upset as i cant stream to my apple tv anymore and im having to use my windows machine... please help
find quote
Memphiz Offline
Team-XBMC Developer
Posts: 10,673
Joined: Feb 2011
Reputation: 112
Location: germany
Post: #87
post the crashreport and the xbmc.log to pastebin.com and put the links in here.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
jchou Offline
Junior Member
Posts: 2
Joined: Jan 2014
Reputation: 0
Post: #88
Hi guys, I am having a similar issue on Mavericks. I installed Mavericks then put the latest build (12.3 at the time) of XBMC on. It worked perfectly. When I was playing with the mac system preference display settings for the TV that was attached via my Mini DV port, XBMC quit and has never been able to start again. It starts to open, creates a long blank window for about 5-10 seconds then crashes with an error report. I have removed and reinstalled with the latest XBMC builds and still the same error. Here is the full error report: http://pastebin.com/LnNqaf5B

Quick synopsis of some of the error messages in the report:
Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x00007fff7aa72310 rcx: 0x00007fff5fbfed58 rdx: 0x0000000000000000
rdi: 0x0000000000000707 rsi: 0x0000000000000006 rbp: 0x00007fff5fbfed80 rsp: 0x00007fff5fbfed58
r8: 0x0000000000000003 r9: 0x0000000000000000 r10: 0x0000000008000000 r11: 0x0000000000000206
r12: 0x000000010bd30000 r13: 0x0000123441b1ba28 r14: 0x0000000000000006 r15: 0x000000010bd9f000
rip: 0x00007fff8ef57866 rfl: 0x0000000000000206 cr2: 0x00000001111a8000

Logical CPU: 0
Error Code: 0x02000148
Trap Number: 133

Please help if you can! Thank you.
find quote
gs_stark Offline
Junior Member
Posts: 2
Joined: Feb 2014
Reputation: 0
Post: #89
Hello! I having a same problem with Frodo version on Maverick. After start XBMC i see main menu about 4-5 sec. after that frodo is closing and i see the crash report http://pastebin.com/Z67tLaHM
I hope that help you.
Thx you for you work!
find quote
DruBoy Offline
Junior Member
Posts: 1
Joined: Feb 2014
Reputation: 0
Post: #90
I've dl the new xbmc version but mavericks is still not letting it run. it says "XBMC" can't be opened because it is from an unidentified developer. Help please
find quote
Post Reply