install awxi without XBMC interface

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
carltondraught Offline
Junior Member
Posts: 2
Joined: Nov 2013
Reputation: 0
Post: #1
Hi there,

I'm trying to get XBMC working on a Pi for music only, problem is i don't have a TV or monitor to use to drive the XBMC interface.

hence i'd like to use the awxi web interface from my laptop to configure and control the pi..

my question: is it possible to install AWXI without using the add-ons install interface in the actual program ? for example i have tried unzipping the addon into the addons dir but it never seems to get used by XBMC when it starts.

from what i understand i can't use X11 forwarding to see the XBMC interface.. is this true ?

any tips would be greatly appreciated,

cheers,

-ivan
find quote
Kabooga Offline
Senior Member
Posts: 232
Joined: Feb 2009
Reputation: 1
Location: Silicon Valley, CA
Post: #2
I think you will need to install the add-on through XBMC...sorry.

Messing around on my local desktop I could change the webinterface from awxi to default (and back) by changing the webskin element in the file guisettings (while XBMC was not running).

Code:
<webskin>webinterface.awxi</webskin>

File guisettings should be in XBMC's userdata folder.

This is a hack and may not work at all for you since awxi was not installed through XBMC already. But it is something you could try.

Regards,
Kabooga

I am an expert at acting like an expert ---- WC Fields.

XBMC Web Control Interface - https://github.com/mthiels/webinterface.xrc
find quote
carltondraught Offline
Junior Member
Posts: 2
Joined: Nov 2013
Reputation: 0
Post: #3
Hi there Kabooga, thanks for your response...

in fact i got it going in the end.. first i edited guisettings.xml and enabled the webserver

then i installed the AWXI plugin by downloading it directly from here:

http://ftp.sunet.se/pub/multimedia/xbmc/...face.awxi/

(can i say how difficult it is to find the direct download urls for plugins?)

and then i unzipped it to the add on dir, then using the trick described here:
http://forum.xbmc.org/showthread.php?tid...#pid628877

specfically:
sudo ln -s ~/.xbmc/addons/webinterface.awx/ /usr/share/xbmc/addons/webinterface.default/awx

then after restarting xmbc i could browse to http://<hostname>:8080/awx/ and it works !!

from there i can force a reload of the library so i don't need/never needed the normal gui.

awesome work by the XBMC mob !!!!

cheers
find quote
Kabooga Offline
Senior Member
Posts: 232
Joined: Feb 2009
Reputation: 1
Location: Silicon Valley, CA
Post: #4
Nice! Glad you got it working.

I am an expert at acting like an expert ---- WC Fields.

XBMC Web Control Interface - https://github.com/mthiels/webinterface.xrc
find quote