VDADecoder and Mavericks 10.9

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
BDPNA Offline
Fan
Posts: 447
Joined: Sep 2008
Reputation: 0
Post: #1
Even on the latest nightly, there's still non stop skipped frames on Mavericks 10.9 when I have VDADecoder turned on when playing MKV files.

Are there any logs from my Mac Mini that I can provide that might help, or are you devs buried in more detail than you can already stomach?

Is there anyone else here with a Mac Mini that is able to have VDADecoder hardware acceleration turned on under Mavericks and play MKV files without lots of dropped frames?
find quote
idioteque Offline
Fan
Posts: 407
Joined: Aug 2008
Reputation: 0
Post: #2
Running mavericks on mini late 2009

Vda is running Well like everything else

No problemen except Some music. Albums not showing up

MBP late 2009 - TimeCapsule 2TB - Harmony One+ - Readynas NV+ 8TB RAID5 - Mac Mini late 2009 with 10.9.0 and VDA - Panasonic TX-PG420ES -
find quote
BDPNA Offline
Fan
Posts: 447
Joined: Sep 2008
Reputation: 0
Post: #3
Guys I figured it out! Not sure why it took me so long to narrow it down.

This happens for any MKV movie file with a 1:85 ratio (1920x1080). Not as many films use this and that's why I wasn't seeing it often enough.

It does not happen for any MKV movie file with a 2:35 ratio (1920x800).

So the issue happens with any MKV video file with VDADecoder turned on that plays at 1920x1080 on my system. Tons of skipped frames.

Can anyone else test or confirm? I've checked the logs and tried different settings, no obvious errors being thrown out but turning off VDADecoder definitely enables the smooth playback for 1920x1080. Leaving it on and it's skipped frame city.

Hope this helps!
find quote
nmirza Offline
Fan
Posts: 330
Joined: Mar 2008
Reputation: 0
Post: #4
(2013-11-23 18:23)BDPNA Wrote:  Guys I figured it out! Not sure why it took me so long to narrow it down.

This happens for any MKV movie file with a 1:85 ratio (1920x1080). Not as many films use this and that's why I wasn't seeing it often enough.

It does not happen for any MKV movie file with a 2:35 ratio (1920x800).

So the issue happens with any MKV video file with VDADecoder turned on that plays at 1920x1080 on my system. Tons of skipped frames.

Can anyone else test or confirm? I've checked the logs and tried different settings, no obvious errors being thrown out but turning off VDADecoder definitely enables the smooth playback for 1920x1080. Leaving it on and it's skipped frame city.

Hope this helps!

i'm not sure if i have the same problem as yours. when you say skipped frames, is that what the video info is reporting on screen? or just what you can notice visually?

I'm having a problem (i havent yet looked at file resolution) where i see a lot of "tearing" on video files. it could really be skipped frames. im not sure what the difference is. but it seems that parts of the picture lag behind other parts sometimes, and you can see the frame change, like parts of the picture are lagging behind. hard to explain but its subtle yet noticable.

i'll give it a short with vdadecoder off. i have a 2010 mac mini. the one with the nvidia 320 video card.
find quote
BDPNA Offline
Fan
Posts: 447
Joined: Sep 2008
Reputation: 0
Post: #5
My Mac Mini is circa 2009, so we may have different issues.

Video looks fine, no tearing, just incredibly choppy. When I pull up the info window I see the SKIP count going up like crazy. Only for 1920x1080 with VDADecoder on. With VDADecoder off it works pretty well though obviously will struggle in action scenes since it's not using hardware decoding. VDADecoder on for 1920x800 works great.

Pull up the info window ("O" on the keyboard while playing) and see what your SKIP and DROPPED FRAMES counts look like as a video plays. Make sure you have VDADecoder on and are watching an mkv that's at 1920x1080 (should play full screen).

I have vertical sync always enabled and have adjust display to match refresh rate on, also use sync playback to display option on set to match audio clock. However, turning these off had no changes to the skipped frames issue at 1920x1080.

The problem was not evident until I bumped up to Mavericks so it's likely just something that Davilla and the other devs need to code for, another weird change Apple made to the graphics driver giving these poor guys headaches to try and support it all.
find quote
BDPNA Offline
Fan
Posts: 447
Joined: Sep 2008
Reputation: 0
Post: #6
Davilla,

You've done it. Your nvidia changes in the recent nightly fixed this issue for me. Saw your notes on git and thought you'd want to know - Problem solved! Thank you thank you thank you!
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #7
thanks for replying, I snuck in this change and was waiting to see the effect Smile


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
BDPNA Offline
Fan
Posts: 447
Joined: Sep 2008
Reputation: 0
Post: #8
The effect is awesomeness. Thanks Davilla. Smile
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,796
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #9
Wonder if this also fixes the issues mentioned here:

http://forum.xbmc.org/showthread.php?tid...pid1535220

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote