[RELEASE] NetfliXBMC - Inofficial Netflix Add-on (Win/OSX/Linux)

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
rmrende Offline
Junior Member
Posts: 6
Joined: Apr 2014
Reputation: 0
Post: #571
(2014-04-14 15:56)rmrende Wrote:  
(2014-04-13 22:28)AddonScriptorDE Wrote:  
(2014-04-12 20:50)rmrende Wrote:  Has anyone else had this problem?
Looks like you have problems with ssl. Are you using a proxy? If so, it must support ssl.

I am using a proxy, adfreetime. I am not sure if it supports SSL but will look into it. I will also test with this newer version and without using the proxy and report back with the progress.

Thanks!

I disabled the proxy and it worked. Looks like a great plugin! Anyone able to get it working using adfreetime?

Also, once in the browser I am trying to use my remote to control it but basically it just takes me out of XBMC and into the browser. I am using safari as it seems the newest version of Silverlight does not support chrome for OSX. You mention that I need cliclick, I downloaded it but am not really sure what needs to be done with it. I just want to be able with my remote to get back into XBMC after it takes me out.

Any help is greatly appreciated. Great plugin!
find quote
fillerguy Offline
Junior Member
Posts: 6
Joined: Jan 2014
Reputation: 0
Post: #572
(2014-04-12 20:50)rmrende Wrote:  
(2014-04-11 03:44)rmrende Wrote:  I am getting "Could not connect to remote server" using both Frodo and Gothem Beta 3. I am running the newest OSX. I tried the recommendation above about changing the login URL. The error in the Xbmc logs is the same either way:

Quote:21:33:16 T:2953924608 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <class 'urllib2.URLError'>
Error Contents: <urlopen error [Errno 8] _ssl.c:480: EOF occurred in violation of protocol>
Traceback (most recent call last):
File "/Users/rmrende/Library/Application Support/XBMC/addons/plugin.video.netflixbmc/default.py", line 771, in <module>
index()
File "/Users/rmrende/Library/Application Support/XBMC/addons/plugin.video.netflixbmc/default.py", line 101, in index
if login():
File "/Users/rmrende/Library/Application Support/XBMC/addons/plugin.video.netflixbmc/default.py", line 473, in login
content = opener.open("http://movies.netflix.com/Login").read()
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 397, in open
response = meth(req, response)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 510, in http_response
'http', request, response, code, msg, hdrs)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 429, in error
result = self._call_chain(*args)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 369, in _call_chain
result = func(*args)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 605, in http_error_302
return self.parent.open(new, timeout=req.timeout)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 397, in open
response = meth(req, response)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 510, in http_response
'http', request, response, code, msg, hdrs)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 429, in error
result = self._call_chain(*args)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 369, in _call_chain
result = func(*args)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 605, in http_error_302
return self.parent.open(new, timeout=req.timeout)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 391, in open
response = self._open(req, data)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 409, in _open
'_open', req)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 369, in _call_chain
result = func(*args)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 1169, in https_open
return self.do_open(httplib.HTTPSConnection, req)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 1136, in do_open
raise URLError(err)
URLError: <urlopen error [Errno 8] _ssl.c:480: EOF occurred in violation of protocol>
-->End of Python script error report<--

Has anyone else had this problem?

I get this exact problem too after the update. Fortunately I had a backup of everything, copied 1.25 back and it works
find quote
scrolling Offline
Senior Member
Posts: 203
Joined: Feb 2009
Reputation: 3
Post: #573
I've been trying to do a search, however, I've been getting nothing back on the search results. Has any one have this issue?

HTPC: Apex MI-008 | Foxconn H67S | Celeron G530 | G.SKILL 4GB | Crucial 64 SSD| Arctic Cooling | PicoPSU-160-XT
find quote
laer0302 Offline
Junior Member
Posts: 10
Joined: Mar 2014
Reputation: 0
Post: #574
(2014-04-11 08:30)fgarcor Wrote:  I may have a guess here, but my feeling is that Netflixbmc_utility is the one that provides the special keys to control the browser (play, stop, exit...). If you map your exit key let's say to "back" instead of alt+f4 the application should terminate the browser and the utility itself. I have the feeling that alt+f4 just closes the browser.

This fixed my problem, thank you very much!
find quote
TVRRichard Offline
Junior Member
Posts: 2
Joined: Apr 2014
Reputation: 0
Post: #575
Thanks for the advice about embed/not embed in browser, however the problem is still there (I've also just installed the new version 1.2.6).

The issue is running Mint 16 on an i5 Intel NUC, pipelight works fine when running in chrome - Netflix is all spot on. When I run the add-on in XBMC all the navigation works fine, movies etc load, I can scroll the progress bar and see the mini preview frames however it just won't play. The play/pause icon toggles, but no moving pictures or audio. Any ideas would be gratefully received.
find quote
Post Reply