Release - VideoExtras Addon

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
im85288 Offline
Fan
Posts: 458
Joined: Aug 2011
Reputation: 11
Location: United Kingdom
Post: #46
(2013-12-06 17:33)rob_webset Wrote:  
(2013-12-06 17:10)im85288 Wrote:  I did use the extra functionality to check if an item had extras and only then is the Extras button visible..this way seemed a lot simpler than adjusting all the views etc.

I was actually referring to the ability to show on the Move/TV List screen if there are any extras (without going into the Information Screen to see if there are any) - no-one has implemented this yet for any skin yet Big Grin

Hi, yes I understood correctly. The only issue I had with this is that as there are so many different views in the skin (i.e.. Info-List, carousel etc etc) I would need to adjust them all to indicate if there are extras....but maybe something for a future update Smile
find quote
rob_webset Offline
Fan
Posts: 710
Joined: Sep 2013
Reputation: 21
Post: #47
(2013-12-06 14:39)rob_webset Wrote:  Looks like it's the \\SERVER\Name format that is causing the problems.

By the time it gets to the VideoExtras addon it has processed the first escape so looks like:

Code:
\SERVER\Name

I believe most people use the smb:// format (Didn't realise that XBMC would even support this format!)

Will take a look at supporting it when I next have a minute - I don't imagine it will be too hard

Fix is now available for manual patching:

https://code.google.com/p/robwebset/source/detail?r=138

Please let me know how you get on.

Thanks, Rob
find quote
tennisbgc Offline
Senior Member
Posts: 237
Joined: Feb 2010
Reputation: 1
Post: #48
cant get this to work with the xperience1080 skin. I tried editing the DialogVideoInfo.xml but nothing happens. is there something else I need to do?
find quote
capfuturo Offline
Fan
Posts: 555
Joined: Feb 2013
Reputation: 11
Location: London, UK
Post: #49
@tennisbgc: Hello there, could you please tell whether all steps to set up VideoExtras properly have been performed. You can find what is needed on the wiki link (1st post of this thread)

Best,

capfuturo


"The world must learn to work together, or finally it will not work at all" - General Eisenhower
(This post was last modified: 2013-12-09 02:12 by capfuturo.)
find quote
tennisbgc Offline
Senior Member
Posts: 237
Joined: Feb 2010
Reputation: 1
Post: #50
I did all of steps 3.1, 4, and 8. If I use xperience1080++ it works just not with xperience1080.
find quote
rob_webset Offline
Fan
Posts: 710
Joined: Sep 2013
Reputation: 21
Post: #51
(2013-12-09 03:06)tennisbgc Wrote:  I did all of steps 3.1, 4, and 8. If I use xperience1080++ it works just not with xperience1080.

Hi tennisbgc,

xperience1080++ supports VideoExtras without any changes required - which may be why it works on your system.

xperience1080 does not currently come with the required hooks - one option is to post on the xperience1080 forum to see if the author of the skin is willing to add built in support for VideoExtras?

The skin changes highlighted in section 8 are for confluence - they are there as an example - and may require slightly different tweaks for each skin. (Depends on what the skin author has done)

Thanks, Rob
find quote
capfuturo Offline
Fan
Posts: 555
Joined: Feb 2013
Reputation: 11
Location: London, UK
Post: #52
@tennisbgc: I have also put a call yesterday at [RELEASE] Xperience1080 2.1 for XBMC 12.x. in case `Black gets interested in supporting VideoExtras.

Best,

capfuturo


"The world must learn to work together, or finally it will not work at all" - General Eisenhower
find quote
kev18 Offline
Junior Member
Posts: 12
Joined: Oct 2011
Reputation: 0
Post: #53
Hi all,

Just wondering what should the folder and file naming structure be for Prometheus Extras....they contain..
- Alternative Ending
- Deleted Scenes 10 of them
- Arrival of Engineers

- Weyland files....4 of them....separate TMDB number
- The Furious Gods: Making Prometheus (2012) separate TMDB number
find quote
rob_webset Offline
Fan
Posts: 710
Joined: Sep 2013
Reputation: 21
Post: #54
(2013-12-09 14:12)kev18 Wrote:  Hi all,

Just wondering what should the folder and file naming structure be for Prometheus Extras....they contain..
- Alternative Ending
- Deleted Scenes 10 of them
- Arrival of Engineers

- Weyland files....4 of them....separate TMDB number
- The Furious Gods: Making Prometheus (2012) separate TMDB number

Whatever you like as long as it meets the format detailed in the Wiki.

Rob
find quote
capfuturo Offline
Fan
Posts: 555
Joined: Feb 2013
Reputation: 11
Location: London, UK
Post: #55
@kev18: videos that contain an IMDB or TMDB ID are official releases. That is the case of 'The Furious Gods:...' for instance, which is a documentary officially released that comes as an extra feature with the DVD or Blu-Ray of 'Prometeus'. Therefore it is up to you how you set up this type of material up in your library. You could well keep these documentaries as different entries (independent movies) and have them scrapped like any other movie, so all the metadata information will show up such as actors, plot, poster, fanart, etc... Or you can have them all under extras for the movie 'Prometeus', which is a nice way to keep them organised and consistent to the way they came with the Blu-Ray. With the latter, you still can assign a specific poster and fanart images, however no plot, actors, ratings whatsoever are currently supported for extras.

It would be nice to hear other user's feedback here too on how they are organising these type of material in their libraries now that there is VideoExtras. There may be other valid and creative approaches that escape my domains. I hope that clears it up.

Best,

capfuturo


"The world must learn to work together, or finally it will not work at all" - General Eisenhower
find quote
invision Offline
Junior Member
Posts: 17
Joined: Dec 2013
Reputation: 0
Post: #56
Rob, that manual patch fixed the \\SERVER issue with XBMC on my PC.
My next question is in regards to my Pivos XIOS Box M3 [Running XBMC Linux Build]. The plugin generally works well on the box.

The only problem i have found is that if i highlight a movie/tv show and press Movie information too quickly (sometimes even 3-4 seconds after highlighting the movie/tv show in library view) it will cause the box to crash and restart XBMC. This crash does not occur when VideoExtras is disabled. I'm sure that this problem is in primarily due to the lack of RAM / CPU on these boxes as it does not occur on my PC, but i thought i might let you know of the problem and perhaps you could implement a work around (if at all possible).

Code:
http://pastebin.com/Y0VhVVuG

In the above log, i waited 4-6 seconds for the first movies and the movie information box worked well. For 2 Guns, i waited under 3 seconds when i went to the movie information page, which caused the box to crash and restart. It occurs if i press the i[information button] on my remote or if i go to the movie information option on the XBMC GUI too quickly.

Not a huge problem, but I'm curious if the problem can be fixed by changing code with the plugin.

Thanks very much
find quote
rob_webset Offline
Fan
Posts: 710
Joined: Sep 2013
Reputation: 21
Post: #57
(2013-12-09 15:36)invision Wrote:  Rob, that manual patch fixed the \\SERVER issue with XBMC on my PC.
My next question is in regards to my Pivos XIOS Box M3 [Running XBMC Linux Build]. The plugin generally works well on the box.

I was previously thinking of getting one of those - but then decided on the Arctic MC001 instead. Unfortunately I don't have an android device to test it on.

(2013-12-09 15:36)invision Wrote:  The only problem i have found is that if i highlight a movie/tv show and press Movie information too quickly (sometimes even 3-4 seconds after highlighting the movie/tv show in library view) it will cause the box to crash and restart XBMC. This crash does not occur when VideoExtras is disabled. I'm sure that this problem is in primarily due to the lack of RAM / CPU on these boxes as it does not occur on my PC, but i thought i might let you know of the problem and perhaps you could implement a work around (if at all possible).

Code:
http://pastebin.com/Y0VhVVuG

In the above log, i waited 4-6 seconds for the first movies and the movie information box worked well. For 2 Guns, i waited under 3 seconds when i went to the movie information page, which caused the box to crash and restart. It occurs if i press the i[information button] on my remote or if i go to the movie information option on the XBMC GUI too quickly.

Not a huge problem, but I'm curious if the problem can be fixed by changing code with the plugin.

Very strange. The time that it fails it is not even printing the logging from VideoExtras, the first thing VideoExtras does is:

Code:
try:
    if len(sys.argv) > 1:
        # get the type of operation
        log("Operation = " + sys.argv[1])

So you should see a log line like:

Code:
DEBUG: script.videoextras: Operation = check

In fact looking closely at the log, you can see the final call:

Code:
XBMC.RunScript(script.videoextras,check,"$INFO[ListItem.FilenameAndPath]")
DEBUG: ExecuteXBMCAction : To
                                                XBMC.RunScript(script.videoextras,check,"smb://SERVERIP/video/Movies/2 Guns (2013)/2 Guns (1080p, BluRay).mkv")
INFO: initializing python engine.
DEBUG: new python thread created. id=7
NOTICE: Thread XBPyThread start, auto delete: false
DEBUG: Python thread: start processing

But then it stops, looking at the previous calls it should be:

Code:
NOTICE: -->Python Interpreter Initialized<--
DEBUG: Process - The source file to load is /root/.xbmc/addons/script.videoextras/default.py

So it seems like the python interpreter is failing to start - and VideoExtras is not getting called at all.

Hope this helps for chase down a possible solution.

Rob
find quote
Deano316 Offline
Posting Freak
Posts: 858
Joined: Jul 2011
Reputation: 9
Location: Brighton, England
Post: #58
I've had to stay away from XBMC for the last couple of months due to my PC becoming increasingly unreliable. All fixed now and I've finally had the chance to catch up with this add-on and it has come along leaps and bounds since I last used it!! Kudos rob_webset, it really is amazing what you've done in a short space of time Big Grin I've updated with only two minor issues really, that being the fanart not displaying and this layout anomoly:

[Image: XByeWGV.png]

The text in the top left seems to be overlayed incorrectly and obviously.....no fanart. I've tried a few different naming conventions, even adding an nfo and using it to point XBMC to the artwork but still nothing. Not a deal breaker by any stretch of the imagination, just wanted to give you some useful feedback. Good to be back and keep up the good work bro Wink

Running Aeon Nox GIT, latest XBMC stable, on Windows 7.

Also, you might want to change the link on the Wiki under "Forum and Issue Report Pages". It currently has a link to the old Extras thread, not this one Wink
(This post was last modified: 2013-12-09 19:44 by Deano316.)
find quote
rob_webset Offline
Fan
Posts: 710
Joined: Sep 2013
Reputation: 21
Post: #59
Hi Deano316,

You may want to have a look at section 7 of the wiki - looks like you have hit the skin issue on the advanced list screen.

Maybe post on the "Aeon Nox" thread to see if they would be willing to support VideoExtras?

Thanks

Rob
find quote
wgstarks Online
Posting Freak
Posts: 1,125
Joined: Jun 2013
Reputation: 7
Location: North Carolina, USA
Post: #60
@deano316
You can disable Details List in the VideoExtras configuration to correct this. That feature is not supported in Nox.

[Image: all-thin-banner.jpg]
MacMini5,2 HTPC (Gotham 13.2/Aeon Nox Redux 5.1.5/MacOSX 10.8.5)/Onkyo TXNR609/Panny65VT30
find quote
Post Reply