Live TV Working but Recordings not...

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
thomcub3 Offline
Junior Member
Posts: 7
Joined: Nov 2013
Reputation: 0
Post: #1
Hi,

I've recently moved away from Mediaportal front end to XBMC on openelec. Live tv is working well using tsreader etc and the all current available functions are working well par the ability to play recordings from the recording menu. I can play the recordings from the video section by browsing to the windows share (which has been mapped on xbmc under videos) and they play fine.

When I click on a recording under the recording section it fails with error message :

AddOnLog: MediaPortal PVR Client: Recording playback not possible. Backend returned empty filename or stream URL for recording id 1277

The recording id is correct and can be played via the videos section..

It looks to be an issue with the decoding of the path into the pvr:// section..

with xbmc running on windows (on seperate pc not running mediaportal tv server) recording play back works ok.. however I believe I had to map the network drive with same letter as the actual drive holding the recordings on the server to get it to work.

any help appreciated - have been trying to get this working for couple of weeks now...

Thanks
find quote
margro Offline
Fan
Posts: 648
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #2
Enable debug logging in XBMC and post your xbmc.log file on http://xbmclogs.com/ (and the link here).
Your error message indicates that the PVR addon does not know the filename of the recording because the backend did not return the path and filename of the recording.
Why? I don't know yet. The log lines above this error should give more information and you did not post them...

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
(This post was last modified: 2013-11-30 17:50 by margro.)
find quote
thomcub3 Offline
Junior Member
Posts: 7
Joined: Nov 2013
Reputation: 0
Post: #3
Hi will get the full log uploaded soon.. the lines before the error are :

:2951451744 DEBUG: PushCecKeypress - received key b duration 69
:3045408768 DEBUG: CPlayerCoreFactory::GetPlayers(pvr://recordings/E4 - The Big Bang Theory/The Big Bang Theory, TV (E4), 20140108_142307.pvr)
:3045408768 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: system rules
:3045408768 DEBUG: CPlayerSelectionRule::GetPlayers: matches rule: system rules
:3045408768 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: rtv
:3045408768 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: hdhomerun/myth/mms/udp
:3045408768 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: lastfm/shout
:3045408768 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: rtmp
:3045408768 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: rtsp
:3045408768 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: streams
:3045408768 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: dvd
:3045408768 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: dvdimage
:3045408768 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: sdp/asf
:3045408768 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: nsv
:3045408768 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: radio
:3045408768 DEBUG: CPlayerCoreFactory::GetPlayers: matched 0 rules with players
:3045408768 DEBUG: CPlayerCoreFactory::GetPlayers: adding videodefaultplayer (4)
:3045408768 DEBUG: CPlayerCoreFactory::GetPlayers: for video=1, audio=0
:3045408768 DEBUG: CPlayerCoreFactory::GetPlayers: for video=1, audio=1
:3045408768 DEBUG: CPlayerCoreFactory::GetPlayers: adding player: DVDPlayer (1)
:3045408768 DEBUG: CPlayerCoreFactory::GetPlayers: adding player: OMXPlayer (4)
:3045408768 DEBUG: CPlayerCoreFactory::GetPlayers: added 2 players
:3045408768 NOTICE: COMXPlayer: Opening: pvr://recordings/E4 - The Big Bang Theory/The Big Bang Theory, TV (E4), 20140108_142307.pvr
:3045408768 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
:3045408768 DEBUG: CRenderManager::UpdateDisplayLatency - Latency set to 0 msec
:3045408768 NOTICE: CXBMCRenderManager::ResetRenderBuffer - using 5 render buffers
:3045408768 DEBUG: LinuxRendererGL: Cleaning up GL resources
:3045408768 DEBUG: DllSwScale: Using libswscale system library
:2962375776 NOTICE: Thread COMXPlayer start, auto delete: false
:2962375776 NOTICE: Creating InputStream
:2962375776 DEBUG: PVRManager - OpenRecordedStream - opening recorded stream ''
:2962375776 DEBUG: AddOnLog: MediaPortal PVR Client: ->OpenRecordedStream(index=2340)
:2962375776 ERROR: AddOnLog: MediaPortal PVR Client: Recording playback not possible. Backend returned empty filename or stream URL for recording id 2340
:2962375776 DEBUG: POParser: loaded 37 strings from file /usr/share/xbmc/addons/pvr.mediaportal.tvserver/resources/language/English/strings.po
:2962375776 DEBUG: CAddonCallbacksAddon - QueueNotification - MediaPortal PVR Client - Error Message : 'Recording playback failed. Empty URL of filename.'
:2962375776 ERROR: COMXPlayer::OpenInputStream - error opening [pvr://recordings/E4 - The Big Bang Theory/The Big Bang Theory, TV (E4), 20140108_142307.pvr]
:2962375776 NOTICE: COMXPlayer::OnExit()
:2962375776 NOTICE: COMXPlayer::OnExit() deleting input stream
:2962375776 DEBUG: CDVDInputStreamPVRManager::Close - stream closed
:2962375776 DEBUG: Thread COMXPlayer 2962375776 terminating
:3045408768 DEBUG: CAnnouncementManager - Announcement: OnStop from xbmc
:3045408768 DEBUG: GOT ANNOUNCEMENT, type: 1, from xbmc, message OnStop

Live tv works fine snippet from log is :

17:43:37 T:3048474368 NOTICE: DVDPlayer: Opening: pvr://channels/tv/All TV channels/0.pvr
17:43:37 T:3048474368 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
17:43:37 T:3048474368 NOTICE: CXBMCRenderManager::ResetRenderBuffer - using 5 render buffers
17:43:37 T:2848615232 NOTICE: Thread CDVDPlayer start, auto delete: false
17:43:37 T:2848615232 NOTICE: Creating InputStream
17:43:38 T:2848615232 NOTICE: AddOnLog: MediaPortal PVR Client: CTsReader::Open(\\Master\TimeShifting\live7-0.ts.tsbuffer)
17:43:39 T:2848615232 NOTICE: Creating Demuxer
17:43:44 T:2848615232 NOTICE: Opening video stream: 0 source: 256
17:43:44 T:2848615232 NOTICE: Creating video codec with codec id: 2
17:43:44 T:2848615232 NOTICE: CDVDVideoCodecFFmpeg::Open() Creating VDPAU(720x576, 2)
17:43:44 T:2848615232 NOTICE: vdp_device = 0x00000001 vdp_st = 0x00000001


The recordings are stored on same server at location \\Master\recordings\*. I've set the TVServer to use either local file path (i.e. F:\) and also tried with \\master\recordings. Neither approach seems to work for the recordings. The correct path is being stored in MediaPortal TV Server database (have checked directly).

Any help really appreciated..
Thanks and sorry about delay in getting back - holiday season took over :-)
(This post was last modified: 2014-01-08 20:42 by thomcub3.)
find quote
thomcub3 Offline
Junior Member
Posts: 7
Joined: Nov 2013
Reputation: 0
Post: #4
Hi log file uploaded to xbmclogs.com link is http://xbmclogs.com/show.php?id=187858

I've been looking through the code of both the XBMCServer as well as the mediaportal pvr plugin and cannot seem to see why this is working ok for live stream and not for recording stream..

Thanks in advance for your time looking into this.
find quote
thomcub3 Offline
Junior Member
Posts: 7
Joined: Nov 2013
Reputation: 0
Post: #5
Hi log file uploaded to xbmclogs.com link is http://xbmclogs.com/show.php?id=187858

I've been looking through the code of both the XBMCServer as well as the mediaportal pvr plugin and cannot seem to see why this is working ok for live stream and not for recording stream..

Thanks in advance for your time looking into this.
find quote
margro Offline
Fan
Posts: 648
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #6
Thanks for the log files. I still don't know what is wrong here, but it seems that the problem is at the TVServerXBMC plugin side.
The XBMC plugin receives to filename or RTSP url, so that is why it can't play the recording.

Could you also post a log file from the TVServer itself? (C:\ProgramData\Team MediaPortal\MediaPortal TV Server\log\TVService.log)
Start XBMC, browse through your recordings list and post the TVService.log file.

I'm in particular interested in the log lines following a "ListRecordings" call e.g:
Code:
[2014-04-28 21:43:05,309] [Log    ] [13       ] [DEBUG] - TVServerXBMC: Handling command: ListRecordings
[2014-04-28 21:43:05,316] [Log    ] [30       ] [INFO ] - Controller: streaming url:rtsp://192.168.1.14:554/A405B7C1 file:E:\Live TV\Recordings\Nederland 1 - 2012-01-15.ts
...

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
thomcub3 Offline
Junior Member
Posts: 7
Joined: Nov 2013
Reputation: 0
Post: #7
Hi extract from the tvserver log starting at ListRecordings line at : http://xbmclogs.com/show.php?id=188209
find quote
thomcub3 Offline
Junior Member
Posts: 7
Joined: Nov 2013
Reputation: 0
Post: #8
Hi margro

Just wondering if the tvserver log extract had helped identify the issue?
Thanks again for taking the time to look into this.

Thanks
find quote
thomcub3 Offline
Junior Member
Posts: 7
Joined: Nov 2013
Reputation: 0
Post: #9
Hi Margro

Just found that if I set the pvr plugin to use ffmpeg option, save, restart xbmc and then go to mediaportal pvr config again and set it back to TSReader the recordings will play, can be paused, forwarded etc and so can Live TV stream.. Is there something be triggered by ffmpeg setting somewhere in the pvr client or TV Server plugin?

Thanks
find quote
hidalgo67 Offline
Junior Member
Posts: 4
Joined: Apr 2014
Reputation: 0
Post: #10
(2014-05-14 18:38)thomcub3 Wrote:  Hi Margro

Just found that if I set the pvr plugin to use ffmpeg option, save, restart xbmc and then go to mediaportal pvr config again and set it back to TSReader the recordings will play, can be paused, forwarded etc and so can Live TV stream.. Is there something be triggered by ffmpeg setting somewhere in the pvr client or TV Server plugin?

Thanks

This worked for me also. But doesn’t survive a reboot. Sad

But I found something very strange. If I have a recording path like \\server\recordings (mapped to R:\) that points to my has, I can do recordings but cannot play them in XBMC. So I change the recording folder in the database to R:\ -> can play the recordings. So I tried to change the recording folder manually in the database to R:\ then I cannot make any recordings.
How can I tell the PVR client to exchange the path \\server\recordings to the mapped letter R:\?

Any other solution is welcome.
find quote
margro Offline
Fan
Posts: 648
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #11
@hidalgo67: the ffmpeg setting will tell XBMC to play the recordings using a rtsp stream.
When the backend and XBMC are on the same machine, XBMC will use the filename as stored in the TV Server database.
When that does not work, XBMC will strip the path from the recording filename and add the network share as specified in the TVServerXBMC plugin settings.

So if the local path is E:\Recordings\MyRecording.ts
and the recordings share in the TVServerXBMC plugin is \\server\Recordings
the result should become: \\server\Recordings\MyRecording.ts
which will be translated into the following xbmc path:
smb://username:password@server/Recordings/MyRecording.ts
-or- with empty username/password settings:
smb://server/Recordings/MyRecording.ts

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
hidalgo67 Offline
Junior Member
Posts: 4
Joined: Apr 2014
Reputation: 0
Post: #12
Thanks margro
In the meantime I found a solution for my problem.
First I did make a link to my NAS with mklink

mklink C:\Recordings \\server\Recordings

then I did make a junction

mklink /J C:\Users\Public\Recorded TV C:\Recordings

finally I did choose the junction as my recording folder in MediaPortal. And everything works like a charm.
find quote