Help us solving the AirPlay issue when using iOS7 devices

  Thread Rating:
  • 6 Votes - 4.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
wwwidowntv Offline
Junior Member
Posts: 1
Joined: Apr 2014
Reputation: 0
Post: #466
(2014-04-18 15:21)bigbobyo Wrote:  I'm having the same problem with NBA Game Time International app. When I airplay the live stream It stops after 5 minutes. Neulion develops both these apps. Hopefully the xbmc developers can figure out the problem since neulion develops alot of sports live stream apps.

I'm also having the same problem with NBA Game Time International app - When I airplay the live stream It stops after 5 minutes.
For non-live streams - like 15 minutes long condensed game - seems to work fine.

(2014-04-21 23:41)testooo Wrote:  win 7 pro
ipad 4
Os 7.1

allow airplay volume control option - doesn't work no effect if enabled

anyone or only me?

cheers

same here - volume control option - doesn't work
(This post was last modified: 2014-04-23 10:44 by wwwidowntv.)
find quote
AllenWang Offline
Junior Member
Posts: 3
Joined: Apr 2014
Reputation: 0
Post: #467
Hi, Memphiz and jyavenard

My xbmc airplayer(ubuntu 12.04) can play various video(ios7.0.4, ios7.0.6, ios7.1) normally, but can't play music,
Because I have not found out the Apple's 'fp' digtal signature algorithm so far, so I can't decrypt the aeskey carried by fpaeskey.
(This post was last modified: 2014-04-24 03:54 by AllenWang.)
find quote
AllenWang Offline
Junior Member
Posts: 3
Joined: Apr 2014
Reputation: 0
Post: #468
Another Informations about airplay :

If we switch to airplay in the course of video playing, the ipad/iphone need to send the silent audio samples to xbmc , so need the _roap to do some rtsp session responses, But needn't if we switch to airplay before video playing
(This post was last modified: 2014-04-24 03:55 by AllenWang.)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,169
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #469
(2014-04-23 10:42)wwwidowntv Wrote:  same here - volume control option - doesn't work

What do you expect that option to do? Controlling volume over airplay only works for ios4 clients when doing video - but should work for all clients when streaming music only. Thats all it does. Controlling volume when airplaying video was ripped out by apple since ios5 ... (nothing we can do about it as its a client thingy not a xbmc thingy).

@AllenWang

while i really appreciate if people are sharing information about airplay - please remove all the clutter from your posts and paste it to pastebin.com and only put the links in here - or even better link to your github account with the code changes. Beside that - i am already aware of howto do the fp handshake to retrieve the key. As you already noticed this is only the small part.

See my patch for fp handshake here:

https://github.com/Memphiz/xbmc/commits/...phandshake

Also the fact that first an raop connection is made before video is known and xbmc handles that aswell (it was introduced by apple in ios5 and later clients...).

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
(This post was last modified: 2014-04-23 19:32 by Memphiz.)
find quote
AllenWang Offline
Junior Member
Posts: 3
Joined: Apr 2014
Reputation: 0
Post: #470
Hi, Memphiz,

Thanks for your suggestion, I have remove the code to my github.

"i am already aware of howto do the fp handshake to retrieve the key. "
--> excited news to me, the fp handshake puzzled me for a long time.

But When pull the newest "shairplay" commit and the xbmc "remotes/origin/shairplayfphandshake" branch,
I couldn't find the _roap fp handshake related code, the comit information is as follows :

commit bd6fac6826459933328f21e278af520a27d8f111
Author: Memphiz <memphis@machzwo.de>
Date: Sun Jan 12 16:49:45 2014 +0100

Is my branch correct ?

Or could you show me how can I do the fp handshake , I want to get the correct aeskey from the ANNOUNCE command
a=fpaeskey:RlBMWQECAQAAAAA8AAAAAJla/.....

I have also sent you an email, waiting for your response.
find quote
testooo Offline
Junior Member
Posts: 27
Joined: Mar 2014
Reputation: 0
Post: #471
Update IOS 7.1.1 :

Xbmc B4
win 7 pro
ipad 4
OS : 7.1.1
App to test with : Youtube

Ive been posting since B1 release the Airplay status after each IOS update, I hope this will help in developing process !!!

Ok I noticed that airplay is more responsive in terms of play back comparing to IOS 7.1.0, but in terms of buffering and sync info between the video and the app is not always working, after playing back few videos the buffer stuck on the app ( loading circle ) and the video on Xbmc is showing full buffer but can't press play. So I need to disconnect airplay from the app then choose it again, after that everything is ok.

Also the quality of the video in xbmc play back has changed before the video plays back at 480p , now it can play the same 720p of the app settings.

I don't know if apple fixed something or youtube has done something !,,,

Hope thats help


Cheers
find quote
ErlendSB Offline
Senior Member
Posts: 187
Joined: Sep 2008
Reputation: 3
Location: Norway
Post: #472
Running RC1 on Windows 8.1
I'm guessing the patches from this thread are included in RC1?
I'm trying to Airplay from Ipad2 7.1.1
XBMC appears in the list over airplay devices (on the Ipad), but upon selecting XBMC I get no sound or indication of connection.

http://pastebin.com/DRwtt1TL

Airplay debugging is enabled in advancedsettings

I have tried with youtube and spotify from the ipad, with same result.

Let me know if I can be of more help. I appreciate the work you are doing.
find quote
testooo Offline
Junior Member
Posts: 27
Joined: Mar 2014
Reputation: 0
Post: #473
(2014-04-28 22:11)testooo Wrote:  Update IOS 7.1.1 :

Xbmc B4
win 7 pro
ipad 4
OS : 7.1.1
App to test with : Youtube

Ive been posting since B1 release the Airplay status after each IOS update, I hope this will help in developing process !!!

Ok I noticed that airplay is more responsive in terms of play back comparing to IOS 7.1.0, but in terms of buffering and sync info between the video and the app is not always working, after playing back few videos the buffer stuck on the app ( loading circle ) and the video on Xbmc is showing full buffer but can't press play. So I need to disconnect airplay from the app then choose it again, after that everything is ok.

Also the quality of the video in xbmc play back has changed before the video plays back at 480p , now it can play the same 720p of the app settings.

I don't know if apple fixed something or youtube has done something !,,,

Hope thats help


Cheers

Update : today there is an update for Youtube app on Ipad, the video works fine but no Sound at all I've tried many things different setting but no Sound. also the video keeps buffering on pause, and after playing back few videos.
(This post was last modified: 2014-05-02 05:41 by testooo.)
find quote
MalcolmSex Offline
Junior Member
Posts: 5
Joined: May 2010
Reputation: 0
Post: #474
I'm having issues with Airplay with the new Gotham RC1 update on Ubuntu 14.04.

Airplay worked fine on Beta4 but now only video based apps work on my iPad Retina Mini running iOS 7.04. Deezer and Google Music no longer work. The screen flashes (XBMC's interface looks like it has refreshed) when I press play but nothing plays. Youtube and iPlayer seem to work fine however.

How would I give you more details of this problem?

Also, does anybody know a good way of rolling back to Beta4 until this issue is resolved?
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 3,426
Joined: Jul 2010
Reputation: 67
Location: Munich
Post: #475
next version will include a fix for this
find quote
DBMandrake Offline
Fan
Posts: 434
Joined: Feb 2013
Reputation: 12
Location: UK
Post: #476
(2014-05-02 12:47)FernetMenta Wrote:  next version will include a fix for this
Can you elaborate or link to a pull request that contains the fix ? Could this also be related to the no sound from iOS youtube app issue ?

XBMC 13.2 - Mid 2007 Mac Mini, 4GB, 2TB HD, OS X 10.6.8.
XBMC 13.2 - Raspberry Pi 512MB Model B, 16GB SD, Raspbmc.
(This post was last modified: 2014-05-02 13:04 by DBMandrake.)
find quote
miappa Offline
Posting Freak
Posts: 949
Joined: Dec 2012
Reputation: 73
Post: #477
I think this is it: https://github.com/xbmc/xbmc/pull/4624
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 3,426
Joined: Jul 2010
Reputation: 67
Location: Munich
Post: #478
(2014-05-02 14:17)miappa Wrote:  I think this is it: https://github.com/xbmc/xbmc/pull/4624

correct
find quote
DBMandrake Offline
Fan
Posts: 434
Joined: Feb 2013
Reputation: 12
Location: UK
Post: #479
(2014-05-02 14:26)FernetMenta Wrote:  
(2014-05-02 14:17)miappa Wrote:  I think this is it: https://github.com/xbmc/xbmc/pull/4624

correct
Just tried building the latest version of Gotham (commit 91880f1671f920ab2b9b6afb084edd5ad5b233c3) on Windows 7 to test this fix, unfortunately airplay audio (airtunes) doesn't work at all now. Sad

On commit ddeedeade8ea835d36163e605b08364036de3b82 XBMC registered that there was an incoming airplay audio only stream (tested with Spotify and the built in Music app on an iPad 3, iOS 7.1.1) complete with active visualiser but there was no actual audio. An airplay video stream from youtube did have audio.

On the latest commit as far as the iPad is concerned everything is fine - it connects to the airplay destination and happily "plays", however XBMC sits at the home screen and does not even acknowledge that an air play sessions is occurring - no visualiser, no sound, nothing.

Debug log:

http://pastebin.com/d0rZp6V1

(xbmclogs.com wouldn't accept my log because of a "censored" word - no idea what ?)

Edit: Hmm, going back to the earlier commit to test it again I see the same problem with no visible action in XBMC. Not sure what to think of that... hopefully something will stand out in the debug log! (I'm trying a build clean in case it didn't properly rebuild the older version)

XBMC 13.2 - Mid 2007 Mac Mini, 4GB, 2TB HD, OS X 10.6.8.
XBMC 13.2 - Raspberry Pi 512MB Model B, 16GB SD, Raspbmc.
(This post was last modified: 2014-05-02 17:28 by DBMandrake.)
find quote
DBMandrake Offline
Fan
Posts: 434
Joined: Feb 2013
Reputation: 12
Location: UK
Post: #480
Don't know what's going on here, I can't get consistent results in my tests. I'm starting to suspect our wireless network at work is interfering with airplay, although it has worked in the past. I'll try it at home over the weekend although it will be on a Mac.

XBMC 13.2 - Mid 2007 Mac Mini, 4GB, 2TB HD, OS X 10.6.8.
XBMC 13.2 - Raspberry Pi 512MB Model B, 16GB SD, Raspbmc.
(This post was last modified: 2014-05-02 17:47 by DBMandrake.)
find quote
Post Reply