Help us solving the AirPlay issue when using iOS7 devices

  Thread Rating:
  • 6 Votes - 4.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Memphiz Offline
Team-Kodi Developer
Posts: 11,050
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #556
your log is cut - post a full log ...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
snelvuur Offline
Member
Posts: 52
Joined: Dec 2009
Reputation: 0
Post: #557
I only posted the log which had the airplay stuff in it, since the rest was mainly trakt, imdb, scanning movies etc. I read on the debug page that if you use the xbmc uploader it could still containt your userid/pwd of your shares. (which i also found in the xbmc.log) i can always send you a pastebin if you dont mind memphiz.
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,050
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #558
well there is no sign of a tried video playback in that snippet then ... (i see the photo requests which worked of course).

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
snelvuur Offline
Member
Posts: 52
Joined: Dec 2009
Reputation: 0
Post: #559
I see what you mean, i only see the "stop" command but no play or something related to video. I'll do another go and only do video's to make sure i only get that part. I'll do a clean restart once with connecting to it via "speaker" and again with connecting with "screen" (on the airplay screenshots) when i get back home.
find quote
DBMandrake Offline
Fan
Posts: 412
Joined: Feb 2013
Reputation: 12
Location: UK
Post: #560
Also what app are you trying to stream video from ? Some apps will definitely not work.

Youtube (currently, as Google has done something to break it) and any App that tries to enforce encrypted Airplay or prevents Airplay altogether. (such as Netflix)
(This post was last modified: 2014-06-12 11:21 by DBMandrake.)
find quote
snelvuur Offline
Member
Posts: 52
Joined: Dec 2009
Reputation: 0
Post: #561
dbmandrake: Just using the standard photo/video library to be safe ;p
find quote
Lupurus Offline
Junior Member
Posts: 3
Joined: May 2014
Reputation: 0
Post: #562
Music doesn't work here for me as well. Tried from my iPhone with the normal music app.

11:41:04 T:3037462528 NOTICE: COMXPlayer: Opening: pipe://1/
11:41:04 T:3037462528 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
11:41:04 T:2832200768 NOTICE: Thread OMXPlayer start, auto delete: false
11:41:04 T:2832200768 NOTICE: Creating InputStream
11:41:04 T:2832200768 NOTICE: Creating Demuxer
11:41:04 T:2832200768 ERROR: OpenDemuxStream - Error creating demuxer
11:41:04 T:2832200768 NOTICE: COMXPlayer::OnExit()
11:41:04 T:2832200768 NOTICE: COMXPlayer::OnExit() deleting input stream
11:41:04 T:3037462528 NOTICE: COMXPlayer: finished waiting
find quote
fritsch Offline
Team-XBMC Developer
Posts: 6,341
Joined: Aug 2011
Reputation: 144
Location: Karlsruhe
Post: #563
@Lupurus:
Your Debug Log skills are insufficient to post in that thread.
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,050
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #564
@lupurus go to the raspberry pi forum - i saw this multiple times now and it seems related to using rbpi only ...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
popcornmix Online
Team-Kodi Member
Posts: 2,880
Joined: Feb 2011
Reputation: 69
Post: #565
(2014-06-12 16:44)Memphiz Wrote:  @lupurus go to the raspberry pi forum - i saw this multiple times now and it seems related to using rbpi only ...

Not sure if I'll be able to help. This is failing before any omxplayer specific code has run. It looks like ffmpeg doesn't like the "pipe://1/" stream.
Is that the same filename as when it is working correctly? I didn't know xbmc used pipes for talking to xbmc.
find quote
snelvuur Offline
Member
Posts: 52
Joined: Dec 2009
Reputation: 0
Post: #566
@memphiz: http://xbmclogs.com/show.php?id=224665 from debug start to end, and the first try with only speaker icon (dont ask me why) doesnt work, i get an error message when selecting a movie. "operation cannot be started" (or similar, it was in my native language) when clicking on selecting an airplay device again (chosing iphone, then xbmc again when it has a screen icon) i actually did get a bit more info. You can see its trying to play a movie but cannot resolve the host. Sounds logically since that name isn't something you would use, it takes the host rather then for instance the ip.
find quote
mrfatboy Offline
Senior Member
Posts: 194
Joined: Jun 2011
Reputation: 0
Post: #567
Sorry if this is redundant. I have been following this thread off and on since it first started. I have not gone back threw all 38 pages again to find out exactly what the status is. I originally used one of Memphiz's test cases that worked about 90% of the time but I upgraded Gotham 13.1 when my computer crapped out.

I have an iphone 5s 32g. XBMC Gotham 13.1. Windows 7x64. Pictures over airplay work fine. Videos don't work at all.

Using the default iphone photos app the "Video" thumbnail (first frame) does display on XBMC. When I push the play button XBMC looks like it tries to start playing the video. XBMC displays 'working' in the lower right corner then just stops.

If this is old news please disregard but if logs will help please let me know and I will post them. It happens every time so it's easy to reproduce.
(This post was last modified: 2014-06-12 21:45 by mrfatboy.)
find quote
snelvuur Offline
Member
Posts: 52
Joined: Dec 2009
Reputation: 0
Post: #568
@memphiz: when using airplay video towards my macbook, if i select the speaker it will fail just as it failed on my openelec xbmc. If i deselect it and select when it has a screen icon again, it will stream. It uses the same hostname but does seem to work, maybe you have some use of it. I made a debug of my working video on the macbook pro, http://xbmclogs.com/show.php?id=224694

@mrfatboy: seems some cases where video streams dont work, like mine. could be as simple as something that does not resolve correctly on a openelec version, but i'am no wizard Smile
(This post was last modified: 2014-06-12 21:33 by snelvuur.)
find quote
mrfatboy Offline
Senior Member
Posts: 194
Joined: Jun 2011
Reputation: 0
Post: #569
I forgot to mention my XBMC is a windows 7x64 machine.
find quote
snelvuur Offline
Member
Posts: 52
Joined: Dec 2009
Reputation: 0
Post: #570
@mrfatboy, in that case, http://wiki.xbmc.org/?title=AirPlay#adva...ttings.xml set that, wait till it started, then turn on debug mode. Try and play a movie.. look at my pictures (max 1 page back) where you have either a screen or a speaker to stream with on airplay. If you get a speaker, you can select it. Wait a bit then select airplay options again, this time select iphone, then select airplay again and you should have a screen to select (if you have a screen to start with ignore it then) play a movie as you would normally do. After that upload the xbmc.log file so we can compare it with the one i have to see if your issue is also related to a host lookup. (the more souls the better)
find quote
Post Reply