Mac OS X - XBMC 12.3 barely plays video after long idle

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
adro21 Offline
Junior Member
Posts: 10
Joined: Jan 2014
Reputation: 0
Post: #1
I'm on a 2012 Mac Mini (Mavericks) with XBMC 12.3. The mini is always running with XBMC open and after it's been idling for several hours and I then try to play a video, it's incredibly choppy. Choppy isn't even the right word, it plays videos at like 1 frame a sec...so not even watchable. I'm not sure what is causing this...the rest of the machine is running normally. The only way to get XBMC to play videos properly again after a long idle is to restart the app.

Any ideas how I can stop this from happening?

Thanks.
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,918
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #2
debug log

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
adro21 Offline
Junior Member
Posts: 10
Joined: Jan 2014
Reputation: 0
Post: #3
Here's the log file: http://xbmclogs.com/show.php?id=108129

(...but, should I have waited until the video playback problem happens again to generate the log?)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,918
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #4
Yes i need the log when the problem appears of course.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
adro21 Offline
Junior Member
Posts: 10
Joined: Jan 2014
Reputation: 0
Post: #5
Ok I will keep debug on and running until it happens again then get you the log. Thanks.
find quote
adro21 Offline
Junior Member
Posts: 10
Joined: Jan 2014
Reputation: 0
Post: #6
I was able to recreate the issue after having XBMC idle for about 15-20 hours or so. Here is the log I just uploaded: http://xbmclogs.com/show.php?id=108826
I realize Step 3 of the log file instructions says to restart XBMC, but if I did that, the problem would not persist. So I was not able to restart before uploading this log file Sad
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,918
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #7
There happens something with the audio device after that time. Do you know if this also happens with current nightly version or maybe is only an issue on frodo?

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
adro21 Offline
Junior Member
Posts: 10
Joined: Jan 2014
Reputation: 0
Post: #8
It's interesting you mentioned the audio device. Because if I select 5.1 and HDMI, movies will barely play, just like after idling. In order to get that to work, I need to set the output to Analog and 2.0 (instead of 5.1...even though I have 5.1 support)

Haven't tried the nightly...where would I get that?
(This post was last modified: 2014-01-12 19:27 by adro21.)
find quote
starhubble Offline
Junior Member
Posts: 4
Joined: Jan 2014
Reputation: 0
Post: #9
(2014-01-12 00:01)Memphiz Wrote:  There happens something with the audio device after that time. Do you know if this also happens with current nightly version or maybe is only an issue on frodo?

As I posted in another thread, the latest nightly build cures this problem.
find quote
wgstarks Offline
Posting Freak
Posts: 989
Joined: Jun 2013
Reputation: 6
Location: North Carolina, USA
Post: #10
(2014-01-12 19:25)adro21 Wrote:  It's interesting you mentioned the audio device. Because if I select 5.1 and HDMI, movies will barely play, just like after idling. In order to get that to work, I need to set the output to Analog and 2.0 (instead of 5.1...even though I have 5.1 support)

Haven't tried the nightly...where would I get that?

http://xbmc.org/download/
See the nightly builds section near the bottom of the page.

[Image: all-thin-banner.jpg]
MacMini5,2 HTPC (Gotham 13.2/Aeon Nox Redux 5.1.4/MacOSX 10.8.5)/Onkyo TXNR609/Panny65VT30
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,918
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #11
@adro21 5.1 is the wrong setting. Set it to 2.0 and enable the passthrough options . and disable lpcm. 5.1 is only needed in special cases (and is not working very well on osx).

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
adro21 Offline
Junior Member
Posts: 10
Joined: Jan 2014
Reputation: 0
Post: #12
thanks...I've never used the nightly builds before. Assuming it fixes this particular issue, are the nightly builds stable enough for everyday use?
find quote
Ned Scott Offline
Team-Kodi Wiki Guy
Posts: 20,589
Joined: Jan 2011
Reputation: 265
Location: Arizona, USA
Post: #13
more or less

You can make easy links to the XBMC wiki using double brackets around common XBMC words: [[debug log]] = debug log, [[Video library]] = Video library, [[SMB]] = SMB , [[userdata]] = userdata, etc
find quote
adro21 Offline
Junior Member
Posts: 10
Joined: Jan 2014
Reputation: 0
Post: #14
(2014-01-13 00:07)Memphiz Wrote:  @adro21 5.1 is the wrong setting. Set it to 2.0 and enable the passthrough options . and disable lpcm. 5.1 is only needed in special cases (and is not working very well on osx).

Thanks for the tip. Should I change from Analog to HDMI as well?
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,918
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #15
If you have an hdmi connection - yes.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Post Reply