Video Rendering - Error Message AND Crashing - Gotham

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Zokkel Offline
Member
Posts: 89
Joined: Apr 2012
Reputation: 1
Location: Bruges, Belgium
Post: #1
Hi all,

Running the Gotham Nightly of 20/01/2014.
I get a "Video Rendering" error with each video I play. The videos plays fine, but the message is getting annoying...
It says: "Failed to init Video filters/scalers - falling back to bilinear scaling"

Although my scaling was set to "auto", I switched it to "Bilinear" and set "apply to all videos". But the message keeps on showing (for about two seconds).

Debug log:
http://xbmclogs.com/show.php?id=113762
(line 836)

(I see now that the option "scan library on startup" was on, I'll put that off next time. The debug log is rather long now...)

Mac Mini 2 (Intel Core 2 Duo, Intel GMA 950), OSX (10.7.5), XBMC Gotham (13), Aeon Nox (5.0.3)
(This post was last modified: 2014-01-21 20:44 by Zokkel.)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,198
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #2
Is there a reason that you run the 64bit build of XBMC on a 32bit version of OSX? Does the same thing happen on the 32bit version? (e.x. i386)

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Zokkel Offline
Member
Posts: 89
Joined: Apr 2012
Reputation: 1
Location: Bruges, Belgium
Post: #3
Nope,
When you guys created the 64bit-file, I thought: let's try that one. Worked for me since Frodo 12.0.

So I tried the i386 version: same problem.

What I did find out (played a bit with the render method in system prefs):
GLSL: gives me the error but plays anyway and uses 50% of my CPU
ARB: the same
Auto: the same
Software: No error, plays just fine, but uses 70% of my CPU! That's a lot, isn't it? (with a 1080p file it is 110%, with peaks at 140% (how is that even possible?))

No noticable difference in quality of the video displayed.

Mac Mini 2 (Intel Core 2 Duo, Intel GMA 950), OSX (10.7.5), XBMC Gotham (13), Aeon Nox (5.0.3)
(This post was last modified: 2014-01-21 18:10 by Zokkel.)
find quote
Zokkel Offline
Member
Posts: 89
Joined: Apr 2012
Reputation: 1
Location: Bruges, Belgium
Post: #4
XBMC is also randomly crashing when I'm opening video files.
I couldn't repeat a randomly one while debugging, but I found one where it ALWAYS crashes.

Had no problem opening that kind of files in Frodo 12.3

debug log:
http://xbmclogs.com/show.php?id=113895

Not sure if this is connected to my original post, otherwis I'll make an other thread

Mac Mini 2 (Intel Core 2 Duo, Intel GMA 950), OSX (10.7.5), XBMC Gotham (13), Aeon Nox (5.0.3)
find quote
Zokkel Offline
Member
Posts: 89
Joined: Apr 2012
Reputation: 1
Location: Bruges, Belgium
Post: #5
This is a movie that sometimes play and other times won't play. Without changing any of the settings.

Debug log when it went wrong:
http://xbmclogs.com/show.php?id=113944

Mac Mini 2 (Intel Core 2 Duo, Intel GMA 950), OSX (10.7.5), XBMC Gotham (13), Aeon Nox (5.0.3)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,198
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #6
No errors in the last one. What kind of mac are you using - is there a reason that you have deactivated hardware decoding (vda)?

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Zokkel Offline
Member
Posts: 89
Joined: Apr 2012
Reputation: 1
Location: Bruges, Belgium
Post: #7
Enabled hardware decoding again (tried to put that off for the video rendering problem).
The file played once like it should, when i tried a similar file again crashes. And now I can't play any of those files anymore without crashing.
These are all files I encoded myself. But they played fine in Frodo.

Video specs:

Code:
General
Complete name                            : \\NEWYORK\JoLo\Foto's\Reizen\2013.11.18-2013.11.22 - Centerparks Erperheide\MVI_1053_19-11-2013.mp4
Format                                   : MPEG-4
Format profile                           : Base Media
Codec ID                                 : isom
File size                                : 6.23 MiB
Duration                                 : 30s 953ms
Overall bit rate mode                    : Variable
Overall bit rate                         : 1 689 Kbps
Encoded date                             : UTC 2013-11-22 10:23:55
Tagged date                              : UTC 2013-11-22 10:23:55

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L5.1
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 2 frames
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 30s 950ms
Bit rate                                 : 1 500 Kbps
Maximum bit rate                         : 2 146 Kbps
Width                                    : 640 pixels
Height                                   : 480 pixels
Display aspect ratio                     : 4:3
Frame rate mode                          : Constant
Frame rate                               : 20.000 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.244
Stream size                              : 5.54 MiB (89%)
Writing library                          : x264 core 129 r2230 1cffe9f
Encoding settings                        : cabac=1 / ref=2 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=10 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=1 / b_pyramid=0 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=60 / rc=2pass / mbtree=1 / bitrate=1500 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
Encoded date                             : UTC 2013-11-22 10:23:55
Tagged date                              : UTC 2013-11-22 10:23:55

Audio
ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : LC
Codec ID                                 : 40
Duration                                 : 30s 953ms
Bit rate mode                            : Variable
Bit rate                                 : 185 Kbps
Maximum bit rate                         : 192 Kbps
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz
Compression mode                         : Lossy
Stream size                              : 699 KiB (11%)
Encoded date                             : UTC 2013-11-22 10:23:55
Tagged date                              : UTC 2013-11-22 10:23:55


Mac specs:
Model: Macmini2,1, BootROM MM21.009A.B00, 2 processors, Intel Core 2 Duo, 1.83 GHz, 2 GB
Graphics: kHW_IntelGMA950Item, GMA 950, spdisplays_builtin, spdisplays_integrated_vram
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x86), 1.4.16.2
Bluetooth: Version 2.1.8f2, 2 service, 1 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Serial ATA Device: Hitachi HTS542580K9SA00, 74,53 GB
Parallel ATA Device: MATSHITACD-RW CW-8124
USB Device: U3 Cruzer Micro, (null) mA
USB Device: Dell USB Mouse, (null) mA
USB Device: USB Keyboard, (null) mA
USB Device: Bluetooth USB Host Controller, (null) mA
USB Device: IR Receiver, (null) mA

Mac Mini 2 (Intel Core 2 Duo, Intel GMA 950), OSX (10.7.5), XBMC Gotham (13), Aeon Nox (5.0.3)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,198
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #8
Post the crashreporter file to pastebin.com and put the link in here. I also have a GMA950 Hackbook and don't see anything similar (never seen gpu shader errors like in your first log file before).

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Zokkel Offline
Member
Posts: 89
Joined: Apr 2012
Reputation: 1
Location: Bruges, Belgium
Post: #9
Well, since I left the render method to "software", I don't have a error message anymore.
Just a huge CPU-usage (but the mac mini seems to handle it just fine)

It keeps on crashing randomly when I want to start a video, sometimes it plays, sometimes not.

Here's the OSX crash report:
http://pastebin.com/gHESwUys

Mac Mini 2 (Intel Core 2 Duo, Intel GMA 950), OSX (10.7.5), XBMC Gotham (13), Aeon Nox (5.0.3)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,198
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #10
Can you post a handfull of other crash reports as well so that i can verify that it is always the same cause?

And what are you using to encode your files?

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
(This post was last modified: 2014-01-22 12:29 by Memphiz.)
find quote
Zokkel Offline
Member
Posts: 89
Joined: Apr 2012
Reputation: 1
Location: Bruges, Belgium
Post: #11
I use Mediacoder 64 (on a windows machine) to convert my videos from my home-camera,
Those files result in a crash in about 90% of the cases,

Other files (randomly from internet) crashes about 50% of the cases.
I see no structure at all when XBMC crashes or not. Like I said, sometimes the same video plays, the other time it just crashes.

I've noticed something new now: in some videos appear a green bar in the bottom of the video. Tried to set all settings back to default, but no luck here...

Here are some crash reports.
http://pastebin.com/ym2DdCKZ
http://pastebin.com/G30VYRp7
http://pastebin.com/4bPewkWn
http://pastebin.com/aCQpFnPV

Found some logic in it: DivX and Xvid never result in a crash! It's only the h264 and the AVC1 codecs,
Can it be that there's a temperaly lack of memory or CPU that results in a crash? Although whit Frodo was that never an issue.
And also: the movies that I encoded myself are barely 10MB

Mac Mini 2 (Intel Core 2 Duo, Intel GMA 950), OSX (10.7.5), XBMC Gotham (13), Aeon Nox (5.0.3)
find quote
Zokkel Offline
Member
Posts: 89
Joined: Apr 2012
Reputation: 1
Location: Bruges, Belgium
Post: #12
I switched render method back to GLSL.
I keep getting the error message, but all the video are playing fine.

Well fine... my audio is out of sync and my subtitles too
Luckely it's the same for all my video's, so I use the "set as default for all movies".

I've tried the A/V sync options, but that had no result.

Mac Mini 2 (Intel Core 2 Duo, Intel GMA 950), OSX (10.7.5), XBMC Gotham (13), Aeon Nox (5.0.3)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,198
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #13
There must be something with your decoder settings which leads to that crash (which is always the same crash and is located in ffmpeg somewhere).

Code:
cabac=1 / ref=2 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=10 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=1 / b_pyramid=0 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=60 / rc=2pass / mbtree=1 / bitrate=1500 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00

Are you certain that those encoder setttings are inside the h.264 spec?

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
(This post was last modified: 2014-01-23 12:59 by Memphiz.)
find quote
Zokkel Offline
Member
Posts: 89
Joined: Apr 2012
Reputation: 1
Location: Bruges, Belgium
Post: #14
I sure hope so. I'm using a preset in the Mediacoder program.
Also no other player has trouble playing those files. On mac or Windows.

But like I said: I switch back to the GLSL rendering. Everything plays normal again in XBMC, no more crashes.
And I think I can live with the (2 second) error coming up every time I start a video.

Thanks for the effort!

Mac Mini 2 (Intel Core 2 Duo, Intel GMA 950), OSX (10.7.5), XBMC Gotham (13), Aeon Nox (5.0.3)
find quote
username_in_use Offline
Junior Member
Posts: 14
Joined: Oct 2012
Reputation: 0
Post: #15
same message on a gm950 macbook here with alpha11 compiled on 1 jan 2014 and nightlybuild 0202 and 0602.

No message on screen while playing video on alpha11 compiled on 1 dec 2013


Code:
00:23:37 T:140735140825440  NOTICE: Starting XBMC (13.0-ALPHA11 Git:20131201-91e5be5). Platform: x86 Darwin OSX 64-bit
00:23:37 T:140735140825440  NOTICE: Using Debug XBMC x64 build, compiled Dec  1 2013 by Clang 4.2.0 for x86 Darwin OSX 64-bit version 1060
00:23:37 T:140735140825440  NOTICE: Running on Darwin OSX 32-bit 11.4.2 i386, Version 10.7.5 (Build 11G63)
00:23:37 T:140735140825440  NOTICE: Host CPU: Intel(R) Core(TM)2 CPU T7400 @ 2.16GHz, 2 cores available
[......]
00:23:38 T:140735140825440  NOTICE: GL_VENDOR = Intel Inc.
00:23:38 T:140735140825440  NOTICE: GL_RENDERER = Intel GMA 950 OpenGL Engine
00:23:38 T:140735140825440  NOTICE: GL_VERSION = 1.4 APPLE-7.4.1
00:23:38 T:140735140825440  NOTICE: GL_SHADING_LANGUAGE_VERSION = 1.20
[......]
00:23:57 T:4584968192   DEBUG: Open - av_find_stream_info finished
00:23:57 T:4584968192  NOTICE: Opening video stream: 0 source: 256
00:23:57 T:4584968192  NOTICE: Creating video codec with codec id: 28
00:23:57 T:4584968192   DEBUG: CDVDFactoryCodec: compiled in hardware support: VDADecoder:yes VideoToolBoxDecoder:no CrystalHD:yes AMCodec:no MediaCodec:no OpenMax:no libstagefright:no
00:23:57 T:4584968192   DEBUG: FactoryCodec - Video: vda- - Opening
00:23:57 T:4584968192  NOTICE: Open - VDADecoder Codec failed to open, currently in use by another process
00:23:57 T:4584968192   DEBUG: FactoryCodec - Video: vda-h264 - Failed
00:23:57 T:4584968192   DEBUG: FactoryCodec - Video:  - Opening
00:23:57 T:4584968192   DEBUG: DllPostProc: Using libpostproc system library
00:23:57 T:4584968192  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
00:23:57 T:4584968192   DEBUG: FactoryCodec - Video: ff-h264 - Opened
00:23:57 T:4584968192  NOTICE: Creating video thread
00:23:57 T:4632186880  NOTICE: Thread DVDPlayerVideo start, auto delete: false
00:23:57 T:4632186880  NOTICE: running thread: video_thread
00:23:57 T:4584968192  NOTICE: Opening audio stream: 1 source: 256
00:23:57 T:4584968192  NOTICE: Finding audio codec for: 86018
00:23:57 T:4632186880   DEBUG: CDVDPlayerVideo - CDVDMsg::GENERAL_SYNCHRONIZE
00:23:57 T:4584968192   DEBUG: FactoryCodec - Audio: passthrough - Opening
00:23:57 T:4584968192   DEBUG: FactoryCodec - Audio: passthrough - Failed
00:23:57 T:4584968192   DEBUG: FactoryCodec - Audio: FFmpeg - Opening
00:23:57 T:4584968192   DEBUG: FactoryCodec - Audio: FFmpeg - Opened
00:23:57 T:4584968192  NOTICE: Creating audio thread
00:23:57 T:4632723456  NOTICE: Thread DVDPlayerAudio start, auto delete: false
00:23:57 T:4632723456  NOTICE: running thread: CDVDPlayerAudio::Process()
00:23:57 T:4584968192   DEBUG: OnPlayBackStarted : play state was 1, starting 1
00:23:57 T:4584968192   DEBUG: CDVDPlayer::SetCaching - caching state 3
00:23:57 T:4632186880   DEBUG: CDVDPlayerVideo - CDVDMsg::GENERAL_RESYNC(0.000000, 1)
00:23:57 T:4584968192   DEBUG: CDVDPlayer::CheckContinuity - wrapback :2, prev:83416.666667, curr:41708.333333, diff:-41708.333333
00:23:57 T:4632186880    INFO: CDVDPlayerVideo - Stillframe left, switching to normal playback
00:23:57 T:4632186880   ERROR: VDA::CDecoder - Failed to init VDA decoder: -12473
00:23:57 T:4632723456   ERROR: Previous line repeats 1 times.
00:23:57 T:4632723456  NOTICE: Creating audio stream (codec id: 86018, channels: 2, sample rate: 48000, no pass-through)
00:23:57 T:4632723456    INFO: CCoreAudioAE::MakeStream - AE_FMT_FLOAT, 48000, 48000, FL,FR
00:23:57 T:140735140825440   DEBUG: PlayFile : OpenFile succeed, play state 2
00:23:57 T:140735140825440   DEBUG: OnPlayBackStarted : play state was 2, starting 0
00:23:57 T:4632186880  NOTICE:  fps: 23.976024, pwidth: 720, pheight: 404, dwidth: 720, dheight: 404
00:23:57 T:4632186880   DEBUG: OutputPicture - change configuration. 720x404. framerate: 23.98. format: YV12
00:23:57 T:4632186880   DEBUG: Resolution 1920x1080@ 60.00 - Full Screen (16) not a very good match for fps 23.976 (weight: 0.166), trying 2:3 cadence
00:23:57 T:4632186880  NOTICE: Display resolution ADJUST : 1920x1080@ 60.00 - Full Screen (16) (weight: 0.001)
00:23:57 T:4632186880   DEBUG: CXBMCRenderManager::Configure - 3
00:23:57 T:140735140825440  NOTICE: Using GL_TEXTURE_2D
00:23:57 T:140735140825440   DEBUG: GL: Requested render method: 0
00:23:57 T:140735140825440  NOTICE: GL: ARB shaders support detected
00:23:57 T:140735140825440   DEBUG: GL: YUV2RGBProgressiveShaderARB: loading yuv2rgb_basic_2d.arb
00:23:57 T:140735140825440  NOTICE: GL: Selecting Single Pass ARB YUV2RGB shader
00:23:57 T:140735140825440  NOTICE: GL: No vertex shader, fixed pipeline in use
00:23:57 T:140735140825440  NOTICE: GL: NPOT texture support detected
00:23:57 T:140735140825440  NOTICE: GL: Using GL_ARB_pixel_buffer_object
0
with error on screen when starting video
Code:
00:19:45 T:140735140825440  NOTICE: Starting XBMC (13.0-ALPHA11 Git:20131231-8eb49b3). Platform: x86 Darwin OSX 64-bit
00:19:45 T:140735140825440  NOTICE: Using Debug XBMC x64 build, compiled Jan  1 2014 by Clang 4.2.0 for x86 Darwin OSX 64-bit version 1060
00:19:45 T:140735140825440  NOTICE: Running on Darwin OSX 32-bit 11.4.2 i386, Version 10.7.5 (Build 11G63)
00:19:45 T:140735140825440  NOTICE: Host CPU: Intel(R) Core(TM)2 CPU T7400 @ 2.16GHz, 2 cores available
[......]
00:19:45 T:140735140825440  NOTICE: GL_VENDOR = Intel Inc.
00:19:45 T:140735140825440  NOTICE: GL_RENDERER = Intel GMA 950 OpenGL Engine
00:19:45 T:140735140825440  NOTICE: GL_VERSION = 1.4 APPLE-7.4.1
00:19:45 T:140735140825440  NOTICE: GL_SHADING_LANGUAGE_VERSION = 1.20
[......]
00:20:10 T:4591579136   DEBUG: Open - av_find_stream_info finished
00:20:10 T:4591579136  NOTICE: Opening video stream: 0 source: 256
00:20:10 T:4591579136  NOTICE: Creating video codec with codec id: 28
00:20:10 T:4591579136   DEBUG: CDVDFactoryCodec: compiled in hardware support: VDADecoder:yes VideoToolBoxDecoder:no CrystalHD:yes AMCodec:no MediaCodec:no OpenMax:no libstagefright:no
00:20:10 T:4591579136   DEBUG: FactoryCodec - Video: vda- - Opening
00:20:10 T:4591579136  NOTICE: Open - VDADecoder Codec failed to open, currently in use by another process
00:20:10 T:4591579136   DEBUG: FactoryCodec - Video: vda-h264 - Failed
00:20:10 T:4591579136   DEBUG: FactoryCodec - Video:  - Opening
00:20:10 T:4591579136   DEBUG: DllPostProc: Using libpostproc system library
00:20:10 T:4591579136  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
00:20:10 T:4591579136   DEBUG: FactoryCodec - Video: ff-h264 - Opened
00:20:10 T:4591579136  NOTICE: Creating video thread
00:20:10 T:4605898752  NOTICE: Thread DVDPlayerVideo start, auto delete: false
00:20:10 T:4605898752  NOTICE: running thread: video_thread
00:20:10 T:4591579136  NOTICE: Opening audio stream: 1 source: 256
00:20:10 T:4591579136  NOTICE: Finding audio codec for: 86018
00:20:10 T:4605898752   DEBUG: CDVDPlayerVideo - CDVDMsg::GENERAL_SYNCHRONIZE
00:20:10 T:4591579136   DEBUG: FactoryCodec - Audio: passthrough - Opening
00:20:10 T:4591579136   DEBUG: FactoryCodec - Audio: passthrough - Failed
00:20:10 T:4591579136   DEBUG: FactoryCodec - Audio: FFmpeg - Opening
00:20:10 T:4591579136   DEBUG: FactoryCodec - Audio: FFmpeg - Opened
00:20:10 T:4591579136  NOTICE: Creating audio thread
00:20:10 T:4606435328  NOTICE: Thread DVDPlayerAudio start, auto delete: false
00:20:10 T:4606435328  NOTICE: running thread: CDVDPlayerAudio::Process()
00:20:10 T:4591579136   DEBUG: OnPlayBackStarted : play state was 1, starting 1
00:20:10 T:4591579136   DEBUG: CDVDPlayer::SetCaching - caching state 3
00:20:10 T:4605898752   DEBUG: CDVDPlayerVideo - CDVDMsg::GENERAL_RESYNC(0.000000, 1)
00:20:10 T:4591579136   DEBUG: CDVDPlayer::CheckContinuity - wrapback :2, prev:83416.666667, curr:41708.333333, diff:-41708.333333
00:20:10 T:4605898752    INFO: CDVDPlayerVideo - Stillframe left, switching to normal playback
00:20:10 T:4605898752   ERROR: VDA::CDecoder - Failed to init VDA decoder: -12473
00:20:10 T:4606435328   ERROR: Previous line repeats 1 times.
00:20:10 T:4606435328  NOTICE: Creating audio stream (codec id: 86018, channels: 2, sample rate: 48000, no pass-through)
00:20:10 T:4606435328    INFO: CCoreAudioAE::MakeStream - AE_FMT_FLOAT, 48000, 48000, FL,FR
00:20:10 T:4605898752  NOTICE:  fps: 23.976024, pwidth: 720, pheight: 404, dwidth: 720, dheight: 404
00:20:10 T:4605898752   DEBUG: OutputPicture - change configuration. 720x404. framerate: 23.98. format: YV12
00:20:10 T:4605898752   DEBUG: Resolution 1920x1080@ 60.00 - Full Screen (16) not a very good match for fps 23.976 (weight: 0.166), trying 2:3 cadence
00:20:10 T:4605898752  NOTICE: Display resolution ADJUST : 1920x1080@ 60.00 - Full Screen (16) (weight: 0.001)
00:20:10 T:4605898752   DEBUG: CXBMCRenderManager::Configure - 3
00:20:10 T:140735140825440   DEBUG: Activating window ID: 12005
00:20:10 T:140735140825440   DEBUG: ------ Window Deinit (MyVideoNav.xml) ------
00:20:10 T:140735140825440   DEBUG: ------ Window Init (VideoFullScreen.xml) ------
00:20:10 T:140735140825440    INFO: Loading skin file: VideoFullScreen.xml, load type: KEEP_IN_MEMORY
00:20:10 T:140735140825440   DEBUG: Load VideoFullScreen.xml: 26.58ms
00:20:10 T:140735140825440   DEBUG: Alloc resources: 27.74ms  (26.65 ms skin load)
00:20:10 T:140735140825440   DEBUG: PlayFile : OpenFile succeed, play state 2
00:20:10 T:140735140825440   DEBUG: OnPlayBackStarted : play state was 2, starting 0
00:20:10 T:4591579136   DEBUG: CDVDPlayer::SetCaching - caching state 0
00:20:10 T:4606435328   DEBUG: CCoreAudioHardware::ResetAudioDevices resetting our devices to LPCM
00:20:10 T:4606435328   DEBUG: CCoreAudioHardware::ResetAudioDevices 1 streams for device Built-in Output
00:20:10 T:4606435328   DEBUG: CCoreAudioStream::Open: Opened stream 0x0023.
00:20:10 T:4606435328   DEBUG: CCoreAudioStream::Close: Closed stream 0x0023.
00:20:10 T:4606435328   DEBUG: CCoreAudioHardware::FindAudioDevice: Searching for device - Built-in Output.
00:20:10 T:4606435328   ERROR: CCoreAudioDevice::SupportsMixing: Device mixing support : 'No'.
00:20:10 T:140735140825440  NOTICE: Using GL_TEXTURE_2D
00:20:10 T:140735140825440   DEBUG: GL: Requested render method: 0
00:20:10 T:140735140825440  NOTICE: GL: ARB shaders support detected
00:20:10 T:140735140825440   DEBUG: GL: YUV2RGBProgressiveShaderARB: loading yuv2rgb_basic_2d.arb
00:20:10 T:4606435328   DEBUG: CCoreAudioGraph::CreateMixMap: Source Stream Layout: [Left] [Right]
00:20:10 T:4606435328   DEBUG: CCoreAudioGraph::CreateMixMap: User-Configured Speaker Layout: [Left] [Right]
00:20:10 T:4606435328   DEBUG: CCoreAudioGraph::CreateMixMap: Output Device Layout: [Unknown] [Unknown]
00:20:10 T:4606435328   DEBUG: CCoreAudioMixMap::CreateMap: No pre-defined mapping from 2 to 2 channels, building diagonal matrix.
00:20:10 T:4606435328   DEBUG: CCoreAudioMixMap::Rebuild 0 = 0.000000
00:20:10 T:4606435328   DEBUG: CCoreAudioMixMap::Rebuild 1 = 0.000000
00:20:10 T:140735140825440  NOTICE: GL: Selecting Single Pass ARB YUV2RGB shader
00:20:10 T:140735140825440  NOTICE: GL: No vertex shader, fixed pipeline in use
00:20:10 T:140735140825440   ERROR: GL: GLSL shaders not supported
00:20:10 T:140735140825440   ERROR: GL: Error compiling and linking video filter shader
00:20:10 T:140735140825440   ERROR: GL: Falling back to bilinear due to failure to init scaler
00:20:10 T:140735140825440  NOTICE: GL: NPOT texture support detected
00:20:10 T:140735140825440  NOTICE: GL: Using GL_ARB_pixel_buffer_object
00:20:10 T:4606435328   DEBUG: CCoreAudioMixMap::SetMixingMatrix channel 0 = [1, 0, ]
00:20:10 T:4606435328   DEBUG: CCoreAudioMixMap::SetMixingMatrix channel 1 = [0, 1, ]
00:20:10 T:4606435328   DEBUG: CCoreAudioGraph::Open: Mixer Output Format: 2 channels, 48.0 kHz, 32 bits, 4 bytes per frame
00:20:10 T:4606435328   DEBUG: CCoreAudioGraph::Open: audioUnit, Input Stream Format  [lpcm] Mixable Non-Interleaved 2 Channel 32-bit Floating Point LE (48000Hz)
00:20:10 T:4606435328   DEBUG: CCoreAudioGraph::Open: audioUnit, Output Stream Format [lpcm] Mixable Non-Interleaved 2 Channel 32-bit Floating Point LE (44100Hz)
00:20:10 T:4606435328   DEBUG: CCoreAudioGraph::Open: mixerUnit, Input Stream Format  [lpcm] Mixable Non-Interleaved 2 Channel 32-bit Floating Point LE (48000Hz)
00:20:10 T:4606435328   DEBUG: CCoreAudioGraph::Open: mixerUnit, Output Stream Format [lpcm] Mixable Non-Interleaved 2 Channel 32-bit Floating Point LE (48000Hz)
00:20:10 T:4606435328   DEBUG: CCoreAudioGraph::Open: inputUnit, Input Stream Format  [lpcm] Mixable Interleaved 2 Channel 32-bit Floating Point LE (48000Hz)
00:20:10 T:4606435328   DEBUG: CCoreAudioGraph::Open: inputUnit, Output Stream Format [lpcm] Mixable Non-Interleaved 2 Channel 32-bit Floating Point LE (48000Hz)
find quote
Post Reply