[MOD] reFocus light for Raspberry Pi

  Thread Rating:
  • 6 Votes - 2.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Galefury Offline
Fan
Posts: 356
Joined: Dec 2009
Reputation: 9
Location: Bucharest, EU
Post: #46
Thanks for you efforts, mate. I'll give it a go.

reFocus - Simply the best
find quote
postdeath Offline
Junior Member
Posts: 37
Joined: Dec 2013
Reputation: 0
Post: #47
Awesome job, dude - thanks Smile
find quote
Dimitriss Offline
Junior Member
Posts: 35
Joined: Jan 2014
Reputation: 0
Post: #48
Very nice job. I found a bug with subtitles, during playback when i choose "get subtitles" nothing comes up.
find quote
freem@n Offline
Senior Member
Posts: 148
Joined: Apr 2013
Reputation: 5
Post: #49
(2014-02-15 17:42)Dimitriss Wrote:  Very nice job. I found a bug with subtitles, during playback when i choose "get subtitles" nothing comes up.

I assume you are using the Gotham alpha version. make sure to install the right version for your XBMC. and did you install at least one subtitle service? (in the add-ons menu)
because it is working for me so far.

[Image: all-thin-banner.jpg]
HTPC OpenELEC 4.0.x - Xperience1080+
RPi XBian 1.0 RC2 - reFocus light “Raspberry Pi Edition“
find quote
Galefury Offline
Fan
Posts: 356
Joined: Dec 2009
Reputation: 9
Location: Bucharest, EU
Post: #50
Two rows banners view doesn't have the title of the show. The same for movies in covers view.

reFocus - Simply the best
(This post was last modified: 2014-02-18 10:21 by Galefury.)
find quote
freem@n Offline
Senior Member
Posts: 148
Joined: Apr 2013
Reputation: 5
Post: #51
@Galefury: sorry, but I can't see your pictures. it's probably a permission issue with your dropbox, so better put them directly in your public folder.

[Image: all-thin-banner.jpg]
HTPC OpenELEC 4.0.x - Xperience1080+
RPi XBian 1.0 RC2 - reFocus light “Raspberry Pi Edition“
find quote
Galefury Offline
Fan
Posts: 356
Joined: Dec 2009
Reputation: 9
Location: Bucharest, EU
Post: #52
I edited my post. Can you see them now ?

reFocus - Simply the best
find quote
freem@n Offline
Senior Member
Posts: 148
Joined: Apr 2013
Reputation: 5
Post: #53
@Galefury: yeah, now I can see them Smile You're right the window title is missing, it should be the "TV Shows Title" and "Movies Title" headline there, I'll look into it. but the name of the show is not on top of the banners, but at the bottom (default behaviour in reFocus).

[Image: all-thin-banner.jpg]
HTPC OpenELEC 4.0.x - Xperience1080+
RPi XBian 1.0 RC2 - reFocus light “Raspberry Pi Edition“
find quote
Scott00007 Offline
Senior Member
Posts: 140
Joined: Sep 2013
Reputation: 0
Post: #54
This is not ReFocus as it was originally made and I think that it deserves it's own splash screen when XBMC. Freem@n has enough on his plate without worrying about this sort of thing and as I am no photoshop expert I was hoping that someone who was more skilled than me with photoshop/GIMP ect. could come up with a new splash screen or two.
find quote
Scott00007 Offline
Senior Member
Posts: 140
Joined: Sep 2013
Reputation: 0
Post: #55
I have just installed the latest version of the skin (the .zip file is still saying that the structure is wrong when I try to install it...am I naming it wrong?) and I am loving how snappy it is. I have noticed that the changes you made to the shutdown menu has removed the option to hide the system menu......that is something that I feel should remain an option...please add it back!!
find quote
freem@n Offline
Senior Member
Posts: 148
Joined: Apr 2013
Reputation: 5
Post: #56
(2014-02-17 06:47)Scott00007 Wrote:  This is not ReFocus as it was originally made and I think that it deserves it's own splash screen when XBMC.

yeah. it would be really cool if someone could make a new skin logo with the overall style. I have too little experience with Photoshop to do so.

(2014-02-17 07:14)Scott00007 Wrote:  I have noticed that the changes you made to the shutdown menu has removed the option to hide the system menu......that is something that I feel should remain an option...please add it back!!

I'm not sure why it is reported as wrong structure... maybe someone can send me a xbmc.log right after you tried to install the zip.


[Image: shutdown_menu_gotham.JPG]

every entry in the shutdown menu is still there, I just changed the behavior to a scroll list. On the Raspberry Pi (main target platform) you only have 5 options and the default shutdown menu was way too big so I decided to make it a bit smaller. if you are using the skin on a different platform where you have more options you can scroll through the list. if you don't like this step you can send me your idea. :)

[Image: all-thin-banner.jpg]
HTPC OpenELEC 4.0.x - Xperience1080+
RPi XBian 1.0 RC2 - reFocus light “Raspberry Pi Edition“
(This post was last modified: 2014-02-17 21:16 by freem@n.)
find quote
ian-ep Offline
Junior Member
Posts: 10
Joined: Mar 2012
Reputation: 0
Post: #57
I have a couple of issues with the latest update. The homescreen background is completely black nomatter how I set the background settings. All other screens seem to use the correct theme background.

Also, I can't seem to get the visualisation to show when playing music. Can't live without Waveform!

Ian
find quote
freem@n Offline
Senior Member
Posts: 148
Joined: Apr 2013
Reputation: 5
Post: #58
@ian-ep: please report what version of XBMC and which skin version you are running (12.?/13.0 alpha). In addition to that I'd like to know which device and software you are using. Everything is fine with the homescreen backgrounds over here, so the problem is most likely something with your exact setup. maybe your guisettings.xml is messed up, you could try a clean one.

I look into that visualization issue, I recently added artist fanart to the music player window...

---------------------------------------------------

(2014-02-16 12:09)Galefury Wrote:  Two rows banners view doesn't have the title of the show. The same for movies in covers view. See below.

https://www.dropbox.com/s/kl2rfvk9fkmaqo....00.25.jpg

https://www.dropbox.com/s/osu3jwpd7okf7p....59.53.jpg

Window titles should be working in Gotham now :) thanks for reporting, I also fixed a couple of related issues.

[Image: screenshot001.png]

[Image: all-thin-banner.jpg]
HTPC OpenELEC 4.0.x - Xperience1080+
RPi XBian 1.0 RC2 - reFocus light “Raspberry Pi Edition“
(This post was last modified: 2014-02-17 21:08 by freem@n.)
find quote
Scott00007 Offline
Senior Member
Posts: 140
Joined: Sep 2013
Reputation: 0
Post: #59
Ha Ha...thanks for the information on the scroll list. I did not realize that it was like that.

When you say send you a log do you mean use the log uploader or some other process?

Thanks.
find quote
freem@n Offline
Senior Member
Posts: 148
Joined: Apr 2013
Reputation: 5
Post: #60
(2014-02-18 02:25)Scott00007 Wrote:  When you say send you a log do you mean use the log uploader or some other process?

either that or post it manually to some site like pastebin. but save it right after you get the installation error message, I don't want to browse through your whole XBMC history ;-)

[Image: all-thin-banner.jpg]
HTPC OpenELEC 4.0.x - Xperience1080+
RPi XBian 1.0 RC2 - reFocus light “Raspberry Pi Edition“
find quote
Post Reply