Solved Issue - Tak decoding in gotham?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
jjd-uk Offline
Team-Kodi Member
Posts: 3,241
Joined: Oct 2011
Reputation: 62
Post: #16
(2014-01-28 13:13)phate89 Wrote:  Yes i mean that with dvdplayer works.
I also followed your advice and with your suggestion it works by default (you actually forgot to close the rules tag but i fixed it), thanks!

I still don't understand if it's wanted that xbmc doesn't switch automatically to DVDPlayer...

I think that wiki entry dates back to before PAPlayer was rewritten for the new AudioEngine which is the audio core of XBMC, I don't believe that fallback still happens.

(2014-01-28 13:37)Martijn Wrote:  sounds like a bug to me as paplayer should be able to play it. probably some audio hook missing

Not sure how audio codecs are handled in PAPlayer, it could be possible that they are hardcoded so PAPlayer only expects certain formats in which case it's not a bug but a feature request either way it's probably good to run it past fritsch & FernetMenta.

phate89, could you raise a ticket on our bugtracker (link at the top of forum), make sure to include the following:

* Debug log showing failed playback (with playercorefactory file temporally removed)
* Debug log showing successful playback (with playercorefactory file)
* A copy of the playcorefactory file that enables successful playback via DVDPlayer.
* A Tak audio file as a sample uploaded to somewhere like Dropbox, Google Drive, Skydrive

If it's a bug then it maybe fixed for Gotham, if it's requires a feature change it won't be, either way we need to get our audio dev's to have a look.
(This post was last modified: 2014-01-28 14:27 by jjd-uk.)
find quote
phate89 Offline
Senior Member
Posts: 271
Joined: Nov 2012
Reputation: 4
Post: #17
(2014-01-28 14:00)jjd-uk Wrote:  phate89, could you raise a ticket on our bugtracker (link at the top of forum), make sure to include the following:

* Debug log showing failed playback (with playercorefactory file temporally removed)
* Debug log showing successful playback (with playercorefactory file)
* A copy of the playcorefactory file that enables successful playback via DVDPlayer.
* A Tak audio file as a sample uploaded to somewhere like Dropbox, Google Drive, Skydrive

If it's a bug then it maybe fixed for Gotham, if it's requires a feature change it won't be, either way we need to get our audio dev's to have a look.

I did it:
http://trac.xbmc.org/ticket/14886
Should i close this thread as solved?
find quote
uNiversal Offline
Out of Memory
Posts: 5,620
Joined: Oct 2012
Reputation: 138
Location: Binary pulsar
Post: #18
Yes. your issue is solved Wink This will enable others to see solution(s) even if xbmc code does this automatically some other way in future.

Though the complete solution is post 2 and post 11 which others may need to know. So you can post the full solution and refer to it in meanwhile.
find quote
uNiversal Offline
Out of Memory
Posts: 5,620
Joined: Oct 2012
Reputation: 138
Location: Binary pulsar
Post: #19
And to follow up here it is https://github.com/xbmc/xbmc/commit/b2e9...1b3c8b88f6

After that this workaround shouldn't be necessary anymore and thus BUG is resolved Wink

Thx Fernet. Big Grin
find quote
Post Reply