TVServerXBMC too old

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
ntompson Offline
Junior Member
Posts: 4
Joined: Feb 2014
Reputation: 0
Post: #1
Hi,

I have a stable and functioning MediaPortal installation on a Windows box - my current HTPC setup. MediaPortal version is 1.5. Newer versions are problematic, so 1.5 is as far forward as I go for now.

I am now dabbling with XBMC - contemplating keeping the MediaPortal backend, but using XBMC as the client. PVR is mandatory for this...

So I have successfully installed and configured the TVServerXBMC plugin to the MediaPortal TVServer (using the latest version appropriate for 1.5).

When I activate the MediaPortal PVR add-on in XBMC, I get told that the TVServerXBMC plugin is too old. I assume that it is expecting to see a version associated with MP 1.6.

This is frustrating, as I will not go beyond MP 1.5. Surely the PVR add-on needs to be able to work with a range of TVServerXBMC plugins - each version appropriate to the MP version.

Any ideas? Are there older versions of the PVR add-on I could use which would be satisfied with MP1.5?

Thanks,

Nick
find quote
nickr Online
Donor
Posts: 7,397
Joined: May 2009
Reputation: 126
Location: Christchurch NZ
Post: #2
Are you saying that the latest mediaportal pvr plugin is not backwards compatible with mediaportal 1.5? If so, that sucks.

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
t-magnus Offline
Member
Posts: 64
Joined: Aug 2013
Reputation: 1
Post: #3
Have you tired to use 1.6 TVSERVERXBMC plug-in with your 1.5 MePo install? You can manually install it if the installer won't work.
find quote
ntompson Offline
Junior Member
Posts: 4
Joined: Feb 2014
Reputation: 0
Post: #4
That's a good question. No, it is not compatible - MePo is very particular about versioning. I have attempted to install the 1.6 version of the TVServerXBMC plugin, but the MPEI warns about the version inconsistency (although allows the install to proceed), and the TVServer won't even load the plugin.

Chances are there is nothing actually incompatible about the two, but if the version numbers don't line up, game over...

Older version of PVR add-on perhaps?
find quote
t-magnus Offline
Member
Posts: 64
Joined: Aug 2013
Reputation: 1
Post: #5
Something is strange because I just upgraded to 1.6 TV Server on Feb 1st... So 1.5 worked in both Frodo and Gotham for me.

In XBMC did you install the PVR add-on form the XBMC PVR Repository, or did you enable the one already installed. It would have been listed under DISABLED add-ons or XBMC would have opened the window automatically when you enabled LiveTV without a PVR add-on enabled. The version that installs with XBMC is the correct one.
find quote
ntompson Offline
Junior Member
Posts: 4
Joined: Feb 2014
Reputation: 0
Post: #6
Yes - I see what you mean - that is odd.

I think I just enabled the one that was already there - although I have to confess I'm new to XBMC, so I'm not exactly sure the difference between the two methods you mention. I would guess that I just followed the prompts when I first attempted to enable LiveTV.

I wonder... is there a way to test the TVServerXBMC plugin in MePo? Maybe the message is a red herring, and just indicates some kind of problem with the MePo side...
(This post was last modified: 2014-02-23 11:23 by ntompson.)
find quote
ntompson Offline
Junior Member
Posts: 4
Joined: Feb 2014
Reputation: 0
Post: #7
So I solved it. Turns out there was a port mismatch between the server and client. TVServerXBMC was set to 9596, but PVR client was 554. I'm fairly sure I didn't change either. Changing PVR client to 9596 did the trick!

Thankyou all for your quick replies.
find quote