TVHEADEND TVH addon

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
negge Offline
Team-Kodi Member
Posts: 2,357
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #241
You should report those issues to Openelec if you haven't done so already.
find quote
xxxnelly Offline
Senior Member
Posts: 193
Joined: Dec 2010
Reputation: 1
Post: #242
Is anyone planning on bumping the PVR version to support the API 1.9.1?

Thanks

--
Frontend : OpenELEC PVR runnig on Acer Revo 3700
Backend : Ubuntu 11.10 running with TVHeadend 1 x DVB-T, 1 x Dual DVB-S2
find quote
negge Offline
Team-Kodi Member
Posts: 2,357
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #243
@xxxnelly: it's bumped in the master branch.
find quote
xxxnelly Offline
Senior Member
Posts: 193
Joined: Dec 2010
Reputation: 1
Post: #244
Sorry noticed that now, ok built successfully.

--
Frontend : OpenELEC PVR runnig on Acer Revo 3700
Backend : Ubuntu 11.10 running with TVHeadend 1 x DVB-T, 1 x Dual DVB-S2
find quote
orduek Offline
Senior Member
Posts: 102
Joined: Dec 2008
Reputation: 0
Post: #245
trying to build new add-on and getting same error as before:
Error

I tried purging and reinstalling autoconf etc. with no luck.
I'm running xbmcbuntu v13.
Thank you.
find quote
negge Offline
Team-Kodi Member
Posts: 2,357
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #246
Strange, I've never seen that before. Does the same happen with the upstream xbmc-pvr-addons project?
find quote
orduek Offline
Senior Member
Posts: 102
Joined: Dec 2008
Reputation: 0
Post: #247
What do you mean?
find quote
negge Offline
Team-Kodi Member
Posts: 2,357
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #248
Try building opdenkamp/xbmc-pvr-addons instead of adamsutton's fork and see if the same thing happens. If it does, open an issue on Github.
find quote
Meindert Offline
Member
Posts: 53
Joined: Dec 2013
Reputation: 0
Post: #249
The latest pvr.tvh is not working properly with playback of recordings. The opdenkamp/xbmc-pvr-addons works better.

Before the API changes, made by Jalle19, i did not have problems with pvr.tvh

How can i go back to the previous source?
(This post was last modified: 2014-07-21 18:49 by Meindert.)
find quote
negge Offline
Team-Kodi Member
Posts: 2,357
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #250
What is it that doesn't work? Could you post a debug log? If you have to revert to the older version you can run "git checkout Gotham" and manually bump the PVR API version (see the recent commits for what needs to be changed).
find quote
Meindert Offline
Member
Posts: 53
Joined: Dec 2013
Reputation: 0
Post: #251
Effect after selecting a recording is a black screen and a crash after a while (sometimes)

http://xbmclogs.com/show.php?id=252281
find quote
negge Offline
Team-Kodi Member
Posts: 2,357
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #252
I think I know what the problem is, I'll try to update code tomorrow. I didn't think anyone would be using the master branch for a while so I merged a pending PR without thinking that much about it. I suspect there was something wrong with it :-P
find quote
negge Offline
Team-Kodi Member
Posts: 2,357
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #253
@Meindert: I tried reproducing today (updated to the latest code) but I couldn't, recordings worked just fine. Are you using comskip or any sort of EDL mechanism?
find quote
Meindert Offline
Member
Posts: 53
Joined: Dec 2013
Reputation: 0
Post: #254
I'm on holiday right now so can't do something now.

I'm on debian testing and using xbmc from multimedia unstable repro. I build the plugin as described, nothing else, and unpack the zip file in the addons directory of xbmc.
find quote
negge Offline
Team-Kodi Member
Posts: 2,357
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #255
Your problem is most likely that you're using an unofficial (broken) version of XBMC. Build it yourself or try the Debian repository posted somewhere on the forums (can't remember where).
find quote
Post Reply