Scraping ignoring local nfos

  Thread Rating:
  • 1 Votes - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
AnalBeard Offline
Member
Posts: 69
Joined: Oct 2011
Reputation: 0
Post: #16
any suggestions?

Fileserver: Athlon 7850 | 2GB RAM | 5x2TB in RAID-Z2 | Ubuntu Saucy | Lian Li PC-A05B

HTPC: Apple TV 2 | Frodo | reFocus
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 175
Post: #17
Please provide the .nfo file.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
AnalBeard Offline
Member
Posts: 69
Joined: Oct 2011
Reputation: 0
Post: #18
http://pastebin.com/ic5arJjP

Fileserver: Athlon 7850 | 2GB RAM | 5x2TB in RAID-Z2 | Ubuntu Saucy | Lian Li PC-A05B

HTPC: Apple TV 2 | Frodo | reFocus
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 175
Post: #19
Unfortunately that's not enough. I need the filename as well please.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
AnalBeard Offline
Member
Posts: 69
Joined: Oct 2011
Reputation: 0
Post: #20
do you mean the name of the mkv, or the name of the nfo? if it's the nfo then it's movie.nfo.

Fileserver: Athlon 7850 | 2GB RAM | 5x2TB in RAID-Z2 | Ubuntu Saucy | Lian Li PC-A05B

HTPC: Apple TV 2 | Frodo | reFocus
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 175
Post: #21
You'll notice in your Debug Log that it didn't load from movie.nfo, rather from the .nfo file that was included with the video file (moviefilename.nfo).

Make sure you have "Movies in separate folders named like the movie" enabled.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
AnalBeard Offline
Member
Posts: 69
Joined: Oct 2011
Reputation: 0
Post: #22
Ok, so I dropped the database and re-scanned from scratch with that option enabled - still no joy.

(really appreciate the help by the way!)

Fileserver: Athlon 7850 | 2GB RAM | 5x2TB in RAID-Z2 | Ubuntu Saucy | Lian Li PC-A05B

HTPC: Apple TV 2 | Frodo | reFocus
(This post was last modified: 2014-03-11 23:03 by AnalBeard.)
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 175
Post: #23
Again, you need to grab the Debug Log. It's working perfectly for me otherwise. I did the following:

1. Created 21.jump.street folder.
2. Popped in your movie.nfo file (named movie.nfo).
3. Touched an empty avi file 21.jump.street.avi
4. Added 21.jump.street.nfo with an IMDb link to 'Die Hard'.
5. Scanned with 'movies in separate folders named like the movie' enabled.

Scanned in as 21 jump street, using the movie.nfo file, exactly as expected.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
AnalBeard Offline
Member
Posts: 69
Joined: Oct 2011
Reputation: 0
Post: #24
Ok, so in a bid to resolve this, I started from scratch. I've made sure I've enabled debug logging and I dumped the database and started from scratch.

http://pastebin.com/tekWieJJ is the debug log - as you can see it never even looks at movie.nfo.

I also ticked 'movies in separate folders named like the movie'



EDIT - OK, so this turns out to have been somewhat of a wild goose chase - I realise now that the issue is down to my setup. I don't want to touch the original files/folders so I've created a duplicate structure which is symlinked back to the original files. In theory this should work fine, however XBMC doesn't look in the directory it's given, it traverses the directory tree back to the original file location and looks there instead, hence why it wasn't finding my movie.nfo. I've since verified this by hardlinking the 21 Jump Street folder, coping the nfo in there and scanning that - it functions exactly as expected.

Many thanks to jmarshall for his input in helping to resolve a problem which is ultimately of my own making.

Fileserver: Athlon 7850 | 2GB RAM | 5x2TB in RAID-Z2 | Ubuntu Saucy | Lian Li PC-A05B

HTPC: Apple TV 2 | Frodo | reFocus
(This post was last modified: 2014-03-13 00:36 by AnalBeard.)
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 175
Post: #25
Glad you got it to work Smile

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
Post Reply