Linux - XBMC (Gotham) freezes when I enable Live TV.

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
punk45rock Offline
Junior Member
Posts: 2
Joined: Feb 2014
Reputation: 0
Post: #1
I followed the guide here on my fedora 20 media center, as soon as I enable live tv in XBMC settings, XBMC completely freezes and I have to kill the process. I can't find any pvr clients in rpmfusion or in the xbmc repo. Are there any known fixes for fedora? I would rather not have to install another OS but I am considering debian testing if I can't find a solution.
find quote
negge Offline
Team-Kodi Member
Posts: 2,271
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #2
You'll need to install the VDR addon first (if VDR is what you intend to use). If you can't find any binaries you can always compile from source, it doesn't take long and there are no dependencies required. The repository is available at https://github.com/opdenkamp/xbmc-pvr-addons.
find quote
punk45rock Offline
Junior Member
Posts: 2
Joined: Feb 2014
Reputation: 0
Post: #3
Thanks, I have compiled the vdr addon for gotham alpha 9 using the instructions here https://bugzilla.rpmfusion.org/show_bug.cgi?id=3143. My only problem now is that fedora packages vdr-vnsiserver3, and the xbmc plugin seems to require vnsiserver4. Is there a flag I can use to compile for vnsiserver3, or a page where I can download vnsiserver4 source and attempt to compile it myself? I have searched google with no luck.
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 3,297
Joined: Jul 2010
Reputation: 65
Location: Munich
Post: #4
vnsi3 is the version required for Frodo and can be found in opdenkamp repo Frodo branch.

Gotham requires vnsi5 with is in opdenkamp repo master branch. vnsi4 has never been a release can only be built by checking out a particular git version. Nobody but the fedora packager knows what version they have used. I recommend that you try Gotham beta instead some old aplpha
find quote