Feature Request - Non English Characters

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
the_remora Offline
Junior Member
Posts: 3
Joined: Jul 2013
Reputation: 0
Post: #1
Hey everyone, I know that I am probably unusual in wanting this feature but my collection has a lot of both Anime and Studio Ghibli movies. The titles of which I like to see in Kanji eg もののけ姫 (Princess Mononoke) and the fonts included with Metropolis don't support the characters. The Airal font however does, to this end I have changed my Font.xml file to add Arial as an option (and still kept the formatting on the weather info in the bottom corner). If possible I would like to see this added to the distribution of Metropolis so I don't have to modify the xml file every time. In the mean time here are the changes I made. It is nearly all taken from the xml for confluence so that might be an issue but the weather section is pulled from the metropolis font.xml. If you want to make these changes yourself drop the following after the </fontset> at the end of the file.

edit: I don't know how to use git (yes I need to learn)

Code:
<fontset id="Arial for non English" unicode="true">
    <!-- Arial Font better for non English -->
         <font>
            <name>font10</name>
            <filename>arial.ttf</filename>
            <size>12</size>
        </font>
         <font>
            <name>font12</name>
            <filename>arial.ttf</filename>
            <size>15</size>
        </font>
         <font>
            <name>font13</name>
            <filename>arial.ttf</filename>
            <size>18</size>
        </font>
         <font>
            <name>font14</name>
            <filename>arial.ttf</filename>
            <size>20</size>
        </font>
         <font>
            <name>font16</name>
            <filename>arial.ttf</filename>
            <size>23</size>
        </font>
         <font>
            <name>font30</name>
            <filename>arial.ttf</filename>
            <size>28</size>
        </font>
         <font>
            <name>fontContextMenu</name>
            <filename>arial.ttf</filename>
            <size>16</size>
        </font>


    <!-- Title Fonts -->
         <font>
            <name>font10_title</name>
            <filename>arial.ttf</filename>
            <size>10</size>
            <style>bold</style>
        </font>
         <font>
            <name>font12_title</name>
            <filename>arial.ttf</filename>
            <size>15</size>
            <style>bold</style>
        </font>
         <font>
            <name>font13_title</name>
            <filename>arial.ttf</filename>
            <size>18</size>
            <style>bold</style>
        </font>
         <font>
            <name>font24_title</name>
            <filename>arial.ttf</filename>
            <size>22</size>
            <style>bold</style>
        </font>
         <font>
            <name>font28_title</name>
            <filename>arial.ttf</filename>
            <size>26</size>
            <style>bold</style>
        </font>
         <font>
            <name>font30_title</name>
            <filename>arial.ttf</filename>
            <size>28</size>
            <style>bold</style>
        </font>
         <font>
            <name>font35_title</name>
            <filename>arial.ttf</filename>
            <size>33</size>
            <style>bold</style>
        </font>
         <font>
            <name>font45caps_title</name>
            <filename>arial.ttf</filename>
            <size>43</size>
            <style>bold</style>
        </font>

         <font>
            <name>font_MainMenu</name>
            <filename>arial.ttf</filename>
            <size>35</size>
            <style>bold</style>
        </font>
        
        <!--
        Font Weather and Time
        -->
         <font>
            <name>METF_WeatherHigh</name>
            <filename>MET_UbuntuRegular.ttf</filename>
            <size>62</size>
        </font>
        <font>
            <name>METF_WeatherLow</name>
            <filename>MET_UbuntuRegular.ttf</filename>
            <size>50</size>
        </font>
        <font>
            <name>METF_Temp</name>
            <filename>MET_Myriad.ttf</filename>
            <size>28</size>
        </font>
        <font>
            <name>METF_Date</name>
            <filename>MET_FontinSansSmallCaps.ttf</filename>
            <size>30</size>
        </font>
        <font>
            <name>METF_OSDTime</name>
            <filename>MET_Bebas.ttf</filename>
            <size>22</size>
        </font>
        <font>
            <name>METF_Temp</name>
            <filename>MET_Myriad.ttf</filename>
            <size>28</size>
        </font>
        <font>
            <name>METF_Date</name>
            <filename>MET_FontinSansSmallCaps.ttf</filename>
            <size>30</size>
        </font>
        <font>
            <name>METF_Hours</name>
            <filename>MET_Myriad.ttf</filename>
            <size>110</size>
        </font>
        <font>
            <name>METF_Minutes</name>
            <filename>MET_Myriad.ttf</filename>
            <size>48</size>
        </font>
        
    </fontset>
(This post was last modified: 2014-03-04 19:10 by the_remora.)
find quote
the_remora Offline
Junior Member
Posts: 3
Joined: Jul 2013
Reputation: 0
Post: #2
Bumping this.
find quote
Choppasmith Offline
Junior Member
Posts: 16
Joined: Feb 2012
Reputation: 0
Post: #3
I tried this but it doesn't work for me. But then I have a bunch of Japanese MP3s. Does this fix not work for those? Do I need a copy of Arial in the Metropolis folder? I made sure to copy and paste after the last fontset but before /fonts.
(This post was last modified: 2014-08-04 19:29 by Choppasmith.)
find quote
the_remora Offline
Junior Member
Posts: 3
Joined: Jul 2013
Reputation: 0
Post: #4
I never tried it with music. My server is down currently, I moved house and haven't set it back up. Did you go into the settings and change your font selection? Also a heads up when they update the theme it will rewrite your font.xml and break your setup. It would be really nice to hear from one of the maintainers about non-English character support. I do believe I had to put the Arial font in /fonts but it has been a while (I got frustrated by the updates breaking my setup)
find quote