Linux - Gotham - Addons Won't download.

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
desaih73 Offline
Junior Member
Posts: 2
Joined: Jun 2014
Reputation: 0
Post: #31
I am getting the same issue. Downloaded xbmc 13 and 13.1 on firetv. For whatever reason, ice films add on is the only add on I can add, everything else just goes into abyss and does nothing.

Any help appreciated.
find quote
Warp3 Offline
Junior Member
Posts: 6
Joined: Feb 2011
Reputation: 0
Post: #32
I was having this issue on XBMCbuntu Frodo 12.2 earlier today, so I decided to take the plunge and go to Gotham (since I had already downloaded the Gotham ISO so this gave me a good excuse to finally upgrade). I wiped my Zbox's drive and installed XBMCbuntu 13.0, upgraded it to 13.1, set everything up, and watched a few videos. Then I decided I would try video plugins and it does the same thing Frodo did (flashes up 0% for a few seconds then just goes away). I know it isn't Internet connectivity since weather (using Weather Underground) updates fine in XBMC and I was able to use apt-get to upgrade XBMC to 13.1 earlier.
find quote
jrnvk Offline
Junior Member
Posts: 1
Joined: Jun 2014
Reputation: 0
Post: #33
EDIT- nvm. Mistake post.
(This post was last modified: 2014-06-23 03:52 by jrnvk.)
find quote
daven1234 Offline
Junior Member
Posts: 2
Joined: Jun 2014
Reputation: 0
Post: #34
go to webserver allow control xmbc via http. for some reason it was off as soon as i turned it on it started downloading stuff . but im new so i dont know if it should be on . but it works now.
find quote
JoseCCnet Offline
Junior Member
Posts: 2
Joined: Jun 2014
Reputation: 0
Post: #35
I'm xbmc user. I have a 'dirty' workarround:

http://mirrors.xbmc.org <- Main problem. This do a load balancing to use mirrors. In America, the aplication web server ALWAYS is trying to send us to mirror.us.leaseweb.net

http://mirror.us.leaseweb.net <- This have "some problem" to serve files.

The workarround:

mirror.us.leaseweb.net [108.59.10.97] NOT use this IP
mirror.nl.leaseweb.net [94.75.223.121] USE this IP from a working mirror (http://mirrors.xbmc.org/addons/frodo/plu...mirrorlist).

On my linux router(gateway):
iptables -t nat -A PREROUTING -d 108.59.10.97 -j DNAT --to-destination 94.75.223.121

An easy and local solution for your operating system is to edit your "hosts" file.

C:\Windows\System32\drivers\etc\hosts <- Windows
/etc/hosts <- Linux, Unix, (android?), etc

mirror.us.leaseweb.net 94.75.223.121 #Add this line

good luck

Saludos!
find quote
Warp3 Offline
Junior Member
Posts: 6
Joined: Feb 2011
Reputation: 0
Post: #36
I just tried this again today (with no changes made on my end in the meantime) and it seems to work fine now. {shrug}
find quote
jgmiller Offline
Junior Member
Posts: 6
Joined: Mar 2013
Reputation: 0
Sad  RE: Gotham - Addons Won't download.
Post: #37
On trying to download addons today 2014-08-28 for XBMC Gotham 13.1, all attempts at download fail.

Checking the addons website URL in a browser results in --

Quote:The following error was encountered while trying to retrieve the URL: http://mirrors.xbmc.org/

Connection to 89.16.176.16 failed.

The system returned: (110) Connection timed out

The remote host or network may be down. Please try the request again.

This has been like this for at least several hours now.

So what is one supposed to do?
find quote
Martijn Offline
Team Kodi
Posts: 11,607
Joined: Jul 2011
Reputation: 167
Location: Dawn of time
Post: #38
wait

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
jgmiller Offline
Junior Member
Posts: 6
Joined: Mar 2013
Reputation: 0
Post: #39
Well the Bytemark mirror site is finally back up, but the all important addons index files are missing in both the frodo and gotham addons directories, eg

Quote:18:23:36 T:2867039040 DEBUG: CFileCache::Open - opening <addons/frodo/addons.xml> using cache
18:23:36 T:2867039040 DEBUG: CurlFile::Open(0xaf1b9920) http://mirrors.xbmc.org/addons/frodo/addons.xml
18:23:36 T:2867039040 ERROR: CCurlFile::FillBuffer - Failed: HTTP response code said error(22)
18:23:36 T:2867039040 NOTICE: CCurlFile::FillBuffer - Reconnect, (re)try 1
18:23:36 T:2867039040 ERROR: CCurlFile::FillBuffer - Failed: HTTP response code said error(22)
18:23:36 T:2867039040 ERROR: CCurlFile::CReadState::Connect, didn't get any data from stream.
18:23:36 T:2867039040 ERROR: Open - failed to open source <http://mirrors.xbmc.org/addons/frodo/addons.xml|Encoding=gzip>
18:23:36 T:2867039040 ERROR: Repository XBMC.org Add-ons returned no add-ons, listing may have failed
18:23:36 T:3035920128 DEBUG: CGUIMediaWindow::GetDirectory (addons://repos/)
18:23:36 T:3035920128 DEBUG: ParentPath = [addons://repos/]
xml|Encoding=gzip>
18:23:36 T:2867039040 ERROR: Repository XBMC.org Add-ons returned no add-ons, listing may have failed
18:23:36 T:3035920128 DEBUG: CGUIMediaWindow::GetDirectory (addons://repos/)
18:23:36 T:3035920128 DEBUG: ParentPath = [addons://repos/]
(This post was last modified: 2014-08-28 18:38 by jgmiller.)
find quote
jgmiller Offline
Junior Member
Posts: 6
Joined: Mar 2013
Reputation: 0
Post: #40
After waiting several more hours, mirrors.xbmc.org is now pointing to (http://ftp.uni-erlangen.de)

Again no addons will download.

XBMC is trying to get the addons from the URL "mirrors.xbmc.org/addons" as in

Quote:22:50:07 T:2949638976 DEBUG: GetImageHash - unable to stat url http://mirrors.xbmc.org/addons/frodo/plu...o/icon.png
22:50:07 T:2949638976 DEBUG: GetImageHash - unable to stat url http://mirrors.xbmc.org/addons/frodo/plu...k/icon.png
22:50:07 T:2949638976 DEBUG: GetImageHash - unable to stat url http://mirrors.xbmc.org/addons/frodo/plu...v/icon.png
22:50:07 T:2949638976 DEBUG: GetImageHash - unable to stat url http://mirrors.xbmc.org/addons/frodo/plu...p/icon.png
22:50:08 T:2949638976 DEBUG: GetImageHash - unable to stat url http://mirrors.xbmc.org/addons/frodo/plu...k/icon.png
...

but the mirror at http://ftp.fau.de has the addons under a top level directory "xbmc", viz

mirrors.xbmc.org/xbmc/addons

so of course the XBMC client never finds any addons to download.

Even doing a "force refresh" in the context menu of

System --> Settings -> Addons -> Get Addons -> xbmc.org addons entry

does not correct the problem.

Does Team-Kodi (nee Team-XBMC) recommend manually downloading addons by FTP since the automatic mirror system appears to be so unreliable, or is one expected to keep waiting (hours, days, weeks?) until it works maybe?
find quote
Post Reply