Mac OS X - Mac mini late 12, Lip Sync error

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Sebski Offline
Junior Member
Posts: 43
Joined: Feb 2013
Reputation: 0
Post: #1
Hey all.

Gear:

Mac mini i5, late 12.
Clean osx 10.9.
xbmc 12.3

Flatscreen:

Samsung led 8005.

I had a Panasonic Plasma before getting the samsung, it seems that i got they lip sync issue after getting the new screen, i updated osx from 10.8 around getting the new screen.

I have tried a lot of settings to get rid of the lip sync error none have helped except ofc changing it in sound settings when playing a movie.

Can anyone help me here I'm a little lost.

Could is be osx 10.9? should i downgrade to osx leopard head that was good for xbmc??

Im only using the mini for xbmc and airplay.

Thx

Sebastien
find quote
juramusger Offline
Member
Posts: 54
Joined: Mar 2014
Reputation: 1
Post: #2
hey sebski,

as I have had my fair share of sync issues I would be willing to troubleshoot with you but I will need more information:
version of XBMC, cabling and setup options (output device, configuration, passthrough settings) that you use.

Beforehand: if you go HDMI to the TV and optical from there to the audio gear the sync issue might be introduced by the TV and your best bet will be to set a global delay in XBMC. As you said you could correct it with the settings from the OSD while playing a movie, try "set as default for all" there and check if it is resolved. If the sync issue is different with different types of files the problem might be more complicated.

Finally, I'm coming from the consumer side of things, so devs might step in with more technical knowledge, but they will need a debug log to help you.
find quote
Sebski Offline
Junior Member
Posts: 43
Joined: Feb 2013
Reputation: 0
Post: #3
Hej Juramusger.

Thx for reply..

I running 12.3 and when thinking about it i seems that the issue started after upgrading from ML to Mavericks...

Im running a tos link from line out to my Logitech Z-5500 surround reciver. i will try the global settings on audio delay and come back, at the same while i will partition my HD and install Leopard to se if it will help, + i have read that leo would be the most stabile for xbmc.

I will return, and again thx.
(This post was last modified: 2014-04-13 11:44 by Sebski.)
find quote
juramusger Offline
Member
Posts: 54
Joined: Mar 2014
Reputation: 1
Post: #4
I think Snow Leopard is recommended by many, but I am not sure whether it will install on your 2012 mini. My MBA 2012 came with Mountain Lion and would have been very complicated to downgrade. Earlier OSX versions usually lack the correct drivers for later hardware.

Edit: Another thing to check since you only experienced the issue with the newer TV are the picture settings. Try turning off all "picture optimizers" as they might introduce further lag (and in my opinion only deteriorate the picture, but that is up to your preferences). Also choose something like "just scan" for picture format so the picture is only scaled once.
(This post was last modified: 2014-04-13 13:26 by juramusger.)
find quote
Sebski Offline
Junior Member
Posts: 43
Joined: Feb 2013
Reputation: 0
Post: #5
Yeah can't downgrade..

All picture optimizers are off,..


Where can i see global audio delay settings?
find quote
juramusger Offline
Member
Posts: 54
Joined: Mar 2014
Reputation: 1
Post: #6
First you choose an audio offset while playing a movie in the audio and subtitle section of the OSD. Right there you select "set as default for all videos". If you open another video the same offset should be enabled and you can see that in the same menu.

Another option for setting offsets is through advancedsettings.xml, there you can set different offsets for different types of videos. Read up on that in the wiki if you are interested! Try different files (with different video/audio codecs) to see if all have the same delay!

How much delay are we talking about? Is the audio too late or too early? Do you use passthrough (for AC3, DTS) and is it different with such files? Does seeking or pausing change the delay?

Finally: Does the Logitech system have an audio delay setting?

And if you have already repartitioned: try to install Mountain Lion on the new partition to check if it works under that version of OSX!
(This post was last modified: 2014-04-13 15:36 by juramusger.)
find quote
Sebski Offline
Junior Member
Posts: 43
Joined: Feb 2013
Reputation: 0
Post: #7
Ok after some more testing.

I tried my old Pivos DS on the TV, and same problem so it looks like its the new screen.... wired and annoying...

I did what you say set the global delay, audio is to late and its set to 375 isn. it seems its the same for most movies witch almost all are in MP4 1080P

I havent tryed ML install yet as its the same delay with the pivot box..

so it is something in the TV, i had to get a longer hdmi label when i got the new TV could it be that?

you know, all was working perfect before getting the new TV and the upgrade på osx 10.9, and i have been fighting with xbmc enough for a long time, so to get some new faults is really sad....

Thx for all your help, the last thing i will try i taking the mini and try it on the bedroom tv, just to se what will happen..

Thx again.

PS:

Is bootcamp win 8 a good sulution??
(This post was last modified: 2014-04-13 18:35 by Sebski.)
find quote
juramusger Offline
Member
Posts: 54
Joined: Mar 2014
Reputation: 1
Post: #8
I have no experience with xbmc on windows so I cannot comment on that.

but you already found out that it's not the mac or xbmc that's causing the issue. Strange enough that audio is now too late. You did mean that you run the toslink from your mini to the Logitech, not from the line out of the TV, didn't you? If you are instead using the TV's line out you have two options:
1. See if there is a lip sync setting in the TV's audio settings
2. Bypass the TV altogether and connect the toslink from your mini's line out to the logitech (the mini jack is a dual electrical/optical out, you need the appropriate cable.

Good luck!
find quote
Sebski Offline
Junior Member
Posts: 43
Joined: Feb 2013
Reputation: 0
Post: #9
Hey.

Yes I'm running from mini to logitech, i will try to see if there are some lip settings in the tv.

Im going to install ML on a partition to se if it have any different.

When I'm playing a file in VLC player there are no lip error, so its in xbmc..

Will return, and thx again
find quote
juramusger Offline
Member
Posts: 54
Joined: Mar 2014
Reputation: 1
Post: #10
Very strange, but now you say that it's only XBMC. I (falsely it seems) assumed that your test with the Pivos indicated something else.
Are you using the same output format in VLC as in XBMC? Do you send PCM or encoded audio (passthrough)?
If it affects only passthrough audio you will need to tinker with advancedsettings.xml I guess, but I have only used that myself to change the delay for files of a specific refresh rate, so I don't know if what I have in mind is even possible. Anyway with that

Also: If it is only XBMC you might not want to change your TV's lipsync settings in order to not mess up other programs' sound.

Although normally the 'harder' way in your case you might try to use the TV's optical out and see if that gets you better results. It would have the added benefit to be able to use your surround system for other stuff connected to the TV as well. You should however check if the TV does allow passthrough of AC3 and DTS from HDMI sources, a lot of them don't.
find quote
Sebski Offline
Junior Member
Posts: 43
Joined: Feb 2013
Reputation: 0
Post: #11
so...

I installed Mountain lion on a other partition, and still the same error, i tried playing a movie through VLC again to make sure it played good there, and gues what, lip sync in VLC also...

There are one thing i changed when i got the new screen, that was the HDMI cable cause the first one wasn't long enough, so tomorrow i will get an other hdmi and i hope that will do the trick....

I report back
find quote
Memphiz Offline
Team-XBMC Developer
Posts: 10,621
Joined: Feb 2011
Reputation: 112
Location: germany
Post: #12
hdmi cable is not it ... hdmi is digital either it works or it doesn't - there is no inbetween state. The difference between your xbmc setup and vlc might be that one uses pass through (xbmc? - bad lip sync) and the other LPCM (vlc). Try the latter by setting the speaker config to 5.1 in XBMC and deactivate the pass through options. (this results in XBMC decoding the audio channels and feeds them to the AMP via LPCM which should be lipsync then).

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Sebski Offline
Junior Member
Posts: 43
Joined: Feb 2013
Reputation: 0
Post: #13
Hey again,

HDMI didnt change anything as Memphiz says , i testate with a windows laptop through VLC with same movie, and that works perfect, so it must be the Mac mini..

I will test some more and report back...
find quote
juramusger Offline
Member
Posts: 54
Joined: Mar 2014
Reputation: 1
Post: #14
(2014-04-14 18:26)Sebski Wrote:  so...

I installed Mountain lion on a other partition, and still the same error, i tried playing a movie through VLC again to make sure it played good there, and gues what, lip sync in VLC also...

I am not entirely sure what you are saying here: Did you mean that VLC still has no issues or that VLC has issues as well?
It would still be interesting to know which kind of files - which audio formats specifically - exhibit the sync problem. Also what you have set as passthrough options in settings - system - audio output. (This is what Memphiz was referring to too and I tried to ask you in a previous post as well)

What still bothers me too is that you said the audio arrives too late. I can hardly imagine that your new screen is that much faster in processing the image. This is further unlikely by your report that only the mini (and the pivos?) exhibit the problem. If it is indeed the case however, a global setting (as discussed above) should do the trick.
(This post was last modified: 2014-04-17 15:32 by juramusger.)
find quote
Sebski Offline
Junior Member
Posts: 43
Joined: Feb 2013
Reputation: 0
Post: #15
Hey.

I Will sum up, ny english aint the best so sorry for my bad posts.

I testet the same movie in vlc.

From Mac mini, the delay are there on osx and in bootcamp win 8.1

Testet the same movie on a win laptop and that was fine ,no delay. So it must be the Mac mini hdmi out, i will try with display-hdmi and see of its the same.
find quote
Post Reply