[RELEASE] CNET Podcasts Video-Addon

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Skipmode A1 Offline
Skilled Python Coder
Posts: 51
Joined: Mar 2013
Reputation: 7
Post: #1
Hello folks,

This addon stopped working recently and unfortunately i haven't been able to reach the author of the addon (divingmule). Therefore i made some alterations to the addon to get it up and running again. Also thanks to gtoons for the feedburner tip.

[Image: icon.png]

If you got problems with the addon, just reply here.

Enjoy.

version 1.1.1 (Sunday 20 april 2014)
fix to get the addon working again after changes in the website.
I couldn't get in contact with divingmule, therefore i (Skipmode A1) made a new version of the addon based on divingmule's sourcecode.
Thanks to gtoons for the feedburner tip.

version 1.1.0
update for frodo/gotham

version 1.0.8
fix for changes in Frodo

version 1.0.7
updated podcasts list

version 1.0.6
fix bug in scraper

version 1.0.5
updated show list, thanks pkscuot

version 1.0.2
fix for feed changes
new playback setting

version - 1.0.1
added the crave podcast

version - 1.0.0
new for eden

version - 0.0.4
added addon settings for video quality instead of categories

version - 0.0.3
updated icon.png

version - 0.0.2
added video descriptions
added categories for SD and HD

version - 0.0.1
initial
(This post was last modified: 2014-04-22 21:55 by Skipmode A1.)
find quote
encript Offline
Junior Member
Posts: 26
Joined: Nov 2013
Reputation: 0
Post: #2
Is there a way to get videos to play in 720p? All the videos play in the lower 360 resolution.
find quote
Skipmode A1 Offline
Skilled Python Coder
Posts: 51
Joined: Mar 2013
Reputation: 7
Post: #3
Not that i know off.
find quote
encript Offline
Junior Member
Posts: 26
Joined: Nov 2013
Reputation: 0
Post: #4
Ok cool. Thanks. The main site doesn't seem to play in HD, must have been one of the changes.
(This post was last modified: 2014-04-23 22:52 by encript.)
find quote
macuniverse Offline
Junior Member
Posts: 13
Joined: Aug 2013
Reputation: 0
Post: #5
Video works but no audio. It looks like CNET audio is in AAC. Other video addons with AAC audio work (such as Twit).
OS: OSX Mavericks 10.9.2
Audio Out: SPDIF Coax through USB (connects to Onkyo AVR)
CNET works fine with HDMI video and audio.
XBMC ver: 10.3b4

Also tried with audio passthrough and no passthrough. Same outcome- No audio
find quote
Trickname Offline
Senior Member
Posts: 130
Joined: Nov 2009
Reputation: 2
Post: #6
Thx for the update but have also sound problems here.
find quote
Skipmode A1 Offline
Skilled Python Coder
Posts: 51
Joined: Mar 2013
Reputation: 7
Post: #7
Not much i can do about that, the addon plays the video with the xmbc player.

The sound works for me with 12.x and even the 13.betax xbmc versions. You might try those...
find quote
Trickname Offline
Senior Member
Posts: 130
Joined: Nov 2009
Reputation: 2
Post: #8
Sound is working but it's really poor quality
find quote
macuniverse Offline
Junior Member
Posts: 13
Joined: Aug 2013
Reputation: 0
Post: #9
(2014-04-27 08:37)Skipmode A1 Wrote:  Not much i can do about that, the addon plays the video with the xmbc player.

The sound works for me with 12.x and even the 13.betax xbmc versions. You might try those...

It, then, looks like a CNET streaming issue as all other add-ons using AAC audio codec have no issue with audio playback over USB to SP/DIF.

BTW, thanks for the effort.
find quote
gtoons Offline
Junior Member
Posts: 6
Joined: Oct 2012
Reputation: 0
Post: #10
All the sound and low video quality issues appear to stem from a change of platforms by engineers at CNET, according to tweets from senior editor Brian Tong...

http://muckrack.com/brian-tong/statuses/...0683877376

http://muckrack.com/brian-tong/statuses/...5055875072
(This post was last modified: 2014-05-04 09:38 by gtoons.)
find quote
macuniverse Offline
Junior Member
Posts: 13
Joined: Aug 2013
Reputation: 0
Post: #11
(2014-05-04 06:01)gtoons Wrote:  All the sound and low video quality issues appear to steam from a change of platforms by engineers at CNET, according to tweets from senior editor Brian Tong...

Thanks for the update. Now it makes sense.
find quote
encript Offline
Junior Member
Posts: 26
Joined: Nov 2013
Reputation: 0
Post: #12
I checked the Videos out today and they look great in high definition, finally the quality is better
find quote
macuniverse Offline
Junior Member
Posts: 13
Joined: Aug 2013
Reputation: 0
Post: #13
(2014-04-25 17:40)macuniverse Wrote:  Video works but no audio. It looks like CNET audio is in AAC. Other video addons with AAC audio work (such as Twit).
OS: OSX Mavericks 10.9.2
Audio Out: SPDIF Coax through USB (connects to Onkyo AVR)
CNET works fine with HDMI video and audio.
XBMC ver: 13.0

Also tried with audio passthrough and no passthrough. Same outcome- No audio

I, now, confirm that audio of CNET video addon works fine under above-mentioned Mac mini setup.

Thanks CNET people!
(This post was last modified: 2014-05-10 06:27 by macuniverse.)
find quote
cdlenfert Offline
Junior Member
Posts: 28
Joined: Oct 2010
Reputation: 0
Post: #14
I'm seeing issues on the apple tv 2 on certain podcasts. Cnet Update seems to catch up and play perfectly, however the Apple Byte never catches up and the video lags further and further behind the audio. I'm on Gotham with plugin 1.1.1 and IOS version 5.3 untethered

Anything I can try to get all podcasts working again?
find quote
Skipmode A1 Offline
Skilled Python Coder
Posts: 51
Joined: Mar 2013
Reputation: 7
Post: #15
Works fine here with windows and xbmc 13.1 :/.
find quote