Movie Collection background art

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
wjbeckett Offline
Junior Member
Posts: 12
Joined: Aug 2012
Reputation: 0
Post: #31
@simonk83 - I wish a reboot fixed mine!
Still not working correctly! :-(
find quote
toineb Offline
Senior Member
Posts: 295
Joined: Mar 2011
Reputation: 8
Post: #32
Hello wjbeckett

I had a similiar problem after I did a fresh install after the latest gotham release, the extended info script, didn't appear to be puling through the info from each movie in the set, for the movie set info.

I did a fresh download at that time for all my addon's including the extendedinfo script. When I went into my library, the movieset info was not being pulled through. I uninstalled the script and reinstalled one I had downloaded previously and it started working correctly as before.

I regret I know nothing about how xbmc, scripts, skins etc work behind the scenes, so I have no idea why it didn't work or why it started to work as I don't think there have been any recent changes to the script.

The only things I can suggest are things you might have done already, uninstall the script and either reinstall via the xbmc add zip option or you could try manually unzipping it into the addon folder and see if that does anything for you.

I wish I could be more help sorry
find quote
Elektro2000 Offline
Junior Member
Posts: 10
Joined: Sep 2011
Reputation: 0
Post: #33
Hey toineb,

Does I see it right that you downloaded every single artwork by your own? Except of CDart.

If yes, could you give me a hint where I can find the best artworks for my movie sets? After I have all my artworks I can run the movie set automator, right?

Thanks
T
find quote
toineb Offline
Senior Member
Posts: 295
Joined: Mar 2011
Reputation: 8
Post: #34
Hello Elecktro

I did download the fanart, poster and logo for each set manually - You can use either Ember or tiny media to scrape the poster and fanart for sets but as far as I know neither will put them in a parent folder for the set. However, they will pust them all in a single folder, which you could use with the movieset artwork automator. I have my files set up with a parent folder for each set and sub folders for each movie in the set, so I just downloaded them all myself


The two best sites are

Fanart.tv and themoviedb.org - If you can't find the fanart or poster you like there, you can always just do a quick search via google images, I found some there that I liked.

Hopefully Ember will be able to scrape all of the above soon
(This post was last modified: 2014-05-08 19:46 by toineb.)
find quote
elnino-1900 Offline
Senior Member
Posts: 120
Joined: May 2013
Reputation: 1
Location: England
Post: #35
Theres a program called Mediaelch. It allows you to scrape the artwork such as logo clearart discart banner and landscape for movie and tv shows. You can also use it to get poster and fanart. But what I do is, scrape the movie using ember and just select the poster fanart and extrathumbs. then use mediaelch to get the rest of the artwork. it saves them into the movie folder using the correct names for xbmc. Thought it could help instead of downloading each one from fanart.tv

Also, i noticed using sets the extrathumbs seem to filled with the logo from the movies within the set. anyway to have the slots fill up with the extrathumbs from the movies within the sets instead
(This post was last modified: 2014-05-09 17:21 by elnino-1900.)
find quote
toineb Offline
Senior Member
Posts: 295
Joined: Mar 2011
Reputation: 8
Post: #36
I use Mediaelch (but really like the way Ember is heading at the moment) in addition to the others too, the problem is at the moment it will scrape movieset fanart and poster and will either save it one single directory for all movieset artwork or save it in the same folder as the movie. Sadly at the moment it will not download the logo for each movieset.

At the moment both the latest Ember and Mediaelch and mber are great for downloading logo's etc for individual movies, the logo's for movie sets still need to be done manually

I prefer to use a parent folder for the movie set, I find it easier to manage to work with movieset automator.

As an example I have my files like this - I like it this way as instead of each artwork needing the movie name it is just calld what it is, logo, fanart, banner etc and it is like this for the set too

J:\Movie Collections\A Nightmare on Elm Street Collection

[Image: 1ab.jpg]

J:\Movie Collections\A Nightmare on Elm Street Collection\A Nightmare on Elm Street 5 The Dream Child (1989)

[Image: Screenshot_1-3.jpg]

But at the end of the day, it is what works best for each person
(This post was last modified: 2014-05-09 17:53 by toineb.)
find quote
elnino-1900 Offline
Senior Member
Posts: 120
Joined: May 2013
Reputation: 1
Location: England
Post: #37
Ah right. For making sets do you have to make sure the movies are within a set on the hard drive or can you just use xbmc to manage movie sets
find quote
toineb Offline
Senior Member
Posts: 295
Joined: Mar 2011
Reputation: 8
Post: #38
(2014-05-09 17:52)elnino-1900 Wrote:  Ah right. For making sets do you have to make sure the movies are within a set on the hard drive or can you just use xbmc to manage movie sets


It is more to do with the moviest artwork automator addon - you have to either have the artwork for the set in a parent folder or in a single folder for all the movieset artwork

[Image: Screenshot_3-4.png]

I personally prefer the parent folder method, as when logo's etc are updated on fanart.tv. I just find it easier to manage each set individually
(This post was last modified: 2014-05-09 18:01 by toineb.)
find quote
elnino-1900 Offline
Senior Member
Posts: 120
Joined: May 2013
Reputation: 1
Location: England
Post: #39
(2014-05-09 17:55)toineb Wrote:  
(2014-05-09 17:52)elnino-1900 Wrote:  Ah right. For making sets do you have to make sure the movies are within a set on the hard drive or can you just use xbmc to manage movie sets


It is more to do with the moviest artwork automator addon - you have to either have the artwork for the set in a parent folder or in a single folder for all the movieset artwork

I shall give that a go. I always seem to revert back to individual movies without the sets. need to try and stick with it!

Thanks
find quote
toineb Offline
Senior Member
Posts: 295
Joined: Mar 2011
Reputation: 8
Post: #40
It took me ages to move the folders and files about, as I never used to bother. I was more than happy for xbmc to manage my moviesets. However, after finding the logo's, posters and fanart for sets, I took the plunge and organised my library.

It is a pain to do but now I have everything organised it is a lot easier to manage. As and when I get a new movie, it can go straight into the set if there is one or on a different hard drive for individual movies - I think I might be getting into the relms of being too anal about how I manage my library now lol
find quote
elnino-1900 Offline
Senior Member
Posts: 120
Joined: May 2013
Reputation: 1
Location: England
Post: #41
Am I right in thinking that I could create soemthing Like this: "moviesets---> Alien collection--> logo,clearar, poster etc" and use the movieset artwork automator to look at that folder to search for artwork. Or is that not possible.
find quote
toineb Offline
Senior Member
Posts: 295
Joined: Mar 2011
Reputation: 8
Post: #42
(2014-05-09 18:13)elnino-1900 Wrote:  Am I right in thinking that I could create soemthing Like this: "moviesets---> Alien collection--> logo,clearar, poster etc" and use the movieset artwork automator to look at that folder to search for artwork. Or is that not possible.


Not sure to be honest, I don't know how the automator works behind the scenes... only thing I can suggest is give it a try
find quote
elnino-1900 Offline
Senior Member
Posts: 120
Joined: May 2013
Reputation: 1
Location: England
Post: #43
Will do. Thanks a lot
find quote
brazen1 Offline
Senior Member
Posts: 120
Joined: Dec 2012
Reputation: 1
Post: #44
(2014-05-03 00:36)toineb Wrote:  ok once I have installed the extrainfo script, I quit xbmc and edit the python default file for it.

C:\Users\username\AppData\Roaming\XBMC\addons\script.extendedinfo-master

I remove these two lines, as it will allow you to set your choice of movieset fanart (for the set instead of a loop of the fanart within that set)

[Image: Screenshot_141.jpg]

I then go into settings and turn on the script

[Image: Screenshot_137.jpg]

this will take you from

[Image: Screenshot_136.jpg]

to

[Image: Screenshot_139.jpg]

basically it fills in the info panel with information about each movie within the set

I then run the movieset automator, giving me this

[Image: Screenshot_142.jpg]

Whilst there is an option on the panel on the left, for some unknown reason I find that the artwork downloader runs better if I do it via programs

[Image: Screenshot_140.jpg]

so I run it


I have downloaded the script.extendedinfo-master from the link you provided. I also downloaded from the link provided on the 4.1.9.9 nox thread. Both point to a Github .zip so they are the same as expected. I have installed the .zip within XBMC and it is in the correct addons folder. When I go to edit the default.py as you suggested, there are no lines even remotely similar to the ones you show being edited. The extendedinfo in XBMC shows version 0.0.2. What have I done incorrect? Fwiw, after installing the .zip, I quit XBMC to attempt to edit the default.py. I then opened XBMC and got the script error. I closed XBMC and opened it again without rebooting or changing anything and after several opens and closings I no longer get the script error. I believe that quirk is fixed. I suspect this version of extended info is different from the one you show being edited. Please update what needs to be edited if indeed it doesn't correspond to your picture. Thank you.
(This post was last modified: 2014-05-11 19:03 by brazen1.)
find quote
toineb Offline
Senior Member
Posts: 295
Joined: Mar 2011
Reputation: 8
Post: #45
(2014-05-11 18:58)brazen1 Wrote:  I have downloaded the script.extendedinfo-master from the link you provided. I also downloaded from the link provided on the 4.1.9.9 nox thread. Both point to a Github .zip so they are the same as expected. I have installed the .zip within XBMC and it is in the correct addons folder. When I go to edit the default.py as you suggested, there are no lines even remotely similar to the ones you show being edited. The extendedinfo in XBMC shows version 0.0.2. What have I done incorrect? Fwiw, after installing the .zip, I quit XBMC to attempt to edit the default.py. I then opened XBMC and got the script error. I closed XBMC and opened it again without rebooting or changing anything and after several opens and closings I no longer get the script error. I believe that quirk is fixed. I suspect this version of extended info is different from the one you show being edited. Please update what needs to be edited if indeed it doesn't correspond to your picture. Thank you.


Hello Brazen

I have just double checked by dowloading the extended info from the first post in the 4.1.9 thread

http://forum.xbmc.org/showthread.php?tid=185290

[Image: Screenshot_1-5.png]

[Image: Screenshot_2-3.png]

[Image: Screenshot_3-5.png]

Those lines are still there as of today....
(This post was last modified: 2014-05-11 19:19 by toineb.)
find quote