Mac OS X - [XBMC 12.3]Constant buffering when playing BluRay Movies from local NAS

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #1
I am using XBMC 12.3 under OS X 10.9.2. The issue I am having is when I playback MKV BluRay movie files, over SMB to my local NAS, I get constant buffering about every 30 seconds. If I playback the same MKV file using VLC over SMB to the my local NAS, there is no such issue. I have searched, in the XBMC forums, for a possible resolution but I have not found anything as of yet. Any help would be greatly appreciated.

Debug Log

By the way, I get no buffering issue when I playback a DVD iso file.

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
(This post was last modified: 2014-04-30 09:34 by winestock.)
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #2
I just tried a little test. I mounted my SMB NAS drives on my local HD under /Volumes. From XBMC I added the mounted SMB drives as source from /Volumes. I then played the same BluRay MKV file. This time there was no buffering. Can someone explain why XBMC does not have the buffering issue if the drives are mounted as Volumes. I would prefer not to have to mount the NAS drives to fix the issue.

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
(This post was last modified: 2014-04-30 09:57 by winestock.)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,965
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #3
libsmbclient vs. the smbclient from osx ... thats the difference ... the latter completely works around the smb code in xbmc and therefore only utilises the osx smb access features...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #4
(2014-04-30 11:20)Memphiz Wrote:  libsmbclient vs. the smbclient from osx ... thats the difference ... the latter completely works around the smb code in xbmc and therefore only utilises the osx smb access features...

From your response this leads me to believe that the issue I am seeing is with libsmbclient in XBMC and not my network. Has libsmbclient been changed for Gotham?

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
(This post was last modified: 2014-04-30 16:56 by winestock.)
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #5
I just tried Gotham RC-1 candidate and the issue still exists. Has anyone been experiencing this issue?

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
find quote
winestock Offline
Fan
Posts: 442
Joined: Jan 2011
Reputation: 5
Post: #6
I solved the issue by mounting the SMB server drives and then changing the XBMC sources to the mounted SMB drives.

XBMC Frodo 12.3, Transparency Skin (5.0.9)
PogoPlug v4 running Arm Linux 3.15 as MySQL (mariadb) and media file server for XBMC
Mac OS X 10.9.4
2011 27" iMac 3.4 GHz Quad, 16GB RAM, 1TB HD, 256GB SSD
2009 2.0GHz MacMini, 4GB RAM, 320GB HD
2009 17" Macbook Pro, 8GB RAM, 500GB HD
find quote
Tiff_Needle Offline
Junior Member
Posts: 6
Joined: Nov 2011
Reputation: 0
Post: #7
Forgot to mention that I'm running gotham 13.1 on mavericks
find quote