Mac OS X - Mac Mini Horisontal tearing issue

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
rofuz Offline
Junior Member
Posts: 9
Joined: May 2014
Reputation: 0
Post: #1
Hi

I upgraded to Gotham and got some weird horisontal tearing issue.

Pastbin XBMC log

I also tried the beta 2, then when the issue were still there, I removed xbmc and all the files. Reinstalled the beta 2. added my sources and advancedsettings.xml file. But the issue was still there. Anyone else have this issue with Gotham and Mac Mini with OSX 10.9.2

My setup is as follows:

LG 60 plasma
Denon x2000 receiver.
Mac Mini mid 2010, 8gb ram and SSD.
Qnap 419p II 12TB
NFS shares
MySQL server on Qnap
Cisco 1gb switch
Thumbnails substition on Qnap (I use ATV2 and Raspberry Pi around the house)
(No tearing issue on ATV2, have not tried Rasp)

I use the 2.0 and passthrough the get the right 5.1 sound (DTS & Dolby)
I also use vertical Blank Sync enable. Also use software rendering.

Please assist!

Thank you
/R
(This post was last modified: 2014-05-21 12:37 by rofuz.)
find quote
arubinst Offline
Junior Member
Posts: 22
Joined: Jan 2011
Reputation: 1
Location: Lausanne, Switzerland
Post: #2
I'm also seeing tearing with gotham. I also tried a fresh install and it gave me the same results. Frodo does NOT show this behavior.

I have the same Mac Mini you have but on 10.9.3 (had tearing on 10.9.2 as well) using an Onkyo receiver. The receiver is configured in passthrough mode for video and connected to a Samsung 65HU8500 4k tv.

Cheers

Mac Mini Intel Core 2 Duo 2.4Ghz | 8GB DDR3 | NVIDIA GeForce 320M | Synology DS412+ | 1 TB Time Capsule | Samsung 65" UE65HU8500 | Onkyo TX-NR809 AVR | Jamo S 426 HCS 3 5.0 Speaker system | Yamaha YST-SW012 Subwoofer | Mac OS X 10.9.3 (Mavericks) | Gotham
find quote
rofuz Offline
Junior Member
Posts: 9
Joined: May 2014
Reputation: 0
Post: #3
Probably something with the passthrough, will try to turn it off later tonight. Will post back later

@Memphiz any thoughts/tips?
(This post was last modified: 2014-05-26 13:07 by rofuz.)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,827
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #4
Me? Never ... flip the vsync setting in xbmc settings and really ensure that it is turned on at the end ...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
rofuz Offline
Junior Member
Posts: 9
Joined: May 2014
Reputation: 0
Post: #5
Found out what was causing the problem. If you have not setup your Mac audio midi settings correctly: you will have tearing and issue when playing movies (for 5.1 sound you have to revert back to 2.0 sound with passthrough) But if you set up the audio midi settings for 8 chanel (I use only 6 but my avr supports 8) then you can have the correct setting in xbmc = 5.1 (instead of 2.0) so much better! :-)
find quote
rofuz Offline
Junior Member
Posts: 9
Joined: May 2014
Reputation: 0
Post: #6
Still some tearing with 720/1080p but a lot better, when we can turn off passthrough all will be gone
find quote
rofuz Offline
Junior Member
Posts: 9
Joined: May 2014
Reputation: 0
Post: #7
Just tried the rc1 tearing gone now. Great!
find quote
rofuz Offline
Junior Member
Posts: 9
Joined: May 2014
Reputation: 0
Post: #8
Still some tearing, now on 13.1, anyone else with mac mini that has this issue?
find quote
Tomas_s Offline
Junior Member
Posts: 2
Joined: Aug 2014
Reputation: 0
Post: #9
I have the same problem with all 13.x releases.
Tearing is mostly on the top part of the image..

I'm running 12.3 without a problem
find quote
rofuz Offline
Junior Member
Posts: 9
Joined: May 2014
Reputation: 0
Post: #10
(2014-08-15 20:11)Tomas_s Wrote:  I have the same problem with all 13.x releases.
Tearing is mostly on the top part of the image..

I'm running 12.3 without a problem

Exactly the same...
find quote
rofuz Offline
Junior Member
Posts: 9
Joined: May 2014
Reputation: 0
Post: #11
13.2 is working as it should, great!
find quote
Tomas_s Offline
Junior Member
Posts: 2
Joined: Aug 2014
Reputation: 0
Post: #12
(2014-08-19 23:23)rofuz Wrote:  13.2 is working as it should, great!

Im still having the same problem with 13.2...
find quote
rofuz Offline
Junior Member
Posts: 9
Joined: May 2014
Reputation: 0
Post: #13
in some files yes, just saw some tearing. Need to investigate further. It is strange because some files actually work.
find quote