Green pixelating lines on xbmc 13

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
ylwfvr Offline
Junior Member
Posts: 17
Joined: Jan 2012
Reputation: 0
Post: #1
Wasn't sure where to post this. Trying to figure out what is causing this. I have my movies as mkv files. Attached are some screenshots of a clip from LOTR played on firetv with xbmc 13 This happens to bunch of my other movies.

I played this same movie on Apple TV 2 with xbmc 13 and it plays fine. Also works fine on my pivos xios running xbmc 12.0 as well as my windows 7 PC with xbmc 13.0

Thanks for any suggestions


[Image: BC7E0C70-A58E-4C2B-9168-05CFFDE9643C_zpsf0wqoz6s.png]

[Image: 3B32B60D-837F-4F3F-919C-9711AD6E4765_zpsgkj4egs4.png]
(This post was last modified: 2014-05-29 00:35 by ylwfvr.)
find quote
PatK Offline
Donor
Posts: 3,290
Joined: Mar 2010
Reputation: 75
Location: Canada
Post: #2
Intel GPUs seem to show a green line when using hardware decoding (VDA).

http://forum.xbmc.org/showthread.php?tid=172787

http://wiki.xbmc.org/index.php?title=Common_issues

looks like a gpu driver issue.
find quote
z31fanatic Offline
Member
Posts: 89
Joined: Oct 2012
Reputation: 2
Post: #3
The Fire TV doesn't have an Intel GPU.
find quote
ylwfvr Offline
Junior Member
Posts: 17
Joined: Jan 2012
Reputation: 0
Post: #4
The screen pics doesn't tell the whole story. The green lines actually flicker. The video is choppy. Kind of like when it storms and satellite signal begins to fade out.

I'll try to take some video and upload to YouTube to so you can see
(This post was last modified: 2014-05-30 14:46 by ylwfvr.)
find quote
Kib Offline
Team XBMC
Posts: 3,202
Joined: Jan 2010
Reputation: 53
Location: NL
Post: #5
It is an issue with the video card or video driver.

Neon skin - v3.0.7 now available for XBMC 13 (Gotham)
find quote
ylwfvr Offline
Junior Member
Posts: 17
Joined: Jan 2012
Reputation: 0
Post: #6
I ended up uninstalling Gotham and installed frodo 12.0 on my fire tv. I played the same files and had no issues. Movie played perfect without issue. At this point im sticking with frodo.
find quote
ylwfvr Offline
Junior Member
Posts: 17
Joined: Jan 2012
Reputation: 0
Post: #7
So I reinstalled Gotham. Found out that the acceleration settings impacted this. So when played around with the different parameters this issue would go away. But the video playing was super slow and would be jittery. The audio would then also not be in sync. This was streaming blu ray rips around 30GB mkv files on hard wired connection.
find quote
optics Offline
Junior Member
Posts: 8
Joined: Jan 2011
Reputation: 0
Post: #8
I too see this on the FireTV for select h.264 movies that have not been reencoded with Handbrake.

To replicate, simply rip any of the following blurays with MakeMkv, then play them on XBMC.

TV Shows
The Big Bang Theory
House of Cards
Justified
Lost

Movies
American Hustle
The Butler
Cloudy with a Chance of Meatballs
Gravity
The Great Gatsby
The Hobbit: Desolation of Smaug
Monuments Men
Nebraska
Pacific Rim
Philomena
Superman: Man of Steel
Warm Bodies


The problem persists regardless of whether you use StageFright only or MediaCodec. The problem exists is 13.1 and 13.2 beta 1.

The problem is greatly reduced (but not entirely eliminated) by remuxing the container to .ts with ffmpeg.
find quote
ylwfvr Offline
Junior Member
Posts: 17
Joined: Jan 2012
Reputation: 0
Post: #9
I'm struggling with why does the xbmc frodo 12.0 not have any issues but the newer Gotham does. That's what doesn't make sense to me.
find quote
jjd-uk Offline
Team-XBMC Member
Posts: 2,707
Joined: Oct 2011
Reputation: 58
Post: #10
Frodo did not support Libstagefright or Mediacodec Hardware Acceleration therefore for anything non-Pivos it was software decode only.
find quote
Ned Scott Offline
Team-XBMC Wiki Guy
Posts: 19,828
Joined: Jan 2011
Reputation: 247
Location: Arizona, USA
Post: #11
XBMC -> Settings -> Videos -> Acceleration -> disable "Mediacodec"

You can make easy links to the XBMC wiki using double brackets around common XBMC words: [[debug log]] = debug log, [[Video library]] = Video library, [[SMB]] = SMB , [[userdata]] = userdata, etc
find quote
optics Offline
Junior Member
Posts: 8
Joined: Jan 2011
Reputation: 0
Post: #12
It's still an issue in XBMC 13.2 beta 2 with Stagefright only (stf-264) enabled on the Amazon Fire TV.

If you use software only (ff-h264), then these videos play without green macro-blocking but they will drop frames even using multi-threaded software decoding.
find quote