Error while compile VNSI on yavdr0.5 (Ubuntu 12.04)

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
big_blue Offline
Junior Member
Posts: 10
Joined: Jan 2010
Reputation: 0
Post: #1
Hi.

First of all, this is the first time i try to compile a plugin for the VDR. I do my best for getting all the infos i need, but i am not able to get the VNSI plugin to compile on my Server. Hopefully with your help i will solve this problem.


I try to get the current version of the VNSI plugin running on my yavdr0.5 (ubuntu 12.04 LTS). I try to use the debian way by creating a package, but got a problem while compile the source. Here is what i have done.

install vdr-dev
download zipped sourcecode
move sourcecode to correct debian naming structure ($PLUGINNAME-$VERSION.tar.gz)
use debianize-vdrplugin to create the debian folder
dpkg-buildpackage -tc

Now the compile starts but after a few seconds i´ve got the following error message:
Code:
/usr/bin/ld: vnsi.o relocation R_X86_54_32S against 'vtable for cPluginVNSIServer' can not be used when making a shared object; recompile with -fPIC
I try to add the -fPIC option to the CFLAGS variable in the Makefile but still got the same error and not sure if this is the correct way.

It would be great, if someone of the community is able to help me with this problem. If you need more informations, please let me know.

Thanks,
bb
(This post was last modified: 2014-06-11 14:48 by big_blue.)
find quote
big_blue Offline
Junior Member
Posts: 10
Joined: Jan 2010
Reputation: 0
Post: #2
Hi.
I try to get some more informations. The make command is working very well. I am able to create the .so file and it looks ok. Maybe there is only a problem with the build of the debian package. So i will have a look about building a debian package.

Cheers
bb
find quote