No Audio on XBMCbuntu desktop

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Gombeek Offline
Donor
Posts: 21
Joined: Feb 2012
Reputation: 1
Post: #1
Hi,

Ive tried searching the guides, FAQ and the forum but no luck.

I have sound in XBMC, however i have no sound in the XBMCbuntu desktop. Im running a Intel Celeron 1037U Dual-Core 1.8GHz Processor.
I don't know if this is relevant but synaptic package manager will not open either.


Thanks
find quote
oldpoem Offline
Fan
Posts: 386
Joined: Jul 2010
Reputation: 6
Post: #2
You need properly config .asoundrc for your system to have sound in desktop. Try searching for that in forums.

Also latest XBMCBuntu has this problem with software that need root privilage won't run from menu. Which is still not address by dev. You need to use "sudo synaptic" from terminal to launch synaptic. They woud told you to use apt-get in terminal anyway.
find quote
Gombeek Offline
Donor
Posts: 21
Joined: Feb 2012
Reputation: 1
Post: #3
So searched .asoundrc and configured it, this did correct the issue, however i was stuck with a write permission error on boot. It turns out it is a grub boot error and it was caused from enabling LVM logical volume management during the install. It was a easy fix, just do a fresh install and don't enable LVM during the install.

Did a fresh install, no sound, edited the .asoundrc and it corrected the problem, I will still left with the issue of no network manager applet in the task bar, while messing around figuring out the solution to correct this last night (the solution was to add '@nm-applet" to ~/.config/lxsession/XBMCbuntu/autostart) i was forced to do a fresh install again for the 3rd time Smile

This time during the installation my network cable (which has a broken end and should be replaced) came out thus not installing the updates, the install went by much faster this time which should have been my first clue but I didn't notice this until i was in the desktop and went to youtube to confirm i still had no sound, plugged in my internet and sound worked perfectly without having to edit the .asoundrc. I don't particularly want to do a 4th fresh install to confirm this fixes the sound issue on the desktop without having to edit the .asoundrc but i think it might.
find quote