Super Turbo settings Raspberry Pi

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
popcornmix Offline
Team-Kodi Member
Posts: 2,967
Joined: Feb 2011
Reputation: 69
Post: #16
(2014-07-05 14:10)da-anda Wrote:  is there a reason why you use force_turbo? I always had the impression that the dynamic overclocking was acting pretty quick and I personally can sleep a bit better when I know that I'm not constantly stressing the CPU to it's max

I feel that force_turbo does give a performance boost - not huge but noticable.
I haven't got any benchmark numbers to prove it, so it could be placebo.
I'd be interested if anyone else thinks there is a difference (or even better has measured a difference in some use case).
find quote
invisable Online
Junior Member
Posts: 31
Joined: Dec 2013
Reputation: 0
Post: #17
Yeah mine can't handle these type of overclocks "wish it could" my psu provides 5.25v at 3amps when measured however I suppose, I could get a volt drop under some circumstances.
Does this show a noticeable performance increase then the standard turbo overclock settings ?
(This post was last modified: 2014-07-05 14:24 by invisable.)
find quote
FAMMAR Offline
Senior Member
Posts: 127
Joined: Dec 2013
Reputation: 2
Post: #18
My stable overclocksettings are: (tips are welcome)

force_turbo=1
gpu_mem=256
disable_overscan=1
arm_freq=1100
core_freq=550
sdram_freq=600
over_voltage=8
avoid_pwm_pll=1
temp_limit=80
hdmi_force_hotplug=1
hdmi_ignore_cec_init=1
find quote
doug Offline
Donor
Posts: 161
Joined: Apr 2012
Reputation: 5
Post: #19
My stable overclock settings are:
Code:
gpu_mem=256
force_turbo=1
hdmi_force_hotplug=1
hdmi_ignore_cec_init=1
arm_freq=1050
core_freq=500
sdram_freq=600
over_voltage=8
hvs_priority=0x32ff

With these settings, the GUI is very fast. I've found my best power supply to be my Samsung Galaxy S4 plug and cable (more stable than chargers for my Kindle and an older Motorola phone)

If I attempt to use force_turbo=0, which I'd prefer to do, I can never boot the RPi. Any thoughts on why that would be?
find quote
FAMMAR Offline
Senior Member
Posts: 127
Joined: Dec 2013
Reputation: 2
Post: #20
hvs_priority=0x32ff


What is the benefit of this setting?
find quote
doug Offline
Donor
Posts: 161
Joined: Apr 2012
Reputation: 5
Post: #21
(2014-07-05 23:48)FAMMAR Wrote:  hvs_priority=0x32ff


What is the benefit of this setting?
It's preventing audio dropouts for me with 1080i Live TV
find quote
Dalton63841 Offline
Member
Posts: 74
Joined: May 2014
Reputation: 3
Post: #22
(2014-07-05 16:11)FAMMAR Wrote:  My stable overclocksettings are: (tips are welcome)

force_turbo=1
gpu_mem=256
disable_overscan=1
arm_freq=1100
core_freq=550
sdram_freq=600
over_voltage=8
avoid_pwm_pll=1
temp_limit=80
hdmi_force_hotplug=1
hdmi_ignore_cec_init=1

My raspberry pi running OpenElec, with storage on a USB3 drive, and an iPad power supply, is handling these settings perfectly stable. REALLY brought a new level of snappiness to the UI.
find quote
MediaPi Offline
Fan
Posts: 488
Joined: Apr 2013
Reputation: 5
Post: #23
I've taken of
over_voltage_sdram=4
from my settings white keeping sdram @ 8 and it seems to be fine so thankyou FAMMAR.

the reason why I wanted to avoid using
avoid_pwm_pll=1
was because Im using analogue audio. but on my hdtv I'm going to try your setting.

I think this is it for a super turbo setting for a pi rather than having

arm=1000
core=500
sdram=500
over_voltage=6

the superturbo setting are this

arm=1100
core=550
sdram=600
over_voltage=8

Big Grin but you need to add other stuff that FAMMAR included

force_turbo=1
gpu_mem=256
disable_overscan=1
arm_freq=1100
core_freq=550
sdram_freq=600
over_voltage=8
avoid_pwm_pll=1
temp_limit=80
hdmi_force_hotplug=1
hdmi_ignore_cec_init=1

thanks FAMMAR, this wont work for everyone but ou can give it a go

EDIT: it froze on me so I would put
over_voltage_sdram=4
with FAMMARs setting if you get the same freeze like me
(This post was last modified: 2014-07-06 12:53 by MediaPi.)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 4,192
Joined: Jan 2011
Reputation: 94
Post: #24
Why are you using a lower temp_limit, this will result in the Pi throttling earlier than usual. The default is 85.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
DBMandrake Offline
Fan
Posts: 437
Joined: Feb 2013
Reputation: 12
Location: UK
Post: #25
Here's my best stable overclock:

Code:
arm_freq=1000
core_freq=500
isp_freq=450
sdram_freq=550
over_voltage=6

This is with a well regulated 2 amp 5.25v supply and no heat sinks.

It runs 24/7 and is 100% stable in Raspbmc. 50Mhz higher on any of the clocks and it will freeze and reboot randomly within an hour typically, 100Mhz more on any of the clocks and it will freeze and reboot within a minute or two, so I know I'm pretty close to the limits.

In my case its not the voltage that's the limitation - with the higher clock speeds where I start to see freezes it still measures 4.95v. (At the above overclock it stays between 5.05-5.10v)

XBMC 13.2 - Mid 2007 Mac Mini, 4GB, 2TB HD, OS X 10.6.8.
XBMC 13.2 - Raspberry Pi 512MB Model B, 16GB SD, Raspbmc.
(This post was last modified: 2014-07-06 21:34 by DBMandrake.)
find quote
Dalton63841 Offline
Member
Posts: 74
Joined: May 2014
Reputation: 3
Post: #26
(2014-07-06 12:24)MediaPi Wrote:  I've taken of
over_voltage_sdram=4
from my settings white keeping sdram @ 8 and it seems to be fine so thankyou FAMMAR.

the reason why I wanted to avoid using
avoid_pwm_pll=1
was because Im using analogue audio. but on my hdtv I'm going to try your setting.

I think this is it for a super turbo setting for a pi rather than having

arm=1000
core=500
sdram=500
over_voltage=6

the superturbo setting are this

arm=1100
core=550
sdram=600
over_voltage=8

Big Grin but you need to add other stuff that FAMMAR included

force_turbo=1
gpu_mem=256
disable_overscan=1
arm_freq=1100
core_freq=550
sdram_freq=600
over_voltage=8
avoid_pwm_pll=1
temp_limit=80
hdmi_force_hotplug=1
hdmi_ignore_cec_init=1

thanks FAMMAR, this wont work for everyone but ou can give it a go

EDIT: it froze on me so I would put
over_voltage_sdram=4
with FAMMARs setting if you get the same freeze like me

Ironically, although my Pi handles these settings very well, adding over_voltage_sdram=4 causes it to freeze almost immediately.
find quote
popcornmix Offline
Team-Kodi Member
Posts: 2,967
Joined: Feb 2011
Reputation: 69
Post: #27
(2014-07-05 23:48)FAMMAR Wrote:  hvs_priority=0x32ff

It's preventing audio dropouts for me with 1080i Live TV

I wonder if you could experiment with this setting. The default for this is:
hvs_priority=0x32f4

Can you try varying the final digit between 4 and f and find the lowest value that cures the dropouts?
Setting it to f does produce a small performance penalty. It would be nice to work out what the ideal value is (possibly to make it a default).
find quote
doug Offline
Donor
Posts: 161
Joined: Apr 2012
Reputation: 5
Post: #28
(2014-07-08 13:29)popcornmix Wrote:  Can you try varying the final digit between 4 and f and find the lowest value that cures the dropouts?
Setting it to f does produce a small performance penalty. It would be nice to work out what the ideal value is (possibly to make it a default).

I would be happy to do that...but my server motherboard crapped out on me on the weekend. I'm limping along with an old setup without TV until I can get my replacement board from Asus.
(This post was last modified: 2014-07-08 16:11 by doug.)
find quote
MediaPi Offline
Fan
Posts: 488
Joined: Apr 2013
Reputation: 5
Post: #29
Will Overclocking the Ram help with XBMC? if so how much. Im talking mainly about addons. Load time and stuff
find quote
popcornmix Offline
Team-Kodi Member
Posts: 2,967
Joined: Feb 2011
Reputation: 69
Post: #30
(2014-07-13 18:42)MediaPi Wrote:  Will Overclocking the Ram help with XBMC? if so how much. Im talking mainly about addons. Load time and stuff

Yes, it all helps. I find most Pi's can handle sdram_freq=600.
It is mostly the arm_freq that affects add-on speed.
They are written in python which isn't the fastest language. It's often the RegEx code that is slow in these.

Many add-ons perform quite well on Pi (I use iplayer regularly and that's pretty responsive).
With a bit of tweaking some have been improved a lot (I think Sports Devil was made several times faster by tweaking the RegExes).

If there is a specific add-on that is slow, reporting it here may be worthwhile:
http://forum.xbmc.org/showthread.php?tid...id=1684389
find quote
Post Reply