Linux - No album art + musicdb error in log

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Scooby-2 Offline
Junior Member
Posts: 5
Joined: Dec 2012
Reputation: 0
Post: #1
This is driving me round the bend - I am completely unable to enable album art for our CD collection. I am running a Raspberry Pi with version: XBMC 13.1 Git: unknown. Compiled Jun 11 2014 (this is what is reported on the TV). NONE of my CDs show any album art. I have made sure that the tracks are all MP3 ID3v2 compliant with all fields completed. Originally I was playing music on a NAS server but I read there are problems with album art on NAS-based files. I did try both Samba and NFS but neither showed album art. I have now copied a CD's tracks to the Pi itself - but there is still no album art. If I play the music in Exaile on my Linux machine it displays the album art correctly, so I don't think it's a problem with my methoid of tagging. I upgraded the XBMC version, going to a newer build - same problem. I tried a different Pi - no different. I enabled debug level logging and I can see something about a problem with the music database:
Code:
ERROR: Open - failed to open source <musicdb://artists/4/6/66.mp3?albumartistsonly=false&albumid=6&artistid=4>
Is this the problem? Does anyone know how to fix this?

I think XBMC is brilliant, but not being able to add Album art is a bit of a downer. Any help is appreciated.
(This post was last modified: 2014-07-08 22:06 by Scooby-2.)
find quote