is there anyway to make the youtube addon faster or tolerable to use

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
smcauley600 Offline
Junior Member
Posts: 7
Joined: Apr 2014
Reputation: 0
Post: #1
is there anyway to make the youtube addon on openelec/raspbmc faster it is so slow and to try and watch even a trailer and i end up growing a beard waiting for it
find quote
Milhouse Offline
Team-Kodi Member
Posts: 4,185
Joined: Jan 2011
Reputation: 94
Post: #2
Can't say I've ever noticed a problem on a 1GHz Pi with 20Mbps broadband and wired ethernet - YouTube video playback starts in under 10 seconds. Of course ten seconds may be how long it takes you to grow a beard, who knows unless you can be a little more precise.

Try overclocking. Get a faster internet connection. Don't use WiFi. It's rather hard to be precise when you fail to describe the setup that is causing you a problem.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2014-07-09 03:59 by Milhouse.)
find quote
da-anda Offline
Team-Kodi Member
Posts: 3,154
Joined: Jun 2009
Reputation: 39
Location: germany
Post: #3
the addon itself probably could be made more efficient and thus faster. It's also dead slow on my HTPC.
find quote
DBMandrake Offline
Fan
Posts: 436
Joined: Feb 2013
Reputation: 12
Location: UK
Post: #4
Hmm, can't say that I've noticed the youtube addon itself is unusually slow - on both my Mac and RPi it's generally as fast or faster than most of my other addons. (Problems with login credentials is a whole other issue though... Wink )

Are we talking about navigation speed through the addon, (how long it takes to navigate to each level, do searches etc) how long it takes a video to start after selecting it (buffering etc) or actual video playback ?

Youtube in general can be very slow with buffering on some ISP's in peak times - doesn't matter what device you try to use. I often see problems with the youtube app on my ipad buffering or dropping down to lower quality then back up again every couple of minutes even on a 30Mbps connection which is otherwise performing perfectly normally and gives a full 30mbps on speedtest.net - not enough bandwidth from the ISP to Youtube...in the UK at least this has been an ongoing intermittent issue for a couple of years now on the major ISP's...

XBMC 13.2 - Mid 2007 Mac Mini, 4GB, 2TB HD, OS X 10.6.8.
XBMC 13.2 - Raspberry Pi 512MB Model B, 16GB SD, Raspbmc.
(This post was last modified: 2014-07-10 12:01 by DBMandrake.)
find quote
da-anda Offline
Team-Kodi Member
Posts: 3,154
Joined: Jun 2009
Reputation: 39
Location: germany
Post: #5
it felt slow in overall usage and I'm not logged it. Only do random searches every once in a while. Maybe addon got better in the meantime - haven't manually used it for some time.
find quote