RSS feed links broken

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Anthirian Offline
Member
Posts: 97
Joined: Jan 2012
Reputation: 1
Post: #1
Hi,

The RSS feeds from the addons section on the homepage seem broken. The headers are updated just fine, but when you actually try to view the content you receive a FeedBurner error. For example, I try viewing the details about the Vine addon that was recently updated according to the feed, which brings me to the following page: http://feeds.xbmc.org/plugin.video.vine. It looks like it tries to load plugin.video.vine from the feeds subdomain, while it would need to load it from the addons subdomain, so I tried changing it to http://addons.xbmc.org/plugin.video.vine, but then I get a 404.

Edit: apparently switching the subdomain to "addons" and adding the "show" parent folder to the URL will bring you to the correct page, e.g. http://addons.xbmc.org/show/plugin.video.vine . This seems like an issue that can be resolved fairly quickly once the feed admin sees this.

I mistakenly posted this in the Addons Support subforum quite a while ago, but it appears to be more appropriate here. Could a moderator would be so kind as to remove the other topic please?

Anthirian

[Image: all-thin-banner@2x.jpg]
find quote
zag Offline
Team-XBMC Member
Posts: 1,662
Joined: Oct 2007
Reputation: 19
Location: UK
Post: #2
Yes thats something to do with the extra Feedburner link as the code shows a relative path.

It works fine if you use the direct RSS page link.

I'd wait to see what Da-anda thinks is best.

HTPC - XBMC Gotham, OpenELEC, Harmony Smart Remote, Intel Haswell NUC, 40gb intel SSD, Core i3, 4gb RAM
Storage - 2 x qnap 8tb 419p+ NAS
Display LG 46" LCD + Casio Bulbless projector [PICS]
[Image: widget]
find quote
da-anda Offline
Team-XBMC Member
Posts: 2,751
Joined: Jun 2009
Reputation: 37
Location: germany
Post: #3
huh, the baseUrl/domain was missing in the configuration and thus all links got created relative. Should be fixed on next feedburner update.
find quote
Anthirian Offline
Member
Posts: 97
Joined: Jan 2012
Reputation: 1
Post: #4
Thanks for picking this up. It seems like it's partially fixed now. Links to e.g. Films for Action now look like this:

http://addons.xbmc.org/plugin.video.film...Add-Ons%29

However, the /show/ folder is missing from the URL. It should be like this:

http://addons.xbmc.org/show/plugin.video...Add-Ons%29

Although this too doesn't seem to work, because I don't get to see the the disclaimer instead of the actual addon. Maybe it has to do with the utm_arguments?

[Image: all-thin-banner@2x.jpg]
find quote
da-anda Offline
Team-XBMC Member
Posts: 2,751
Joined: Jun 2009
Reputation: 37
Location: germany
Post: #5
argh, stupid google analytics crap. Will have a look
find quote