XBMC 13.1 crashes Windows 8.1 x64 Intel Nuc d54250wyk

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
vpekus Offline
Junior Member
Posts: 12
Joined: Jul 2014
Reputation: 0
Post: #1
Hi! i have a problem with XBMC 13.1 installed on intel Nuc d54250wyk running windows 8.1 x64, xbmc crashes in many different situations , sometimes a few seconds after launching xbmc and navigating menus , sometimes during playback of video files, the last crash was when i watched a movie with TMT 6 as external player after about 1.5-2 hours xbmc suddenly crashes. I can not find a reason as every time xbmc hangs in different situations. the most frequent crashes happen when i start my htpc (xbmc start automatic) and i start to watch a movie , after about 2 minutes xbmc crashes, then if i run xbmc again and play the same(or any other) movie, it won't crash any more until next reboot.

log files :
xbmc.log: http://xbmclogs.com/show.php?id=244017
xbmc.old.log: http://xbmclogs.com/show.php?id=244018
crashlog: http://xbmclogs.com/show.php?id=244019

Thanks in advance for any help.
(This post was last modified: 2014-07-10 20:24 by vpekus.)
find quote
tssgery Offline
Member
Posts: 72
Joined: May 2007
Reputation: 0
Post: #2
I had a similar issue running XBMCbuntu on an Intel NUC. Turns out that one of my memory modules was bad.

If you have two modules in there, try taking one out at a time and see if the problem goes away.
find quote
PatK Offline
Donor
Posts: 3,442
Joined: Mar 2010
Reputation: 75
Location: Canada
Post: #3
Yes it smacks of hardware issues.... BTW: the log is not a debug log and it appears to have issues with the gfx driver, I suggest a gfx driver re-install with the latest.
find quote
vpekus Offline
Junior Member
Posts: 12
Joined: Jul 2014
Reputation: 0
Smile  RE: XBMC 13.1 crashes Windows 8.1 x64 Intel Nuc d54250wyk
Post: #4
seems to be ok now Blush, after reinstalling the gfx and audio driver, and updating the bios. thanks for help!
(This post was last modified: 2014-07-14 06:15 by vpekus.)
find quote
vpekus Offline
Junior Member
Posts: 12
Joined: Jul 2014
Reputation: 0
Post: #5
(2014-07-10 20:31)tssgery Wrote:  I had a similar issue running XBMCbuntu on an Intel NUC. Turns out that one of my memory modules was bad.

If you have two modules in there, try taking one out at a time and see if the problem goes away.

don't sure that this is a memory (hardware) problem, because all other programs run smoothly,and I prefer to first try to resolve the problem without disassembling the computer because I have modified my Nuc by installing internal hdmi-cec adapter inside, and it's not very easy to pull out the memory slot now. but I will keep in mind this option, thank you anyway.
find quote
vpekus Offline
Junior Member
Posts: 12
Joined: Jul 2014
Reputation: 0
Post: #6
(2014-07-13 18:04)PatK Wrote:  Yes it smacks of hardware issues.... BTW: the log is not a debug log and it appears to have issues with the gfx driver, I suggest a gfx driver re-install with the latest.

after installing\ reinstalling and updating all the latest drivers and bios , the problem is gone for awhile ,but now xbmc crashes again and again in a different situations, sometimes even when I just turn on xbmc and leave it to work without playing anything and not even touching the remote.

last crash was when after using xbmc i turned my tv off (the tv sends cec power off command to pc), the computer does not turn off and xbmc crashed.

log files (debug mode)

xbmc.log: http://xbmclogs.com/show.php?id=251302
xbmc.old.log: http://xbmclogs.com/show.php?id=251303
crashlog: http://xbmclogs.com/show.php?id=251304

p.s. now i have XBMC 13.2 Gotham – beta 1 installed, but the problem existed in earlier versions(12.2, 13 and 13.1).
(This post was last modified: 2014-07-22 21:40 by vpekus.)
find quote
Martijn Offline
Team Kodi
Posts: 11,576
Joined: Jul 2011
Reputation: 167
Location: Dawn of time
Post: #7
Don't use paste sites for windows dmp files. It's useless. Find a filesharing service

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
vpekus Offline
Junior Member
Posts: 12
Joined: Jul 2014
Reputation: 0
Post: #8
My setup:

XBMC 13.2 Gotham – beta 1 (but the problem existed in earlier versions: 12.2, 13 and 13.1.)
Windows windows 8.1 x64 update 1
intel Nuc d54250wyk ( Intel HD Graphics 5000, 4th Gen Intel Core i5-4250U) graphic driver version 10.18.10.3643
8GB ram Crucial "CT51264BF160BJ" (PC12800, 1600МГц, CL11)
Msata SSD SATA3 240ГБ CRUCIAL M500 ( CT240M500SSD1 )
Internal HDMI-CEC Adapter

the pc connected to TV (LG 55LM860V) through AV receiver (Denon AVR-X4000).
(This post was last modified: 2014-07-22 22:01 by vpekus.)
find quote
vpekus Offline
Junior Member
Posts: 12
Joined: Jul 2014
Reputation: 0
Post: #9
another crash while watching youtube

debug xbmc.log: http://xbmclogs.com/show.php?id=252468
debug xbmc.old.log: http://xbmclogs.com/show.php?id=252469
XBMC crashlog: https://www.sendspace.com/file/1demg8 - xbmc_crashlog-13.2-BETA1 Git_20140711-450924a-20140723-213410.dmp

can someone please check the log files and tell me what could be the problem ?

thanks in advance.
(This post was last modified: 2014-07-23 20:05 by vpekus.)
find quote
vpekus Offline
Junior Member
Posts: 12
Joined: Jul 2014
Reputation: 0
Post: #10
sorry for the dmp files, I just noticed that the crash log files are in dmp format.

here are last 5 crash files:

https://www.sendspace.com/file/9lea3w - xbmc_crashlog-13.1 Git_20140604-84725b0-20140715-203434.dmp

https://www.sendspace.com/file/0i09kh - xbmc_crashlog-13.1 Git_20140604-84725b0-20140718-225537.dmp

https://www.sendspace.com/file/0vycyc - xbmc_crashlog-13.2-BETA1 Git_20140711-450924a-20140720-150300.dmp

https://www.sendspace.com/file/fexfti - xbmc_crashlog-13.2-BETA1 Git_20140711-450924a-20140721-205442.dmp

https://www.sendspace.com/file/1demg8 - xbmc_crashlog-13.2-BETA1 Git_20140711-450924a-20140723-213410.dmp

I can upload more if needed.
(This post was last modified: 2014-07-23 19:59 by vpekus.)
find quote
PatK Offline
Donor
Posts: 3,442
Joined: Mar 2010
Reputation: 75
Location: Canada
Post: #11
Still looks like a driver error "ERROR: LoadLibrary('atiadlxx.dll') failed"

Switch over to software rendering to see if the gfx works in that mode. Crash on close is usually a call to the net that has not returned.... an add-on problem.
find quote
vpekus Offline
Junior Member
Posts: 12
Joined: Jul 2014
Reputation: 0
Post: #12
(2014-07-24 04:00)PatK Wrote:  Still looks like a driver error "ERROR: LoadLibrary('atiadlxx.dll') failed"

Switch over to software rendering to see if the gfx works in that mode. Crash on close is usually a call to the net that has not returned.... an add-on problem.

I Switched to software rendering and the gfx works great, but it crashed again after restarting pc , running XBMC and just navigating menus without access to any addons or playing something.

debug xbmc.log: http://xbmclogs.com/show.php?id=253103
debug xbmc.old.log: http://xbmclogs.com/show.php?id=253104
Crash log http://sharesend.com/n4ns79ae xbmc_crashlog-13.2-BETA1 Git_20140711-450924a-20140724-221855.dmp

I will try to uninstall addons.
find quote
vpekus Offline
Junior Member
Posts: 12
Joined: Jul 2014
Reputation: 0
Sad  RE: XBMC 13.1 crashes Windows 8.1 x64 Intel Nuc d54250wyk
Post: #13
(2014-07-24 04:00)PatK Wrote:  Still looks like a driver error "ERROR: LoadLibrary('atiadlxx.dll') failed"

Switch over to software rendering to see if the gfx works in that mode. Crash on close is usually a call to the net that has not returned.... an add-on problem.

I disabled and uninstalled all third-party plugins but the problem still there Sad
find quote
paavor Offline
Donor
Posts: 90
Joined: Mar 2011
Reputation: 4
Location: Tampere, Finland
Post: #14
(2014-07-24 04:00)PatK Wrote:  Still looks like a driver error "ERROR: LoadLibrary('atiadlxx.dll') failed"

This error message comes from XBMC's CEC module. I get that too and I don't even have ATI/AMD hardware. Smile I think it just tries to probe if AMD/ATI hardware is present. That error message is most likely harmless and not related to crashing.

You can test it by disabling CEC hardware from "Device Manager -> Ports" and starting XBMC again. You don't have to remove actual hardware, just disable it temporary and that error message goes away.

Kodi @ Windows Server 2012 R2 | Pulse-Eight USB-CEC Adapter
find quote
vpekus Offline
Junior Member
Posts: 12
Joined: Jul 2014
Reputation: 0
Post: #15
(2014-08-03 03:20)paavor Wrote:  
(2014-07-24 04:00)PatK Wrote:  Still looks like a driver error "ERROR: LoadLibrary('atiadlxx.dll') failed"

This error message comes from XBMC's CEC module. I get that too and I don't even have ATI/AMD hardware. Smile I think it just tries to probe if AMD/ATI hardware is present. That error message is most likely harmless and not related to crashing.

You can test it by disabling CEC hardware from "Device Manager -> Ports" and starting XBMC again. You don't have to remove actual hardware, just disable it temporary and that error message goes away.

Thank you for replay , but i dont care about that error message , my problem is crashing. if you think that the error message not related to crashing , what you think can cause the crashing?
find quote
Post Reply