MovieMeter.nl (Dutch Movies) Scraper development...

  Thread Rating:
  • 5 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
_Mitch_ Offline
Junior Member
Posts: 15
Joined: Dec 2010
Reputation: 1
Post: #316
Just istalled RC2 and notice moviemeter scrapper not working , hope @Thegost16 fix it soon
find quote
FibreNL Offline
Junior Member
Posts: 15
Joined: Dec 2011
Reputation: 0
Post: #317
konti Wrote:It's not an issue with XBMC. It seems there's an issue with the website of theghost16 that is used by the scraper. There is an issue with his mysql server. Let's just wait for theghost16 to fix it.
@Thegost16 I suggest to hide the "user friendly" error messages. It provides too much information.

Oke hope he will fix it soon whant my Dutch movie info back hahaha
find quote
The_Ghost16 Offline
Senior Member
Posts: 102
Joined: Dec 2009
Reputation: 0
Location: Netherlands
Post: #318
I changed some database settings last week and was thinking it would work Sad but i will try to fix this ASAP.

EDIT: Problem is fixed Smile it should work now.
(This post was last modified: 2012-03-05 10:08 by The_Ghost16.)
find quote
FibreNL Offline
Junior Member
Posts: 15
Joined: Dec 2011
Reputation: 0
Post: #319
yes downloading moviemeter ingo again ty for the fixBig GrinBig GrinBig Grin
find quote
Peekstra Offline
Junior Member
Posts: 26
Joined: Aug 2009
Reputation: 0
Post: #320
Hi,

these two movies fail to download info:

Karen Llora en un Bus (2011)

and

Guizi Lai Le (2000)

Does scaper need to be "fixed" to get them to download? The information is exactly as listed on the site.

thanks!
find quote
The_Ghost16 Offline
Senior Member
Posts: 102
Joined: Dec 2009
Reputation: 0
Location: Netherlands
Post: #321
I could find both movies. So I think something else is going wrong.
Can you enable debug logging and see what it says.
find quote
Peekstra Offline
Junior Member
Posts: 26
Joined: Aug 2009
Reputation: 0
Post: #322
Edit: Oops, I misread your answer, I'll turn on the debugging level and post the results.


thanks.
(This post was last modified: 2012-03-20 12:21 by Peekstra.)
find quote
The_Ghost16 Offline
Senior Member
Posts: 102
Joined: Dec 2009
Reputation: 0
Location: Netherlands
Post: #323
I COULD find both movies in Moviemeter and on my own website. Now trying to add them to XBMC to see what happens then.

Edit: Tested with XBMC and also find them both. Could you update your library again and see what happens.
(This post was last modified: 2012-03-20 12:34 by The_Ghost16.)
find quote
Peekstra Offline
Junior Member
Posts: 26
Joined: Aug 2009
Reputation: 0
Post: #324
Hmmm... I now was also able to refresh the information and update the info from moviemeter. The previous time I did this a keyboard appeared to enter a name and now I could select the correct entry.

Maybe XBMC just wasn't able to connect to the internet service at that time? Or should that produce an error?
find quote
The_Ghost16 Offline
Senior Member
Posts: 102
Joined: Dec 2009
Reputation: 0
Location: Netherlands
Post: #325
It could be that the movies weren't known to my website so it has to look at the moviemeter website. And my website already made 5000 requests to the API and therefore it couldn't find anything.
But I don't know this for sure.

I'm glad it works.
find quote
Peekstra Offline
Junior Member
Posts: 26
Joined: Aug 2009
Reputation: 0
Post: #326
Hi,

I have movie which I've not been able to scrape for a couple of days now. I have the debug log so maybe you can see why it's not working?

The title of the movie is Le Havre (2011).

Code:
20:58:44 T:6180   DEBUG: ADDON::CScraper::FindMovie: Searching for 'Le Havre' using MovieMeter scraper (path: 'C:\Users\admin\AppData\Roaming\XBMC\addons\metadata.moviemeter.nl', content: 'movies', version: '1.2.0')
20:58:44 T:6180   DEBUG: scraper: CreateSearchUrl returned <url>http://www.theghost16.nl/MovieMeter/index.php?movie=le%20havre%20(2011)</url>
20:58:44 T:6180   DEBUG: FileCurl::Open(0124C5A0) http://www.theghost16.nl/MovieMeter/index.php?movie=le%20havre%20(2011)
20:58:44 T:6180    INFO: XCURL::DllLibCurlGlobal::easy_aquire - Created session to http://www.theghost16.nl
20:58:44 T:6180   DEBUG: scraper: GetSearchResults returned <?xml version='1.0' encoding='iso-8859-1' standalone='yes'?><results></results>
20:58:44 T:6180   DEBUG: ADDON::CScraper::FindMovie: Searching for 'Le Havre' using MovieMeter scraper (path: 'C:\Users\admin\AppData\Roaming\XBMC\addons\metadata.moviemeter.nl', content: 'movies', version: '1.2.0')
20:58:44 T:6180   DEBUG: scraper: CreateSearchUrl returned <url>http://www.theghost16.nl/MovieMeter/index.php?movie=le%20havre%20(2011)</url>
20:58:44 T:6180   DEBUG: FileCurl::Open(0124C5A0) http://www.theghost16.nl/MovieMeter/index.php?movie=le%20havre%20(2011)
20:58:44 T:6180   DEBUG: scraper: GetSearchResults returned <?xml version='1.0' encoding='iso-8859-1' standalone='yes'?><results></results>

If I manually go to http://www.theghost16.nl/MovieMeter/inde...e%20(2011) I get the following message:

Movie already not found today.

thanks!
(This post was last modified: 2012-03-25 21:07 by Peekstra.)
find quote
The_Ghost16 Offline
Senior Member
Posts: 102
Joined: Dec 2009
Reputation: 0
Location: Netherlands
Post: #327
I looked at the movie and i tried to find it.
But in Moviemeter I can find the movie by using this title but I can't find the movie by using the API of Moviemeter.

I've added this to my own database by hand so it can be found. But it could be that the information that is shown isn't complete.
find quote
Peekstra Offline
Junior Member
Posts: 26
Joined: Aug 2009
Reputation: 0
Post: #328
Thanks!
find quote
Dr_IT Offline
Junior Member
Posts: 33
Joined: Mar 2012
Reputation: 1
Post: #329
I have multiple movies that don't get scraped, f.e.

Abduction (2011)
No: http://www.theghost16.nl/MovieMeter/inde...=abduction
Yes: http://www.theghost16.nl/MovieMeter/inde...%282011%29
Why does year have to be added instead of just "abduction"?

Captain America - The First Avenger (2011)
No: http://www.theghost16.nl/MovieMeter/inde...%20america
Yes: http://www.theghost16.nl/MovieMeter/inde...%282011%29
Why not only part of movie name?

Thanks in advance!
find quote
The_Ghost16 Offline
Senior Member
Posts: 102
Joined: Dec 2009
Reputation: 0
Location: Netherlands
Post: #330
(2012-03-30 15:28)Dr_IT Wrote:  I have multiple movies that don't get scraped, f.e.

Abduction (2011)
No: http://www.theghost16.nl/MovieMeter/inde...=abduction
Yes: http://www.theghost16.nl/MovieMeter/inde...%282011%29
Why does year have to be added instead of just "abduction"?
This is because there can be more than one movie with that title. In this case with the movie Abduction there are 3 movies found.
(2012-03-30 15:28)Dr_IT Wrote:  Captain America - The First Avenger (2011)
No: http://www.theghost16.nl/MovieMeter/inde...%20america
Yes: http://www.theghost16.nl/MovieMeter/inde...%282011%29
Why not only part of movie name?
For this case it is the same as the above one. It can find more than one movie and therefore give incorrect results.

For the scraper it is very important to have correct filenames because that makes the result much more accurate.
find quote
Post Reply