[RELEASE] Just another YouTube (Video) Plugin

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
anoobie Offline
Skilled Skinner
Posts: 187
Joined: Aug 2006
Reputation: 17
Post: #31
hey, thanks for the plugin. I just wanna say that videos only play for about 3 seconds and then they stop. The videos from search function play to normal full length. Thanks
find quote
Unbehagen Offline
Skilled Python Coder
Posts: 347
Joined: Jul 2007
Reputation: 4
Location: Bremen, Germany
Post: #32
anoobie Wrote:hey, thanks for the plugin. I just wanna say that videos only play for about 3 seconds and then they stop. The videos from search function play to normal full length. Thanks

Use a different player core (MPlayer). Configure it in the plugin settings. DVDPlayer has strange caching behaviour. The expected behaviour if the cache is empty would be to pause playback and refill the cache. Instead, DVDPlayer seems to stop the video sometimes. I'm not into the video stuff in XBMC, but this seems to be a known bug.
find quote
Rand Al Thor Offline
Collect3 Project Manager
Posts: 916
Joined: Jul 2005
Post: #33
Hmm search works great but for some reason every video is still called "watch" it might be something to do with my setup though, im using xbmc linux. Cheers for the great script.
find quote
C-Quel Offline
Retired Team-Kodi Member
Posts: 1,375
Joined: Aug 2004
Reputation: 0
Post: #34
Rand Al Thor Wrote:Hmm search works great but for some reason every video is still called "watch" it might be something to do with my setup though, im using xbmc linux. Cheers for the great script.

probablyin files view i guess... try library or visa versa? Confused

Zotac ID89 + 4GB + 160GB Intel SSD + Samsung UE40D7000 + DS411+II / 2 x 3TB WD RED CAVIAR (TVHeadend Package + 4 Tuners) + Fibaro HC2 Home Automation Intergration!

^^^

Fucking awesome springs to mind :)

iNerd Store

iNerd Forum
find quote
Rand Al Thor Offline
Collect3 Project Manager
Posts: 916
Joined: Jul 2005
Post: #35
I only use library view (because it is freakin awesome!) i will give files view a try and see if that changes anything.
find quote
hani Offline
Junior Member
Posts: 35
Joined: May 2007
Reputation: 0
Post: #36
Reason you are getting watch as the name is I'm passing the full url as the last argument in the file name.
the url of youTube video looks something like this "http://www.youtube.com/watch?v=ID"
and I think in the library view xbmc is interpreting watch as the name of the video.
well I guess in general If you pass a url with segments then the last segment will be take as a label, I could be wrong I just notice that.
I do not have a quick fix for that but I will look into rectifying this issue in the coming update.

Regards.
find quote
Unbehagen Offline
Skilled Python Coder
Posts: 347
Joined: Jul 2007
Reputation: 4
Location: Bremen, Germany
Post: #37
hani Wrote:Reason you are getting watch as the name is I'm passing the full url as the last argument in the file name.
the url of youTube video looks something like this "http://www.youtube.com/watch?v=ID"
and I think in the library view xbmc is interpreting watch as the name of the video.
well I guess in general If you pass a url with segments then the last segment will be take as a label, I could be wrong I just notice that.
I do not have a quick fix for that but I will look into rectifying this issue in the coming update.

Regards.
You need to supply at least one sort method and set one listitem infolabel. Again, look at the messy code of the joox plugin for example. Find the AddLink Method for setting the infolabel and search for sortmethod.
find quote
hani Offline
Junior Member
Posts: 35
Joined: May 2007
Reputation: 0
Post: #38
Thanx again that did the trick.
find quote
hani Offline
Junior Member
Posts: 35
Joined: May 2007
Reputation: 0
Post: #39
Just small update to make "Rand Al Thor" happy. Thanx to Unbehagen for the fix.

http://www.megaupload.com/?d=TY0MG7DN
find quote
MajorTom Offline
Senior Member
Posts: 229
Joined: May 2004
Reputation: 0
Post: #40
just wanted to say thanks hani.... great work so far (it is appreciated). keep at it Smile
find quote
Rand Al Thor Offline
Collect3 Project Manager
Posts: 916
Joined: Jul 2005
Post: #41
hani Wrote:Just small update to make "Rand Al Thor" happy. Thanx to Unbehagen for the fix.

http://www.megaupload.com/?d=TY0MG7DN

Hey thanks for the update Wink Hope you didn't go through the trouble just for me, but either way cheers!
find quote
hani Offline
Junior Member
Posts: 35
Joined: May 2007
Reputation: 0
Post: #42
Another update:

http://www.megaupload.com/?d=SA5NYYEE

I have extended the search function in this plugin to include the results from other search engines "Google video and Yahoo". You can select the search channel from the plugin settings dialog. And you can specify which web site you want to search.
The search function may not return any result depends on search engine indexing for that web site.

Streaming and downloading only available for YouTube videos "check the STUDIO tag for the video". I will try to fix this in next version.

I have tested the following websites:
vids.myspace.com
liveleak.com
gofish.com
metacafe.com
crackle.com


Please let me if you find other we sites being indexed by Google.I need this information to implement the streaming function. Thank you in advance.Nerd
find quote
wizbitz Offline
Junior Member
Posts: 11
Joined: Sep 2007
Reputation: 0
Post: #43
Thanks for this plugin.. Smile
find quote
Unbehagen Offline
Skilled Python Coder
Posts: 347
Joined: Jul 2007
Reputation: 4
Location: Bremen, Germany
Post: #44
hani, I added the plugin to my xbox plugin downloads page and the plugin all in one package. I hope that's okay as it gives people a convenient download method...It's not on a free hosting service!

http://theendofthelongestline.de/xbox/do.../index.php

If any of you want to support that page, open it and...look for the links on the left. You might want to click on those if you're interested in helping me a bit to keep that page up Wink
find quote
Rand Al Thor Offline
Collect3 Project Manager
Posts: 916
Joined: Jul 2005
Post: #45
Hmm, for some reason i get no sound with any of the videos. I am using the linux build with iec958 output so that might be part of the issue. If i remember correctly a few others in this thread are running this plugin on the linux build. Anyone else have sound issues? It is weird that the yahoo music plugin works fine, as do the apple trailers scripts. It might have something to do with the way the linux build handles mono audio. Cheers.
find quote