High CPU usage on Idle

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
t029248 Offline
Fan
Posts: 309
Joined: Apr 2004
Reputation: -10
Location: Holanda
Post: #1
When i start OSXBMC 1.6 the CPU usage is very high even when it's idle is always around 50%.

[Image: 20080315-tb7f3pw8n2572pdcdhf3fpbb86.png]


Mij MBP C2D 2.33 runs hot this way, and it sucks empty the battery empty in no time. Anyone else has this behavior?
find quote
Razor_109 Offline
Senior Member
Posts: 234
Joined: Nov 2007
Reputation: 0
Location: Netherlands
Post: #2
i heard turning on Vsync in options solves this.

The 'problem' is in idle the GUI is being ran at an FPS as high as possible so it max out the CPU. Not really a problem though but when you turn on Vsync in options it should thake less CPU i think
find quote
t029248 Offline
Fan
Posts: 309
Joined: Apr 2004
Reputation: -10
Location: Holanda
Post: #3
tnx f4 replying

I can't find that option, only Screen/vertical blanc sync, it was already set to "always enabled"

After some minutes running OSXBMC the Cpu usage drops a bit, but it's always above 10% and without a reason it's raising for periods to 50%
find quote
elan Offline
Team Plex
Posts: 278
Joined: Dec 2007
Location: Maui
Post: #4
I've verified that this is a bug even with vertical sync enabled.
find quote
CosyCat Offline
Senior Member
Posts: 263
Joined: Mar 2005
Reputation: 0
Location: Sweden
Post: #5
On my macbook(2Gig 2gig ram gma950 skin PM3)when doing nothing I always have 13-25% cpu?! When I hide xbmc(running 480p)to the dock CPU load increase from 15 to 30%?!(doing nothing)

Clean install of xbmc 0.1.7

[Image: cosycat.gif]
find quote
elan Offline
Team Plex
Posts: 278
Joined: Dec 2007
Location: Maui
Post: #6
Known issue, hopefully fixed in the next release (high CPU when hidden).

-elan
find quote
CosyCat Offline
Senior Member
Posts: 263
Joined: Mar 2005
Reputation: 0
Location: Sweden
Post: #7
still high cpu usage when hidden running 0.4.0

[Image: cosycat.gif]
find quote
t029248 Offline
Fan
Posts: 309
Joined: Apr 2004
Reputation: -10
Location: Holanda
Post: #8
yes, unfortunately it still is high when minimized (avg40%). After minutes the CPU temp goes up to 71 Celsius, and the fans kick in!
find quote
elan Offline
Team Plex
Posts: 278
Joined: Dec 2007
Location: Maui
Post: #9
The bug should be fixed in 0.4.1, when it's released.
find quote
hs-l Offline
Junior Member
Posts: 4
Joined: Apr 2008
Reputation: 0
Post: #10
elan Wrote:The bug should be fixed in 0.4.1, when it's released.

Too bad it still isn't fixed Smile
find quote
elan Offline
Team Plex
Posts: 278
Joined: Dec 2007
Location: Maui
Post: #11
If there's not a Ticket for this, please create one.

Thanks,

-elan
find quote