Wiki Needing to be further updated again?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
djdafreund Offline
Skilled Skinner
Posts: 562
Joined: Dec 2005
Reputation: 0
Location: Atlanta
Post: #1
Just tried fixing something with my xbmc sdl setup since i started getting build error's recently, and noticed the Wiki changes. I did have a question as well about what "(put in checkout path)\xbmc\tools\win32 " means? Sorry.
It seems (at least on both at my house and my friends house) that from the Wiki, "http://sourceforge.net/tracker/index.php?func=detail&aid=1882873&group_id=87054&atid=581840 " LINK for the patch to allow building again seems to be a dead link. And noticed some additions in the wiki have already been changed in the SVN which helps. But is there any way i can help make things easier to not have this be complicated for other users also wanting to build, it seems there are more steps being added, some files mentioned that a user has to find on the net and aren't linked?
I know that the SVN changes a lot and sometimes even broken temporary, but my question isn't about that. It is more about wanting to help out with making the setup portion a bit easier and less confusing to users that aren't as savy with using VC++ yet. Like maybe helping out with (partially done already, just to mess around.) some type of installer file that has all the downloaded needed files and automatically setup the directory in "program files\xbmc_lib" (as i am assuming none of them are illegal to obtain since this is open-sourced and already linked in the wiki.) and the other stuff.
I am just wanting to help contribute my work to help make this go easier for others. Or maybe once i get things myself on a more stable level and understanding of things, i can help produce already compiled versions of the SDL XBMC and put them up for others to grab, since i usually build linux and xbox versions anyway every day or every other day, i'd be doing the same with the SDL versions as well, but have more problems that seem to arise out of the blue days later.
Posted is the new problems i am all the sudden having now, that i didn't have just 3 days ago. And don't know enough to fix them, other then i did read and make the new changes mentioned in the wiki, but the PATCH link doesn't work so i couldn't do that part.

Output Info
http://pastebin.com/d76b555b5

Task List Info
http://pastebin.com/f222923c6

Thanks for the help and advice. I am really trying hard here.
find quote
WiSo Offline
Team-XBMC Developer
Posts: 2,695
Joined: Oct 2003
Reputation: 0
Location: Germany
Post: #2
Which version of the Wiki did you read? Only the vs 2003 is quite up-to-date.
http://wiki.xbmc.org/?title=HOW-TO_compi..._Edition_2
Try a recent svn checkout. The linux version of the libsmb client was updated which broke the win32 build. Chadoe fixed it today by using the old lib.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
djdafreund Offline
Skilled Skinner
Posts: 562
Joined: Dec 2005
Reputation: 0
Location: Atlanta
Post: #3
I built it a few times today, using VS 2003, using fresh checkout's each time (lot's of changes today too.) I'm not sure what the error's are though. And just tried building again 20 minutes ago, still error's. I don't mean to be a burden, but i really would like to figure this out so i can start help releasing regular builds for people if i can.
I am using x64, but it was working fine for me before now, up until a few days ago. I double checked the wiki link, but it's the same thing i did already, but it's still giving me an error.

Edit- It's working again. That's cool. I saw earlier when posted
"2008-03-16 12139 fixed: broke Win32 with my last update." and thought that meant it was fixed. But just noticed "[SIZE=2]
2008-03-16 12156 fixed: compile issues on win32" when i got home, and just now compiled it again with no error's. So
now that i got it working, i would like to start compiling up packages and upload it for others to grab if that's acceptable by the XBMC guidelines, and as long as I label it 'Unofficial and Unsupported" until they release an official release when they consider it at that point.
[/SIZE]
(This post was last modified: 2008-03-17 02:29 by djdafreund.)
find quote
CrazyIvan Offline
Senior Member
Posts: 159
Joined: Dec 2004
Reputation: 0
Post: #4
djdafreund Wrote:So now that i got it working, i would like to start compiling up packages and upload it for others to grab if that's acceptable by the XBMC guidelines, and as long as I label it 'Unofficial and Unsupported" until they release an official release when they consider it at that point.

Wonderful!

cheers,

crazyivan
find quote
DanSh0 Offline
Junior Member
Posts: 12
Joined: Mar 2008
Reputation: 0
Post: #5
djdafreund Wrote:now that i got it working, i would like to start compiling up packages and upload it for others to grab if that's acceptable by the XBMC guidelines, and as long as I label it 'Unofficial and Unsupported" until they release an official release when they consider it at that point.
[/SIZE][/SIZE]

That would be much appreciated. I'm currently stuck trying out T3ch releases with the xbmc.exe's that Wiso has been kind enough to share but would love to run the supported SDL\OpenGL release instead.

As this project does not use any xdk stuff to compile, I'm assuming that there are no legal reasons for not providing a compiled release? (Is this correct?)
find quote
djdafreund Offline
Skilled Skinner
Posts: 562
Joined: Dec 2005
Reputation: 0
Location: Atlanta
Post: #6
Well, it seems broken again. Getting an error each time after today. Using new checkout each time too.

"2008-03-17 12168 fixed: We were still including the system libsmbclient.h instead of the one in xbmc/lib/libsmb. I hope this doesn't break win32"

Looks like it did break win32 builds then. I was just about to make a daily build today for all too.

Getting 2 error's now.
================
D:\XBMC SDL\xbmc\FileSystem\CMythSession.cpp(91): error C2039: 'proginfo_subtitle' : is not a member of 'DllLibCMyth'
D:\XBMC SDL\xbmc\utils\CharsetConverter.cpp(17): error C2664: 'libiconv' : cannot convert parameter 2 from 'char ** ' to 'const char ** '
(This post was last modified: 2008-03-18 05:53 by djdafreund.)
find quote
WiSo Offline
Team-XBMC Developer
Posts: 2,695
Joined: Oct 2003
Reputation: 0
Location: Germany
Post: #7
DanSh0 Wrote:I'm currently stuck trying out T3ch releases with the xbmc.exe's that Wiso has been kind enough to share but would love to run the supported SDL\OpenGL release instead.
The one I provided is the sdl/opengl version.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
WiSo Offline
Team-XBMC Developer
Posts: 2,695
Joined: Oct 2003
Reputation: 0
Location: Germany
Post: #8
djdafreund Wrote:Getting 2 error's now.
================
D:\XBMC SDL\xbmc\FileSystem\CMythSession.cpp(91): error C2039: 'proginfo_subtitle' : is not a member of 'DllLibCMyth'
D:\XBMC SDL\xbmc\utils\CharsetConverter.cpp(17): error C2664: 'libiconv' : cannot convert parameter 2 from 'char ** ' to 'const char ** '

You should have a look in the svn log to see which changes may have break it.
Try to remove the (char**) in line 17 of CharsetConverter.cpp and comment line 91.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
djdafreund Offline
Skilled Skinner
Posts: 562
Joined: Dec 2005
Reputation: 0
Location: Atlanta
Post: #9
I'll give that a shot and post results. Too tired now though. Time for some sleep finally.
find quote
djdafreund Offline
Skilled Skinner
Posts: 562
Joined: Dec 2005
Reputation: 0
Location: Atlanta
Post: #10
Got fixed again today. Just checked, and it's building fine. So happy.
find quote