Are radio buttons working correctly?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
billcow Offline
Junior Member
Posts: 9
Joined: Oct 2003
Reputation: 0
Post: #1
small bit of odd behavior: radio buttons seem to use the main texture for both the button itself *and* the "blip", and ignoring entirely the image referenced in the "textureradiofocus" and "textureradionofocus" tags. am i missing something, or is this an actual bug?

it's a bit annoying, since the image i'm using for the buttons blends in with itself - at such a small scaling the borders disappear. so if it is intended i'd like to know a way to work around it other than re-designing the interface.

if anyone is interested, the skin i'm working on is supposed to look like the blackbox style "charcoal", which comes with bb4win (windows port of blackbox). it's rather close, aside from the fact that it's signifigantly brighter once on a tv. i have the buttons and such done (minus some quirks). so now i have to work on all the icons - the part that takes the most skill.
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,228
Joined: Oct 2003
Reputation: 177
Post: #2
from a quick look at the code, it appears to be a bug.

it's on my todo list.

edit: actually, at a closer look, it may not be a bug - will investigate either way.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,228
Joined: Oct 2003
Reputation: 177
Post: #3
a further look has revealed the bug:

in guilib/guiradiobuttoncontrol.cpp, in the constructor, the strings passed to the constructors of m_imgradiofocus and m_imgradionofocus should be strradiofocus and strradionofocus respectively.

i'll check to make sure of this tonight (i'm on a linux machine with no xbox available at the moment), and update cvs as necessary.

thanks for finding this bug - hopefully your skinning can continue now!

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote