cant find IRSSmap file

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
TrocaNiklas Offline
Junior Member
Posts: 46
Joined: May 2008
Reputation: -10
Post: #1
Hi i read a Guide on getting the MCE remote to work in xbmc i installer some ir suite and did everything in the guide. last the guide tells me to edit the IRSSmap in my documents folder app data xbmc. i find the folder but in there there is no IRSSmap.xml file and i did a search on my comp for it cant find it and iam sure i have the latestbuild of XBMC just reinstalled it aswell its the one in the sticky post on the forum

pls help
find quote
Bedpan Offline
Junior Member
Posts: 43
Joined: Nov 2007
Reputation: 0
Post: #2
Make sure you are running the latest SVN. IR Server Support I believe was not added until a recent build (139** or the likes). 14125 has it for sure.. File will be in two places.
1. C:\Program Files\XBMC
2. C:\Documents and Settings\USER NAME\Application Data\XBMC\UserData

It will use one or the other depending on how XBMC is started. If the -p flag is used, then it uses 2, without the -p flag it uses 1. Thats the way I understand it anyways. Personally I just update both with my changes.
find quote
TrocaNiklas Offline
Junior Member
Posts: 46
Joined: May 2008
Reputation: -10
Post: #3
well i did a reinstall of windows today aswell installed everything from scratch and i installed xbmc rev14125 but i dont have the IRSSmap.xml in any of the two locations. Dont know whats wrong
find quote
kraqh3d Offline
Retired Developer
Posts: 7,172
Joined: Dec 2003
Reputation: 4
Location: New York City, USA
Post: #4
That's not quite accurate.

First, Xbmc looks for a "default" one in the system folder. (Though that might not be in 14125 yet.)

Then it looks for one in the UserData location which can be Xbmc\Userdata\ or Xbmc\Userdata\<User>\ or Documents and Settings\<User>\Application Data\Xbmc\UserData\, depending on how you invoke Xbmc.

If you don't have the file, don't worry. You can get it from svn. (hmm seems the svn browser is down at the moment.)

It's back up now. Not sure if it was SF or my computer... Here's the link.
http://xbmc.svn.sourceforge.net/viewvc/x...RSSmap.xml

(and 14125 definitely has support of the default version from the system folder.)

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
(This post was last modified: 2008-07-18 19:38 by kraqh3d.)
find quote
TrocaNiklas Offline
Junior Member
Posts: 46
Joined: May 2008
Reputation: -10
Post: #5
Iam going Crazy on this remote thing atm.

1 i have a sony vaio Media center VGX XL202
that has a built in IR reciver and comes with a MCE remote.

2. I have downloaded IR Server Suite - 1.0.4.1 installed it and ran Input Service Configuration it detected that i had a mce reciver and mce sender i clicked ok the program told me it needed to restart i clicked ok done (is there anything more i need to do ?)

3. I opend C:\program files\xbmc\system\IRSSmap.xml edited it according to a post i found here.

4. my xbmc map in my documents are actualy located in C:\User\<username>\AppData (that is a hiden directory)\Roaming\Xbmc\UserData\ in there i have Rssfeeds.xml Userinterface etc But no file named IRSSmap.xml so i copied the one from C:\Program files\xbmc\system\

(iam running windows vista ultimate service pack1 32bit)

And it still dosent freaking work !!!!! iam going crazy someone plz help.
find quote
Bedpan Offline
Junior Member
Posts: 43
Joined: Nov 2007
Reputation: 0
Post: #6
Run the IR Server Suite Debugger to confirm that IR Server Suite is getting the IR Codes. If it is then just make sure you have the IRSSmap.xml and it is located in the right place. If you cannot decipher Kraqh3d's post just update them all. That should be all you need. The default IRSSmap.xml file I believe has all the appropriate codes for MCE remote already included. The updates to the XML that I have seen are if you want to use the orginal XBox remote (or other remotes for that matter).

Again I am just some schmuck who guesses a lot on how this works. But this is how I understand it.

Mike

TrocaNiklas Wrote:Iam going Crazy on this remote thing atm.

1 i have a sony vaio Media center VGX XL202
that has a built in IR reciver and comes with a MCE remote.

2. I have downloaded IR Server Suite - 1.0.4.1 installed it and ran Input Service Configuration it detected that i had a mce reciver and mce sender i clicked ok the program told me it needed to restart i clicked ok done (is there anything more i need to do ?)

3. I opend C:\program files\xbmc\system\IRSSmap.xml edited it according to a post i found here.

4. my xbmc map in my documents are actualy located in C:\User\<username>\AppData (that is a hiden directory)\Roaming\Xbmc\UserData\ in there i have Rssfeeds.xml Userinterface etc But no file named IRSSmap.xml so i copied the one from C:\Program files\xbmc\system\

(iam running windows vista ultimate service pack1 32bit)

And it still dosent freaking work !!!!! iam going crazy someone plz help.
find quote
chadoe Offline
Team-XBMC Developer
Posts: 627
Joined: Nov 2003
Reputation: 0
Location: Home
Post: #7
Goto settings - system, enable debug logging, press some buttons on your remote, open xbmc.log in the installation folder and search for any lines containing "IRServerSuite".

IRSSmap.xml from xbmc\system is used by default, if there's a IRSSmap.xml in your userdata folder that one will be used instead.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
(This post was last modified: 2008-07-18 21:13 by chadoe.)
find quote
kraqh3d Offline
Retired Developer
Posts: 7,172
Joined: Dec 2003
Reputation: 4
Location: New York City, USA
Post: #8
try using the 1.0.4.2 release candidate. i'm using it with an x10 lola remote.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
TrocaNiklas Offline
Junior Member
Posts: 46
Joined: May 2008
Reputation: -10
Post: #9
cant find no debugger rogram to run in ir server suite
find quote
TrocaNiklas Offline
Junior Member
Posts: 46
Joined: May 2008
Reputation: -10
Post: #10
from xbmc debug logfile

:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23529
20:37:56 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23529
20:37:57 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23529
20:37:57 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23529
20:37:58 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23527
20:37:58 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23527
20:37:58 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23520
20:37:58 T:760 M:2147483647 DEBUG: CApplication::OnKey: 61480 pressed, action is 4
20:37:59 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23521
20:37:59 T:760 M:2147483647 DEBUG: CApplication::OnKey: 61478 pressed, action is 3
20:38:00 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23521
20:38:00 T:760 M:2147483647 DEBUG: CApplication::OnKey: 61478 pressed, action is 3
20:38:00 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23521
20:38:00 T:760 M:2147483647 DEBUG: CApplication::OnKey: 61478 pressed, action is 3
20:38:00 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23521
20:38:00 T:760 M:2147483647 DEBUG: CApplication::OnKey: 61478 pressed, action is 3
20:38:01 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23521
20:38:01 T:760 M:2147483647 DEBUG: CApplication::OnKey: 61478 pressed, action is 3
20:38:01 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23517
20:38:01 T:760 M:2147483647 DEBUG: CApplication::OnKey: 61453 pressed, action is 7
20:38:01 T:760 M:2147483647 DEBUG: CApplication::OnMessage : Translating ActivateWindow(MyVideos)
20:38:01 T:760 M:2147483647 DEBUG: CApplication::OnMessage : To ActivateWindow(MyVideos)
20:38:01 T:760 M:2147483647 DEBUG: Activating window ID: 10024
20:38:01 T:760 M:2147483647 DEBUG: Checking if window ID 10024 is locked.
20:38:02 T:760 M:2147483647 INFO: Attempting to default to:
20:38:02 T:760 M:2147483647 INFO: Loading skin file: MyVideo.xml
20:38:02 T:760 M:2147483647 DEBUG: Load MyVideo.xml: 25.16ms (1.13 ms xml load)
20:38:02 T:760 M:2147483647 DEBUG: Alloc resources: 125.64ms (25.81 ms skin load, 0.44 ms preload)
20:38:02 T:760 M:2147483647 DEBUG: CGUIMediaWindow::GetDirectory ()
20:38:02 T:760 M:2147483647 DEBUG: ParentPath = []
20:38:02 T:760 M:2147483647 DEBUG: CFileItemList::Sort, sorting took 0 millis
20:38:02 T:2796 M:2147483647 DEBUG: thread start, auto delete: 0
20:38:02 T:2796 M:2147483647 DEBUG: CThread::staticThread, deleting thread graphic context
20:38:02 T:2796 M:2147483647 DEBUG: Thread 2796 terminating
20:38:03 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23520
20:38:03 T:760 M:2147483647 DEBUG: CApplication::OnKey: 61480 pressed, action is 4
20:38:03 T:760 M:2147483647 INFO: IRServerSuite, RemoteEvent: Microsoft MCE 23517
20:38:03 T:760 M:2147483647 DEBUG: CApplication::OnKey: 61453 pressed, action is 7
20:38:03 T:760 M:2147483647 DEBUG: Clearing cached fileitems [smb://192.168.1.1/]
20:38:03 T:760 M:2147483647 DEBUG: CGUIMediaWindow::GetDirectory (smb://192.168.1.1/)
20:38:03 T:760 M:2147483647 DEBUG: ParentPath = []
20:38:03 T:760 M:2147483647 DEBUG: DIRECTORY::C
find quote
kraqh3d Offline
Retired Developer
Posts: 7,172
Joined: Dec 2003
Reputation: 4
Location: New York City, USA
Post: #11
Xbmc is reporting events from IR Server Suite. What exactly is your problem?

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
TrocaNiklas Offline
Junior Member
Posts: 46
Joined: May 2008
Reputation: -10
Post: #12
hehe thanks to the xbmc log i can press some button in order then chck the log what nummer those buttons i pressed register as and then put that in IRSSmap.xml and it actualy works Smile thanks alot guys is there any easyway to c what nummbers my buttons register as ? without having to open and close xbmc and check logg everytime ?
find quote
TrocaNiklas Offline
Junior Member
Posts: 46
Joined: May 2008
Reputation: -10
Post: #13
well my problem is that i was to stupid to know how to check if it recives my commands and to figure out what was wrong but thanks to you guys i should be ok now i will post a pic of my remote and the codes for the buttons here when iam done
find quote
kraqh3d Offline
Retired Developer
Posts: 7,172
Joined: Dec 2003
Reputation: 4
Location: New York City, USA
Post: #14
im using the 1.0.4.2 release candidate version, and it included a test application that displayed the button presses. from there I built an IRSSmap.xml file to support the x10 Lola remote. the IRSSmap.xml file maps those button presses (in your case they are represented as 5-digit numbers) to button-names that Xbmc understands.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Bedpan Offline
Junior Member
Posts: 43
Joined: Nov 2007
Reputation: 0
Post: #15
As Kraqh3d says, under the latest version of IR Server Suite (not sure if it is in earlier ones) there is a debugger tool in the start menu icons. Start it up, click connect and press buttons and see the results
find quote
Post Reply