Problem compiling XBMC from SVN

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
rasmusth Offline
Junior Member
Posts: 12
Joined: Mar 2008
Reputation: 0
Post: #1
I followed the steps in the HOW-TO on the wiki. When I compile I run into a problem with missing files from the dvdplayer directory.

the error is as follows: http://pastebin.com/m633e1d19

Hope somebody has the patience to help me.

/Rasmus
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #2
First line on the wiki;
Quote:This is only a copy and paste from the README.osx just to get this article started Please refer to the SVN version to be sure you got the latest edition!

See http://xbmc.svn.sourceforge.net/viewvc/x...README.osx, the wiki is stale.



Build "configure", "python", Build "libraries", Build "XBMCHelper", then Build "XBMC".


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
rasmusth Offline
Junior Member
Posts: 12
Joined: Mar 2008
Reputation: 0
Post: #3
Thanks davilla. I made it work.

Keep up the brilliant work!

/Rasmus
find quote
jonm42 Offline
Senior Member
Posts: 177
Joined: Feb 2009
Reputation: 0
Location: Portland, OR
Post: #4
I've tried everything I can think of, but I can't make this work on my iMac; running 10.5.6, MacPorts 1.7, not configured to be 10.4 compatible (primarily because there was no straightforward way to figure out what port items needed to be tweaked to be universal), and debug.

Some logging, debug and transcripts follow. I'd really appreciate some help. Thanks. Running SVN_REV="17715M"'.

Doing this:

cd xbmc/XBMC/
make clean
make python
make externals more_libs
make xbmc
export XBMC_HOME=$HOME/XBMC
./xbmc.bin


gives this console output:

sh: XBMC.app/Contents/Resources/XBMC/tools/preflight: No such file or directory
++ WARN: could not retrieve file info for `image.nrg': No such file or directory
++ WARN: can't open nrg image file image.nrg for reading
++ WARN: could not retrieve file info for `image.nrg': No such file or directory
++ WARN: can't open nrg image file image.nrg for reading
++ WARN: could not retrieve file info for `image.nrg': No such file or directory
++ WARN: can't open nrg image file image.nrg for reading
Asking helper to start.
QZ_SetVideoWindowed(1280, 720)
sh: /Users/jonathan/XBMC/XBMCHelper: No such file or directory
Using display 69671552
Fatal error encountered, aborting
Error log at /Users/jonathan/Library/Logs/xbmc.log
Abort trap


And here's the ~/Library/Logs/xbmc.log content:

19:22:28 T:2689103648 M:712466432 NOTICE: -----------------------------------------------------------------------
19:22:28 T:2689103648 M:712458240 NOTICE: Starting XBMC, Platform: Mac OS X. Built on Feb 14 2009
19:22:28 T:2689103648 M:712458240 NOTICE: special://xbmc/ is mapped to: /Users/jonathan/XBMC
19:22:28 T:2689103648 M:712458240 NOTICE: special://masterprofile/ is mapped to: /Users/jonathan/Library/Application Support/XBMC/userdata
19:22:28 T:2689103648 M:712458240 NOTICE: special://home/ is mapped to: /Users/jonathan/Library/Application Support/XBMC
19:22:28 T:2689103648 M:712458240 NOTICE: special://temp/ is mapped to: /tmp/xbmc
19:22:28 T:2689103648 M:712458240 NOTICE: The executable running is: /Users/jonathan/xbmc/XBMC/xbmc.bin
19:22:28 T:2689103648 M:712458240 NOTICE: Log File is located: /Users/jonathan/Library/Logs/xbmc.log
19:22:28 T:2689103648 M:712458240 NOTICE: -----------------------------------------------------------------------
19:22:28 T:2689103648 M:712445952 NOTICE: Setup SDL
19:22:29 T:2689103648 M:711888896 INFO: Available videomodes:
19:22:29 T:2689103648 M:711888896 INFO: Found mode: 1680x1050
19:22:29 T:2689103648 M:711888896 INFO: Found mode: 1344x840
19:22:29 T:2689103648 M:711888896 INFO: Found mode: 1280x800
19:22:29 T:2689103648 M:711888896 INFO: Found mode: 1024x768
19:22:29 T:2689103648 M:711888896 INFO: Found mode: 1024x640
19:22:29 T:2689103648 M:711888896 INFO: Found mode: 800x600
19:22:29 T:2689103648 M:711888896 INFO: Found mode: 840x524
19:22:29 T:2689103648 M:711888896 INFO: Found mode: 800x500
19:22:29 T:2689103648 M:711868416 INFO: Drives are mapped
19:22:29 T:2689103648 M:711868416 NOTICE: load settings...
19:22:29 T:2689103648 M:711864320 NOTICE: special://profile/ is mapped to: special:\\masterprofile\
19:22:29 T:2689103648 M:711864320 NOTICE: loading special://masterprofile/guisettings.xml
19:22:29 T:2689103648 M:711839744 NOTICE: Getting hardware information now...
19:22:29 T:2689103648 M:711839744 INFO: Using analog output
19:22:29 T:2689103648 M:711839744 INFO: AC3 pass through is enabled
19:22:29 T:2689103648 M:711839744 INFO: DTS pass through is enabled
19:22:29 T:2689103648 M:711839744 NOTICE: Checking resolution 10
19:22:29 T:2689103648 M:711839744 NOTICE: Setting autoresolution mode 1
19:22:29 T:2689103648 M:711831552 NOTICE: No advancedsettings.xml to load (special://masterprofile/advancedsettings.xml)
19:22:29 T:2689103648 M:711823360 NOTICE: Default Video Player: dvdplayer
19:22:29 T:2689103648 M:711806976 NOTICE: Default Audio Player: paplayer
19:22:29 T:2689103648 M:711819264 NOTICE: special://masterprofile/sources.xml
19:22:29 T:2689103648 M:711491584 DEBUG: Constructing surface 1280x720, shared=0x0, fullscreen=0
19:22:29 T:2689103648 M:706428928 NOTICE: GL_VENDOR = ATI Technologies Inc.
19:22:29 T:2689103648 M:706428928 NOTICE: GL_RENDERER = ATI Radeon HD 2600 PRO OpenGL Engine
19:22:29 T:2689103648 M:706428928 NOTICE: GL_VERSION = 2.0 ATI-1.5.36
19:22:29 T:2689103648 M:706428928 NOTICE: GL_EXTENSIONS = GL_ARB_transpose_matrix GL_ARB_vertex_program GL_ARB_vertex_blend GL_ARB_window_pos GL_ARB_shader_objects GL_ARB_vertex_shader GL_ARB_shading_language_100 GL_EXT_multi_draw_arrays GL_EXT_clip_volume_hint GL_EXT_rescale_normal GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_gpu_program_parameters GL_EXT_geometry_shader4 GL_EXT_transform_feedback GL_APPLE_client_storage GL_APPLE_specular_vector GL_APPLE_transform_hint GL_APPLE_packed_pixels GL_APPLE_fence GL_APPLE_vertex_array_object GL_APPLE_vertex_program_evaluators GL_APPLE_element_array GL_APPLE_flush_render GL_APPLE_aux_depth_stencil GL_NV_texgen_reflection GL_NV_light_max_exponent GL_IBM_rasterpos_clip GL_SGIS_generate_mipmap GL_ARB_imaging GL_ARB_point_parameters GL_ARB_texture_env_crossbar GL_ARB_texture_border_clamp GL_ARB_multitexture GL_ARB_texture_env_add GL_ARB_texture_cube_map GL_ARB_texture_env_dot3 GL_ARB_multisample GL_ARB_texture_env_combine GL_ARB_texture_compression GL_ARB_texture_mirrored_repeat GL_ARB_shadow GL_ARB_depth_texture GL_ARB_shadow_ambient GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_occlusion_query GL_ARB_point_sprite GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ARB_pixel_buffer_object GL_ARB_draw_buffers GL_ARB_shader_texture_lod GL_EXT_compiled_vertex_array GL_EXT_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_texture_rectangle GL_ARB_texture_rectangle GL_EXT_texture_env_add GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_texture_lod_bias GL_EXT_abgr GL_EXT_bgra GL_EXT_stencil_wrap GL_EXT_texture_filter_anisotropic GL_EXT_separate_specular_color GL_EXT_secondary_color GL_EXT_blend_func_separate GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_texture_compression_s3tc GL_EXT_texture_compression_dxt1 GL_EXT_texture_sRGB GL_EXT_blend_equation_separate GL_EXT_texture_mirror_clamp GL_EXT_packed_depth_stencil GL_EXT_draw_buffers2 GL_APPLE_flush_buffer_range GL_APPLE_ycbcr_422 GL_APPLE_vertex_array_range GL_APPLE_texture_range GL_APPLE_float_pixels GL_ATI_texture_float GL_ARB_texture_float GL_ARB_half_float_pixel GL_APPLE_pixel_buffer GL_APPLE_object_purgeable GL_NV_blend_square GL_NV_fog_distance GL_ATI_texture_mirror_once GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_texture_env_combine3 GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SGI_color_matrix
19:22:29 T:2689103648 M:706547712 INFO: GL: Maximum texture width: 4096
19:22:29 T:2689103648 M:706539520 INFO: load language info file: special://xbmc/language/English/langinfo.xml
19:22:29 T:2689103648 M:706535424 ERROR: unable to load special://xbmc/language/English/langinfo.xml: Failed to open file at line 0
19:22:29 T:2689103648 M:706400256 DEBUG: SECTION:LoadDLL(special://xbmc/system/ImageLib-osx.so)
19:22:29 T:2689103648 M:706396160 DEBUG: Loading: /Users/jonathan/XBMC/system/ImageLib-osx.so
19:22:29 T:2689103648 M:706396160 ERROR: Unable to load /Users/jonathan/XBMC/system/ImageLib-osx.so, reason: dlopen(/Users/jonathan/XBMC/system/ImageLib-osx.so, 1): image not found
19:22:29 T:2689103648 M:706396160 ERROR: Texture manager unable to load file: special://xbmc/media/splash.png
19:22:29 T:2689103648 M:706093056 INFO: load language file:special://xbmc/language/English/strings.xml
19:22:29 T:2689103648 M:706084864 DEBUG: unable to load special://xbmc/language/English/strings.xml: Failed to open file at line 0
19:22:29 T:2689103648 M:706084864 WARNING: Emergency recovery console starting...


And when I try building via XCode command line using make commands through "make externals more_libs" and using XCode:

sixByNine:XBMC jonathan$ xcodebuild -configuration Debug -target "XBMC.app" -project XBMC.xcodeproj
=== BUILDING NATIVE TARGET XBMC OF PROJECT XBMC WITH CONFIGURATION Debug ===

Checking Dependencies...
.
.
.


and it gets to
.
.
.
make -C ../Python
case $MAKEFLAGS in \
*-s*) CC='gcc' LDSHARED='gcc -bundle -undefined dynamic_lookup' OPT='-DNDEBUG -Wno-deprecated-declarations' ./python.exe -E ./setup.py -q build;; \
*) CC='gcc' LDSHARED='gcc -bundle -undefined dynamic_lookup' OPT='-DNDEBUG -Wno-deprecated-declarations' ./python.exe -E ./setup.py build;; \
esac
running build
running build_ext
^C** BUILD INTERRUPTED **
sixByNine:XBMC jonathan$


and then hangs. Overnight.

If you read this far, thank you.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #5
jonm42 Wrote:I've tried everything I can think of, but I can't make this work on my iMac; running 10.5.6, MacPorts 1.7, not configured to be 10.4 compatible (primarily because there was no straightforward way to figure out what port items needed to be tweaked to be universal), and debug.

Some logging, debug and transcripts follow. I'd really appreciate some help. Thanks. Running SVN_REV="17715M"'.

Doing this:

cd xbmc/XBMC/
make clean
make python
make externals more_libs
make xbmc
export XBMC_HOME=$HOME/XBMC
./xbmc.bin


gives this console output:


Quote:Unable to load /Users/jonathan/XBMC/system/ImageLib-osx.so

XBMC_HOME is not set correctly. "$HOME/XBMC" sets it to "/Users/jonathan/XBMC" and I suspect that is NOT where it's located.

try

Quote:export XBMC_HOME=`pwd`


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
jonm42 Offline
Senior Member
Posts: 177
Joined: Feb 2009
Reputation: 0
Location: Portland, OR
Post: #6
Much much better! Thanks. Do I need to worry about the following?

sixByNine:XBMC jonathan$ ./xbmc.bin
sh: XBMC.app/Contents/Resources/XBMC/tools/preflight: No such file or directory
++ WARN: could not retrieve file info for `image.nrg': No such file or directory
++ WARN: can't open nrg image file image.nrg for reading
++ WARN: could not retrieve file info for `image.nrg': No such file or directory
++ WARN: can't open nrg image file image.nrg for reading
++ WARN: could not retrieve file info for `image.nrg': No such file or directory
++ WARN: can't open nrg image file image.nrg for reading
Asking helper to start.
QZ_SetVideoWindowed(1280, 720)
Using display 69671552
XBOX360: Registering for notifications.
Using key code for OSX 10.5
++ WARN: could not retrieve file info for `image.nrg': No such file or directory
++ WARN: can't open nrg image file image.nrg for reading
++ WARN: could not retrieve file info for `image.nrg': No such file or directory
++ WARN: can't open nrg image file image.nrg for reading
++ WARN: could not retrieve file info for `image.nrg': No such file or directory
++ WARN: can't open nrg image file image.nrg for reading
++ WARN: could not retrieve file info for `image.nrg': No such file or directory
++ WARN: can't open nrg image file image.nrg for reading
++ WARN: could not retrieve file info for `image.nrg': No such file or directory
++ WARN: can't open nrg image file image.nrg for reading


Note that I cannot find a means of building xbmc.app; searched through all the Make* files and there is no mention of it.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #7
Quote:WARN: could not retrieve file info for `image.nrg': No such file or directory

is a side effect from libcdio, you can ignore it.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #8
Quote:make xbmc.app

is not implemented yet. Ignore that too. Use Xcode to build xbmc.app


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
jonm42 Offline
Senior Member
Posts: 177
Joined: Feb 2009
Reputation: 0
Location: Portland, OR
Post: #9
davilla Wrote:is not implemented yet. Ignore that too. Use Xcode to build xbmc.app

When I do that, I get 4 compile errors (edited for brevity):

Compiling .../xbmc/FileSystem/FileFactory.cpp
error: redefinition of 'struct statfs'

and the same for FileRar.cpp, RarManager.cpp and linux/XFileUtils.cpp.

All of them are complaining about the system include mount.h.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #10
jonm42 Wrote:When I do that, I get 4 compile errors (edited for brevity):

Compiling .../xbmc/FileSystem/FileFactory.cpp
error: redefinition of 'struct statfs'

and the same for FileRar.cpp, RarManager.cpp and linux/XFileUtils.cpp.

All of them are complaining about the system include mount.h.

Xcode version? and which svn version?


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
jonm42 Offline
Senior Member
Posts: 177
Joined: Feb 2009
Reputation: 0
Location: Portland, OR
Post: #11
Xcode 3.1.2
IDE 1149.0
Core 1148.0
ToolSupport 1102.0
SVN_REV="17715M"'.

And I have the iPhone 2.2.1 SDK installed as well.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #12
jonm42 Wrote:Xcode 3.1.2
IDE 1149.0
Core 1148.0
ToolSupport 1102.0
SVN_REV="17715M"'.

And I have the iPhone 2.2.1 SDK installed as well.

Quote:error: redefinition of 'struct statfs'

was fixed a long time ago. check xbmc/linux/PlatformDefs.h

http://trac.xbmc.org/ticket/5626

When you build under Xcode, exactly how are you doing it?


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
jonm42 Offline
Senior Member
Posts: 177
Joined: Feb 2009
Reputation: 0
Location: Portland, OR
Post: #13
Selecting the XBMC target, setting 10.5 and Debug, then clicking Build and Go.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #14
jonm42 Wrote:Selecting the XBMC target, setting 10.5 and Debug, then clicking Build and Go.

Try

Selecting the XBMC target, setting 10.4 and Debug, then clicking Build and Go.

10.5 target builds are unsupported at the current time.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
jonm42 Offline
Senior Member
Posts: 177
Joined: Feb 2009
Reputation: 0
Location: Portland, OR
Post: #15
Arg. Got to the point of a successful build (with lots of warnings), but get a "You can't open the application "XBMC" because it is not supported on this architecture. I'm going to drop off the forum for a bit and redo my port builds with the 10.4u sdk active and see what happens. Thanks so much for the help thus far, and I'll be back in a bit.
find quote
Post Reply