MythTV client (cmyth) crashes XBMC for Mac

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
t0ny Offline
Junior Member
Posts: 2
Joined: Sep 2008
Reputation: 0
Location: Caldwell, Idaho
Sad  MythTV client (cmyth) crashes XBMC for Mac
Post: #1
I've been trying to use mythtv with XBMC on my mac. I see the list of recordings but when I try to view one it freezes. I do this my adding this as a source "myth://tony:pass@192.168.1.101". This works on Linux but not mac.

Here is the log:
Quote:9/18/08 6:54:43 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)cmyth_conn_connect: asked for version 8, got version 40
9/18/08 6:54:43 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)cmyth_conn_connect: asked for version 40, got version 40
9/18/08 6:54:43 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)cmyth_proginfo_get_from_basename: didn't recieve OK as response
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] __cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:45 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 6:54:46 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)cmyth_conn_connect: asked for version 8, got version 40
9/18/08 6:54:46 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)cmyth_conn_connect: asked for version 40, got version 40
9/18/08 6:54:46 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)cmyth_conn_connect: asked for version 8, got version 40
9/18/08 6:54:46 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)cmyth_conn_connect: asked for version 8, got version 40
9/18/08 6:54:46 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)cmyth_conn_connect: asked for version 40, got version 40
9/18/08 6:54:46 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)cmyth_conn_connect: asked for version 40, got version 40
9/18/08 6:54:46 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)cmyth_conn_connect: asked for version 8, got version 40
9/18/08 6:54:46 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)cmyth_conn_connect: asked for version 40, got version 40
9/18/08 6:54:49 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)__cmyth_send_message: write() failed (38)
9/18/08 6:54:49 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)cmyth_file_read: cmyth_send_message() failed (-38)
9/18/08 6:54:49 PM [0x0-0x50050].com.teamxbmc.xbmc[1137] (cmyth)cmyth_conn_connect: asked for version 8, got version 40
9/18/08 6:55:49 PM com.apple.launchd[131] ([0x0-0x50050].com.teamxbmc.xbmc[1137]) Stray process with PGID equal to this dead job: PID 1139 PPID 1 XBMCHelper
9/18/08 6:55:49 PM com.apple.launchd[131] ([0x0-0x50050].com.teamxbmc.xbmc[1137]) Exited abnormally: Segmentation fault
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #2
New one on me, I've been testing mythtv access in the same way and have not had any problems. I see you are running version 40, same as me.

Any info you have about your backend might be helpful.

Also Mac info, 10.5 or 10.4.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
garion911 Offline
Junior Member
Posts: 5
Joined: Sep 2008
Reputation: 0
Post: #3
I've had the same issue since the early days of OSXBMC and Plex.. In my case, I add my Myth source, and the brwose to the recordings area.. I see it flash a list of my records, and then it crashes. I can get a more detailed log if you want.

Here's my log:

9/18/08 8:47:15 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] The XBMC_HOME environment variable is not set.
9/18/08 8:47:15 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] The XBMC_HOME environment variable is not set.
9/18/08 8:47:15 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] QZ_SetVideoWindowed(720, 480)
9/18/08 8:47:15 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] Using display 549837921
9/18/08 8:47:15 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] ++ WARN: search for kIOCDMediaClass/kIODVDMediaClass came up empty
9/18/08 8:47:26 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] Error loading jpeg - no SOI marker found in first 4096 bytes
9/18/08 8:47:26 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] Error loading jpeg - no SOI marker found in first 4096 bytes
9/18/08 8:48:03 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] Error loading jpeg - no SOI marker found in first 4096 bytes
9/18/08 8:48:03 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] Error loading jpeg - no SOI marker found in first 4096 bytes
9/18/08 8:48:05 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] (cmyth)cmyth_conn_connect: asked for version 8, got version 40
9/18/08 8:48:05 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] (cmyth)cmyth_conn_connect: asked for version 40, got version 40
9/18/08 8:48:05 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] (cmyth)cmyth_proginfo_get_from_basename: didn't recieve OK as response
9/18/08 8:48:06 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] (cmyth)__cmyth_rcv_proginfo: got recording info

<snip.. remove lots of recordings loading..>

(cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 8:48:06 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] (cmyth)__cmyth_rcv_proginfo: got recording info
9/18/08 8:48:07 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] (cmyth)cmyth_conn_connect: asked for version 8, got version 40
9/18/08 8:48:07 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] (cmyth)cmyth_conn_connect: asked for version 8, got version 40
9/18/08 8:48:07 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] (cmyth)cmyth_conn_connect: asked for version 40, got version 40
9/18/08 8:48:07 PM [0x0-0x4d04d].com.teamxbmc.xbmc[571] (cmyth)cmyth_conn_connect: asked for version 40, got version 40
9/18/08 8:48:43 PM com.apple.launchd[174] ([0x0-0x4d04d].com.teamxbmc.xbmc[571]) Exited abnormally: Segmentation fault
find quote
garion911 Offline
Junior Member
Posts: 5
Joined: Sep 2008
Reputation: 0
Post: #4
Oh yeah.. I'm OSX 10.5.5, my backend is gentoo, mythtv-0.21_p18116 (there's a newer version available I haven't installed yet..).. I do have a large number of recordings (at least I think so Smile ), 100+, if that makes a difference. I also have a mix of nuv + mpg files..
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #5
ok, second person with this problem. This will be fun to track down Wink I'm a mythtv fan and have a big mythtv backend setup. And have moved to XBMC for Mac to view recordings. But seems to work for me unfortunately. I'll make some changes and try on a few other boxes to try and reproduce the crash.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #6
It could be you both are seeing the aggressive nature of the OSX firewall under 10.5. This is ultimately solved by making XBMC for Mac signed but that did not make it into beta1 release.

Try this;

1) Go to the Apple menu, and choose System Preferences.
2) Click the Security icon (or choose View > Security).
3) Click the Firewall tab.

If the Allow all incoming connections button is selected, stop here. Your Mac OS X firewall is not enabled and that's not the problem.

4) Click the Set access for specific services and applications button.
5) Click the Add (+) button (beneath the large white rectangle).
6) A dialog to select an application appears. Find the XBMC application, and click Add.
The XBMC icon should now be listed in the Firewall preferences window, saying "Allow incoming connections."
7) Close the Firewall System Preferences window.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
garion911 Offline
Junior Member
Posts: 5
Joined: Sep 2008
Reputation: 0
Post: #7
Not the problem, allow all is checked.

I've tried this on two different systems (both MBP, OSX 10.5.5 and 10.5.4)..

Its been happening to me ever since the first support with Myth on OSXBMC and Plex..

From what I recall from the crash log, its occurring somewhere in the OSX display stuff.. Tonight I'll try it again, and post the crashreport...
find quote
garion911 Offline
Junior Member
Posts: 5
Joined: Sep 2008
Reputation: 0
Post: #8
I've posted a crash log here.

How i got that was to load XBMC, go to Videos, select my myth entry, Recordings... I briefly see my list of recording, and then it crashes.
find quote
garion911 Offline
Junior Member
Posts: 5
Joined: Sep 2008
Reputation: 0
Post: #9
Move info, some mild success...

While watching my mythbackend log while crashing XBMC, I notice it was dying on a PNG file... I move all my png's out of the way, and now I can watch recordings!

Can the other person with the problem try the same thing and see if it fixes them?
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,229
Joined: Oct 2003
Reputation: 177
Post: #10
Yes - it appears to be crashing in the background thumbloader. Can you reproduce it just by placing the PNG's back in there?

I'm wondering whether it's on all PNG's, or only on some of them?

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
spiderlane Offline
Member
Posts: 75
Joined: Mar 2008
Reputation: 0
Post: #11
Hi,

I'm experiencing exactly the same symptoms.

Would be more than happy to help debug if required.

Bit of info :

MBP running 10.5.5
Myth Protocol version 31

Here is the crashlog when attempting to view live channels

http://pastie.org/276603

If any more info would help then please let me know. Also I'll try to experiment with the PNGs and see if that helps.

Cheers
find quote
spiderlane Offline
Member
Posts: 75
Joined: Mar 2008
Reputation: 0
Post: #12
Bad form to reply to my own message I know (don't think there's an edit option?), but here's the debug log from the point of opening up the myth menu to the crash

http://pastie.org/276606
find quote
d4rk Offline
Team-XBMC Developer
Posts: 499
Joined: May 2007
Reputation: 1
Location: Albuquerque
Post: #13
Note to myself and other devs, the crash seems to be occurring here:
Code:
0xffffffff 0 + 4294967295
0x0063bc89 CArchive::operator<<(CStdStr<char> const&) + 233
0x007297c9 CVideoInfoTag::Serialize(CArchive&) + 137

Always read the XBMC online-manual, FAQ and search the forum before posting.
Please read and follow the forum rules.
For troubleshooting and bug reporting, please make sure you read this first.


[Image: badge.gif]
find quote
bob2009 Offline
Junior Member
Posts: 16
Joined: Sep 2008
Reputation: 0
Post: #14
Hi,

I think a have the same problem on my AppleTV 2.1. I have a Knoppmyth R5.5 backend (Mythtv 0.21).

Thanks
Bob
find quote
bob2009 Offline
Junior Member
Posts: 16
Joined: Sep 2008
Reputation: 0
Post: #15
Hi,

Can someone confirm the problem will be zapped on the next release of XBMC RC1. Any developpers working on this bad issue?

Thanks
Bob
find quote
Post Reply