[APPLE TV] HD Playback Suggestion

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Gibby Offline
Junior Member
Posts: 6
Joined: Jul 2005
Reputation: 0
Post: #1
Hello.

My first post in the ATV section. I just firstly wanted to thank Davilla for all of his support and quick responses as any question that I would have had about ATV installation of XBMC had already been answered by him!

I used the new ATV patchstick installation method and honestly, it really does not get any easier. If you have a problem, just read the forums...the answer is there. Everything even works as advertised (ha...as here on the forums that is) other than the HD content.

DivX content works excellent and I have tried all the way up to 480p with perfect playback. (Upscaling is a lil too much for the poor ATV to handle tho!)

Of course, I have little to no expectation for the ATV to handle 1080i/p content and therefore have not even wasted my time. What I am slightly troubled with is the fact that I cannot get any of my x.264 content to play that is 720p with bitrates as low as ~2000kbps. I have also tried several streams with an average of 4000kbps with similar results. (All play back fine on the PC with CoreAVC with a 1.4GHz Athlon processor...) I always get the same result where the video is slow in most occasions and the audio plays straight through with no issue (no choppy audio, but video is several seconds behind the audio and continues to get worse and worse). If there is any suggestion out there for better HD playback...really anything I can do on my end, please let me know!

If there is more information that I have not provided or if there is a particular HD stream you would like me to try and play, please let me know. This is really the main reason I would want XBMC on the ATV as I already have an Xbox1 which plays SD content near perfect.

Thanks for any help and suggestions you may have!

Gibby
find quote
d4rk Offline
Team-XBMC Developer
Posts: 499
Joined: May 2007
Reputation: 1
Location: Albuquerque
Post: #2
The XBMC for Mac Beta 1 build, which is what gets installed when you run the patchstick, is actually not very optimized for Apple TV (it's the same build used for Tiger and Leopard Macs). With Beta 2, which is a few days away, XBMC will be much better optimized specifically for Apple TV.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Please read and follow the forum rules.
For troubleshooting and bug reporting, please make sure you read this first.


[Image: badge.gif]
find quote
Gibby Offline
Junior Member
Posts: 6
Joined: Jul 2005
Reputation: 0
Post: #3
awesome, thanks for the quick feedback!
find quote
xeonicxpression Offline
Senior Member
Posts: 236
Joined: May 2008
Reputation: 0
Post: #4
Well that is great news! Do we just hit update on the appletv to get the new version, when it comes out?
find quote
Gibby Offline
Junior Member
Posts: 6
Joined: Jul 2005
Reputation: 0
Post: #5
I now have loaded Beta 2 onto the AppleTV and am having the exact same problems with the playback. I would be more than happy to provide a ~50mb sample of the 720p video and see what you think d4rk or davilla. The videos play just fine even on Beta1 on my Windows machine, but do not play on the ATV well at all (audio plays with no glitches, just continuous frame drops and lag in the video). I am not sure if this is directly related or not, but I have the same problem with video while trying to playback some DVD ISOs that I have. The audio plays great, just laggy/dropped video.

For simplicity's sake, I had started this thread before the other thread was opened (http://forum.xbmc.org/showthread.php?tid=38725) or http://forum.xbmc.org/showthread.php?tid=38569 but they seem to be experiencing the same problem. I have tried both locally and streaming with the same problems.

Thanks for the help!
(This post was last modified: 2008-10-10 00:43 by Gibby.)
find quote
crowl Offline
Junior Member
Posts: 6
Joined: Oct 2008
Reputation: 0
Post: #6
having the same problem.
find quote