Jittery Video?

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Andydigital Offline
Junior Member
Posts: 13
Joined: Sep 2008
Reputation: 0
Post: #16
I have a similar problem too but in the case of my Panasonic TH-42PX80B Plasma the only way to get the 100hz image smoothing to work is if the refresh rate is set to 50hz, if it gets 60hz from the PC then the 100hz is disabled and the picture tears really badly. Now I've set the PC to 50hz by forcing the Vsync in the ATI drivers I've cured the tearing but now i get the jitters in slow panning shots.
find quote
ashlar Offline
Donor
Posts: 2,110
Joined: Mar 2006
Reputation: 27
Post: #17
mdaria510 Wrote:well, from what I can tell that seems to be the root of the problem. Xbmc is htpc software, and therefore it's primary use will be on a tv. Virtually all tvs are locked at a 60hz refresh.
I have a plasma display, at 48Hz. Just tried Atlantis beta 2 with Planet Earth pans... terrible results. Unusable for me. It judders like crazy and, by looking at the infos (I) one can see that the framerate fluctuates wildly, even if no frames are dropped.

I suggest developers give a long look at Reclock.
find quote
mdaria510 Offline
Junior Member
Posts: 23
Joined: Oct 2008
Reputation: 0
Post: #18
Alright, I'm now 100% convinced this is an issue with refresh rates. I have the option to set my TV to a 24hz refresh rate in 1080p. Ran a few tests:

1) Playing a 24p source (720 planet earth .mkv) at a 24hz refresh rate eliminates the judder. There's one frame per refresh, and XBMC doesnt seem to have any issue syncing them.

However, leaving the HTPC on at 24hz is hardly practical, and I'd suspect that 99% of HTPC users don't have a TV that can run at anything but 60hz.

As soon as I switched the refresh rate back to 60hz, the jitter is back.

Next, I tried some 30fps (progressive) video - mostly videogame trailers. I was hoping that since 30hz is a multiple of 60hz, it would play back in sync. Didnt happen - same deal, microjitters, but no dropped frames. It did appear to be slightly better, able to lock the interpolation for a second or two here or there, but it still didnt play back right.

Tried all of the above videos, 24p/30p in media player classic, and they played back smooth as butter, and all locked perfectly to the interpolation due to the proper 2:2 and 3:2 cadences.

Tried all in 480p, 720p and 1080p to see if the video card was being choked - exact same behavior despite the resolution.

So as far as I can tell, unless the frame rate of the video is exactly the same as the refresh rate, the video does not play back at the proper rate. This may be only a windows specific problem - I have no way of telling otherwise, but there is definitely a major issue here.

This is still a beta, so bugs are expected, but I dont feel that it should be brought out of beta until this is taken care of. I'm not sure exactly how to help the devs reproduce the problem, but from seeing the responses in this thread, I'm clearly not the only one experiencing this.
find quote
mdaria510 Offline
Junior Member
Posts: 23
Joined: Oct 2008
Reputation: 0
Post: #19
ashlar Wrote:I have a plasma display, at 48Hz. Just tried Atlantis beta 2 with Planet Earth pans... terrible results. Unusable for me. It judders like crazy and, by looking at the infos (I) one can see that the framerate fluctuates wildly, even if no frames are dropped.

I suggest developers give a long look at Reclock.

Give it a try at 24hz (if you can), and see what happens.
find quote
harryzimm Offline
Posting Freak
Posts: 852
Joined: May 2008
Reputation: 6
Location: Auchtermuchty, Scotland
Post: #20
I use the linux port on my htpc but after reading this thread i tried the windows port. I can confirm the video on windows is considerably more juddier. I think this issue might effect the linux port aswell though because video smoothness has definatly suffered due to a recent change (pre beta1). I tried planet earth 720p on both platforms, panning is watchable on linux but not perfect. On windows its unwatchable.

Maybe im just noticing it more now im looking for it (linux) but i do think there is a problem. Just my 2.

cheers

HTPC 1 : Acer revo R3700 ion2 HTPC 2 :Apple TV2 HTPC 3 : Apple TV2 HTPC4 Acer revo R3700 ion2 Remote : x2 Riimote2
SERVER : 10TB Ubuntu Server 10.04, dual wintv nova hd s2 cards, tvheadend, Newcs, Omnikey reader, White *Sky uk* Card, Mysql Db, Sabnzbdplus, SickBeard, Couchpotato, FlexRaid. :cool:
--------------------------------------------
[Image: widget]
find quote
sensei73 Offline
Senior Member
Posts: 104
Joined: May 2008
Reputation: 0
Post: #21
Thanks for the tips, I set my TV to 24hz and it solved the problem of the clock perhaps when navigating the interface is not so smooth as It was in 60Hz.
find quote
harlekin Offline
Member
Posts: 66
Joined: Feb 2008
Reputation: 0
Post: #22
Just to state the point, this does not mean, that the problem is solved. It only confirms, that XBMC is failing to interpolate (multiply) frames correctly. Compared to other ffmpeg based players such as VLC on 60hz, XBMCs output is way more "jumpy" and susceptible to repeated slowdowns and speedups withing cycles.
find quote
ashlar Offline
Donor
Posts: 2,110
Joined: Mar 2006
Reputation: 27
Post: #23
mdaria510 Wrote:Give it a try at 24hz (if you can), and see what happens.
Yeah, I'm connected through VGA (analogue), so I have the 24Hz refresh rate setup as well. I usually don't use it because for all other uses (interfaces included) it's too slow. But I'll give it a try and report back.
find quote
eyelander Offline
Junior Member
Posts: 20
Joined: Mar 2007
Reputation: 0
Post: #24
mdaria510 Wrote:Alright, I'm now 100% convinced this is an issue with refresh rates. I have the option to set my TV to a 24hz refresh rate in 1080p. Ran a few tests:

1) Playing a 24p source (720 planet earth .mkv) at a 24hz refresh rate eliminates the judder. There's one frame per refresh, and XBMC doesnt seem to have any issue syncing them.

However, leaving the HTPC on at 24hz is hardly practical, and I'd suspect that 99% of HTPC users don't have a TV that can run at anything but 60hz.

As soon as I switched the refresh rate back to 60hz, the jitter is back.

Next, I tried some 30fps (progressive) video - mostly videogame trailers. I was hoping that since 30hz is a multiple of 60hz, it would play back in sync. Didnt happen - same deal, microjitters, but no dropped frames. It did appear to be slightly better, able to lock the interpolation for a second or two here or there, but it still didnt play back right.

Tried all of the above videos, 24p/30p in media player classic, and they played back smooth as butter, and all locked perfectly to the interpolation due to the proper 2:2 and 3:2 cadences.

Tried all in 480p, 720p and 1080p to see if the video card was being choked - exact same behavior despite the resolution.

So as far as I can tell, unless the frame rate of the video is exactly the same as the refresh rate, the video does not play back at the proper rate. This may be only a windows specific problem - I have no way of telling otherwise, but there is definitely a major issue here.

This is still a beta, so bugs are expected, but I dont feel that it should be brought out of beta until this is taken care of. I'm not sure exactly how to help the devs reproduce the problem, but from seeing the responses in this thread, I'm clearly not the only one experiencing this.



Yes that is the problem with XBMC!

Let hope for some proper 2:2 and 3:2 cadences!!!
find quote
tslayer Offline
Team-XBMC Developer
Posts: 3,557
Joined: Oct 2003
Reputation: 12
Post: #25
Maybe somebody can try this patch and see if it makes any difference:

It's for linux right now but I'm sure somebody can adapt it for windows as well.


http://trac.xbmc.org/ticket/4902

42.7% of all statistics are made up on the spot

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
mdaria510 Offline
Junior Member
Posts: 23
Joined: Oct 2008
Reputation: 0
Post: #26
tslayer Wrote:Maybe somebody can try this patch and see if it makes any difference:

It's for linux right now but I'm sure somebody can adapt it for windows as well.


http://trac.xbmc.org/ticket/4902

I'll be sure to give that a whirl when it's adapted for windows. Auto changing refresh rate is a neat option that should stay as a feature for those with variable refresh rates. But it's a bandaid and shouldn't be considered a fix...if this software is intended for use on tvs and not monitors, it needs to properly display at the 60hz most tvs are locked to. I know I'm beating that point into the ground, but when that happens, xbmc will have no equal...it will be the software of the gods. Really looking forward to it. Smile
find quote
mindweaver Offline
Posting Freak
Posts: 998
Joined: Jan 2004
Reputation: 1
Location: Sweden
Post: #27
I think you have narrowed down the problem. But I want to add myself to the list of people that are experiencing it.

Stutter on pans in XBMC (no framedrop, cpu around 20%). Works perfectly in MPC with FFDShow and CoreAVC.

I have noticed that the vq changes alot between 20-80%, should it do that?

Tried at both 60 and 50hz. Can't set my TV to 24 or 48 and don't think I should have to do that since other players handles it just fine in 50/60.

My setup:

AMD X2 6000+ (3.15Ghz)
2 GB DDR2
NVIDIA 8500 GT HDMI
WinXP SP2, XBMC Beta2, NVIDIA 178+ drivers.
(This post was last modified: 2008-10-08 20:57 by mindweaver.)
find quote
hubsi Offline
Junior Member
Posts: 3
Joined: Oct 2008
Reputation: 0
Post: #28
On my 100 Hertz Samsung F86, I'm experiencing jittering when I set my HTPC to 60 Hertz; no matter if I'm using XBMC or MediaPortal with the Cyberlink codec. When I set the HTPC to 24 Hertz everything is smooth. Unfortunately playback at 24 Hertz draws significantly more CPU power, that's why the audio is out of sync (just guessing). With Beta 2 however, the delay is constant so I was able to even it out by delaying the audio. I'm also having a couple of framedrops. In summary, I'm now able to watch 24Hertz material smooth and with synced audio Smile This is probably a result of the dual core support in Beta 2.

Maybe a quad core would remove the necessity of the manually added audio delay and the dropped frames. Any opinions on that?

My Setup:
AMD 64 x2 5200+
GeForce 8600GT
XP MCE 2005 SP2
Nvidia driver settings:
Threaded optimization: off
Multi display/mixed GPU acceleration: single display performance mode
Tripple buffering: on

The way I see it it's as follows: The source is running at 24 Hertz. The flat screen panel is running at e.g. 100 Hertz (or at 60 or 120 Hertz). So upscaling is definitely required. We have two options:
1) Let the software (codec) do the upscaling by setting your HTPC to 100 Hertz
2) Let the TV do the upscaling by setting your HTPC to 24 Hertz

I claim that you cannot change the refresh rate of your flatscreen. You can only change the resfresh rate of the input and if it doesn't match the panel's refresh rate the TV scales up. Correct me if I'm wrong.

If I'm right then using intermediate values between 24 Hertz and your panels refresh rate (like 60 Hertz in my case) is a bad idea because then upscaling is done twice. Once by the codec and once by the TV.

The question is: Who do you trust more to do the upscaling correctly?
Flatscreen TVs were built with bluray in mind, so they do the upscaling from 24 Hertz to whatever the panel refresh rate is pretty well.

So my conclusion is: Set the resresh rate of your HTPC to match the refresh rate of the source and let the TV worry about the rest.

I'd highly appreciate the possibility to switch the refresh rate within XBMC.
find quote
ashlar Offline
Donor
Posts: 2,110
Joined: Mar 2006
Reputation: 27
Post: #29
I tried at 24Hz (24.004 as reported by Reclock). Pans were smooth. At 48Hz (48.008 as reported by Reclock) the jitter is unbearable, even if no frames are lost.

In Zoom Player (a Direct Show based player), using Reclock, pans are smooth at both frequencies, as they should be.
find quote
mdaria510 Offline
Junior Member
Posts: 23
Joined: Oct 2008
Reputation: 0
Post: #30
hubsi Wrote:On my 100 Hertz Samsung F86, I'm experiencing jittering when I set my HTPC to 60 Hertz; no matter if I'm using XBMC or MediaPortal with the Cyberlink codec. When I set the HTPC to 24 Hertz everything is smooth. Unfortunately playback at 24 Hertz draws significantly more CPU power, that's why the audio is out of sync (just guessing). With Beta 2 however, the delay is constant so I was able to even it out by delaying the audio. I'm also having a couple of framedrops. In summary, I'm now able to watch 24Hertz material smooth and with synced audio Smile This is probably a result of the dual core support in Beta 2.

Maybe a quad core would remove the necessity of the manually added audio delay and the dropped frames. Any opinions on that?

My Setup:
AMD 64 x2 5200+
GeForce 8600GT
XP MCE 2005 SP2
Nvidia driver settings:
Threaded optimization: off
Multi display/mixed GPU acceleration: single display performance mode
Tripple buffering: on

The way I see it it's as follows: The source is running at 24 Hertz. The flat screen panel is running at e.g. 100 Hertz (or at 60 or 120 Hertz). So upscaling is definitely required. We have two options:
1) Let the software (codec) do the upscaling by setting your HTPC to 100 Hertz
2) Let the TV do the upscaling by setting your HTPC to 24 Hertz

I claim that you cannot change the refresh rate of your flatscreen. You can only change the resfresh rate of the input and if it doesn't match the panel's refresh rate the TV scales up. Correct me if I'm wrong.

If I'm right then using intermediate values between 24 Hertz and your panels refresh rate (like 60 Hertz in my case) is a bad idea because then upscaling is done twice. Once by the codec and once by the TV.

The question is: Who do you trust more to do the upscaling correctly?
Flatscreen TVs were built with bluray in mind, so they do the upscaling from 24 Hertz to whatever the panel refresh rate is pretty well.

So my conclusion is: Set the resresh rate of your HTPC to match the refresh rate of the source and let the TV worry about the rest.

I'd highly appreciate the possibility to switch the refresh rate within XBMC.

Well, you've got it a bit mixed up.

Refresh rate is the number of times a screen updates - thats between the video card/PC and the display.

Sources don't have refresh rates, they have frame rates.

Upscaling also isnt the right word to use - its not a matter of scaling, its a matter of timing.

It's the job of the software to make sure that the frame rate of the source is evenly timed to the refresh rate of the display.


Monitors have variable refresh rates - old CRTs are very flexible, LCDs not so much. They all 60hz, most also do 75hz, some do 70hz or 72hz. Some might be able to go lower, I've personally never used them.

TVs are an entirely different beast. The *vast* majority (all non-hd, all non-120hz HDs) of TVs are hard locked to 60hz.

The new 120hz TVs are a bit odd. They can display and accept either a standard 60hz TV signal/refresh rate or switch over to 24hz to directly display a 24fps blu-ray movie. They run internally at 120hz, but they can't accept a 120hz/fps signal.

120hz is a special number because its divisible by the common frame rates of video (24, 30, 60fps). So the first benefit is that they can display those frames perfectly evenly spaced. The second benefit is that 120hz leaves plenty of "extra frames" that allow for the opportunity of smoothing the frame rates on top of evenly spacing the "real frames".

Since the vast majority of content is going to come through 60hz signal, it needs to be able to determine what the frame rate of the actual content is by looking at the pattern of how the frames are spaced out in the signal. 30fps is easy (every other frame), 24fps a bit trickier but there a *very* standard way to do this which has been in place for decades.

The problem is that XBMC isnt respecting those standard frame spacings. For instance - it might be displaying all 30 frames each second, but its not displaying a frame every other hz. The end result is jerky pans because the video is technically speeding up and slowing down several times a second.

Having to resort to switching refresh rates isnt a solution - there's no reason it shouldnt be outputting properly at 60hz. Whether or not *you* can change the refresh rate of your display isnt the problem, its the 90% (at least) that can't change from anything but 60hz. It needs to respect the standard.

I'm sure its just a bug and all of this is well known to the devs. I just hope it gets fixed soon!

Edit: Just so there's no confusion - 24, 30, 60 are the US standards - European TV uses 25 and 50 instead - so they use 100hz TVs instead of the 120hz we get here.
(This post was last modified: 2008-10-09 02:45 by mdaria510.)
find quote
Post Reply