Movie info plus - nfo thumbnail and poster tool

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
fekker Offline
Posting Freak
Posts: 1,545
Joined: Oct 2008
Reputation: 30
Post: #1
------------------
http://sourceforge.net/projects/movieinfoplus/
--UPDATE-- Beta 1 - Build 2157 (Nov 25th '08)
TMDB API Version 2 implemented for Fanart and HighRes Posters
TMDB Posters added to the gui (limit of 24 displayed)
The Crash after auto-pilot finished it's run has been fixed.

3 ways to get the latest version
If you used any build later then 2000, use the update download
If your hard drive is fat32 or you don't want the IMDB Cache information (or already have those files) use the lite version
If you want the full installer, with everything embeded, use that one

--previous info
The missing button text issue under Windows Vista should be fixed now.
The installer is no longer using the One Click Install, now it's just a winrar self extractor that installs to c:\program files\movieinfoplus
It will automatically remove the configuration file, this is required due to the changes.

Old versions should be uninstalled first and at a minimum all XML's must be removed from c:\program files\movieinfoplus

I think i fixed the issues with changing the config.xml file manually to store different data onto different drives, if someone is using that, give it a try.

TV Show data is not yet enabled, I still have some updates and pretty much all the ties into the GUI to work on for that portion and need to embed 7zip so it can extract the zip files that it grabs from tvdb.

If you get a wget error, close and restart the program, it basically means it's hit 100 child processes of wget at the same time or your out of system memory. I've put in several delays to try to prevent that from happening, but it may not be enough if you have less then 2 gigs of ram or a slow internet connection.

There's a small utility that allows conversion from IMDB My Movies to a folder structure with .nfo's that contain the imdb id in them so that movieinfoplus can load that data and create the correct .nfo's and all the other assorted goodies (fanart, folder.jpg, tbn, etc), it's up there on sourceforge and displayed when you choose download.

-------

Alpha 2.0.0.1 uploaded on 11/8

- 1.5.1.2 builds on the 1.4 version, adding in the autopilot option (ability to automatically set the folder.jpg, movie.tbn, movie.nfo, and movie-fanart.jpg) to an entire collection automatically. You can now edit the movie information quickly and easily from the main screen. Information about the current folder is also displayed, allowing an easy way to see what files are associated with the movie (clicking on the movie file label will open the folder that contains the movie). Pre-cache has been updated with additional workflow to speed it up. The program will look for a file (moviename.nfo) in the folder and if it finds a <id>tt0000000</id> match in that file it will use that for the imdb id. Fanart selection is working now, it will pull the fanart from themoviedb.org and allow single click selection like the other icons.

XML files are currently used for known movie information, which works well and doesn't have the speed hit i'm running into with the embedded database. When finished, there will be a hybrid of sorts that uses both the xml and the internal database.

Feedback is requested, I'd like to have a release ready when xbmc is out of beta. I think it's close.
------------------
Here's an overview
I wanted to get all the icons and movie information, allowing me to select which icons i wanted to use for the movie, and push the icon and imdb information to the folder on the media server. Optionally i wanted to be able to just automate the whole process for larger media collections. My movies are stored by folders, so it's geared in that manner at this time.

Initially i just used folder.jpg (which is great if you have different systems linked to the media server as it's displayed under windows, media center, xbmc, sagetv, and others).

The app is currently limited to windows, but I'm planning on re-writing it with a .net 1.1 base so that it'll run under Linux (via wine).

My media is organized by folder, i.e. -- > Movies --> Action --> Jumper .. under the Jumper folder would be the actual movie file (in various formats).

Here's a short list of what it does
- reads up folder's that you configured
- checks the local xml files and later it will check the built in imdb database (created from the IMDB txt files on the imdb's ftp servers) to see if the movie information already exists, if it does, it'll use the local information
- takes the folder name (Jumper in this example) and gets the IMBD information
- takes the folder name and grabs (and caches) all the icons (wide, box, tilted, etc) - each type is user selectable
- takes the folder name and grabs the poster (from impawards)

In the gui you can select the icons for the folder.jpg by clicking on the image (it's a paneled view of all of them for that movie)

The end goal is to be able to parse through a subset of folders and add all the different items. (folder.jpg, moviename.tbn, fanart, imbd xml (or nfo), movie trailer from apple.

I've been slacking in getting all the features finished up, but it does do some nifty pre-cache of all the icons for all the folders, and uses local cached items first, speeding things up after the initial cache.
(This post was last modified: 2008-11-27 03:21 by fekker.)
find quote
Gamester17 Offline
Team-XBMC Forum Moderator
Posts: 10,523
Joined: Sep 2003
Reputation: 10
Location: Sweden
Post: #2
Open source code is always welcomed for the prosperity of future applications Wink

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
HexusOdy Offline
Aeon Group
Posts: 413
Joined: Sep 2008
Post: #3
Sounds useful. Keep us updated!
find quote
MicheldeL Offline
Junior Member
Posts: 1
Joined: Oct 2008
Reputation: 0
Post: #4
Sounds like a great piece of work. I've been struggling myself to get my entire movie collection working this way, sounds like you'd have my solution Smile
find quote
fekker Offline
Posting Freak
Posts: 1,545
Joined: Oct 2008
Reputation: 30
Post: #5
I'm still hammering out some issues, but should have a version ready by the end of the week and uploaded to sourceforge with the .net 2.0 reversions.

http://sourceforge.net/projects/movieinfoplus/

I added an early version to souceforge - it also needs the supplimental files (postersxml) to be extracted to c:\movieinfoplus\posterxml
(This post was last modified: 2008-10-13 21:15 by fekker.)
find quote
fekker Offline
Posting Freak
Posts: 1,545
Joined: Oct 2008
Reputation: 30
Post: #6
I uploaded a newer version of the app today, .nfo creation works, there's a few thousand known items (xml files of parsed imdb data) that will auto extract, known impawards.com posters auto-extract, there's an option to update those in the gui.

The install location has changed to c:\program files\movieinfoplus

The internal database is not yet linked, and the path's are wrong for extraction and database updates. Initial icon loads are still slower then expected, pre-caching data helps a ton, but will take time based on movie collection size.

The more icon types, quality setting, and number of items that are displayed will impact caching time as well as gui speed the first time a movie is loaded.

Quality settings - applied to icons only (not posters or fanart)
Low quality is a small jpeg format
Medium quality is regular sized jpeg
Highest quality is a PNG file (default) that has transparency options

I've got some code cleanup to do, and then have to figure out how the svn works on sourceforge to get the source up there.
find quote
fekker Offline
Posting Freak
Posts: 1,545
Joined: Oct 2008
Reputation: 30
Post: #7
I had some issues with the last nfo's i created, but i've recreated that part from scratch and they now work!

I'm going to cleanup the code now that the alpha works and figure out the svn.
(This post was last modified: 2008-10-24 01:50 by fekker.)
find quote
fekker Offline
Posting Freak
Posts: 1,545
Joined: Oct 2008
Reputation: 30
Post: #8
New version with new features is up on sourceforge. 1.5.1.2 is the latest, another build coming tonight or tommorrow.
find quote
fekker Offline
Posting Freak
Posts: 1,545
Joined: Oct 2008
Reputation: 30
Post: #9
I've made a lot of changes in the past week, I've rolled up those changes into Alpha 2.0.0.1

- new look and feel (which you will later be able to change the look of the gui in the settings, not yet active)
- updated folder read and internal workflow for movie handling, it's way faster now
- additional mutli-threading incorporated into slower tasks
- filtering of moves based on status (ie all movies, movies without fanart, etc.)
find quote
JiveTalker Offline
Senior Member
Posts: 114
Joined: Nov 2008
Reputation: 0
Location: Bristol, UK
Thumbs Up  Feedback
Post: #10
Hi Fekker, I've been using Alpha 2.0.0.1 and have some feedback for you.

Obviously, the application is not yet complete so it's hard to be sure whether things are just not functioning as expected or whether they are known issues so forgive me if I state the blindingly obvious!

On my pc (running XP Pro) none of the buttons have any labels or tooltips which makes things a little confusing. When I double click on a movie title in the left hand side listbox and try to display any of the artwork the images are almost always corrupt though recognisable. Double clicking a second time seems to refresh them fine though. My hard disk cache folder is now about 1GB in size so it would be nice to have an option to install the cache to a different drive to the application itself as it is generally good practice to store data on a different drive to the o/s and applications.

Overall, it seems to be coming together nicely. I had some ideas for "future enhancements" which I hope I've posted in the right place?


I look forward to the next release, well done! Smile

JiveTalker

Jive talkin, just isnt a crime
find quote
fekker Offline
Posting Freak
Posts: 1,545
Joined: Oct 2008
Reputation: 30
Post: #11
JiveTalker Wrote:Hi Fekker, I've been using Alpha 2.0.0.1 and have some feedback for you.

Obviously, the application is not yet complete so it's hard to be sure whether things are just not functioning as expected or whether they are known issues so forgive me if I state the blindingly obvious!

On my pc (running XP Pro) none of the buttons have any labels or tooltips which makes things a little confusing. When I double click on a movie title in the left hand side listbox and try to display any of the artwork the images are almost always corrupt though recognisable. Double clicking a second time seems to refresh them fine though. My hard disk cache folder is now about 1GB in size so it would be nice to have an option to install the cache to a different drive to the application itself as it is generally good practice to store data on a different drive to the o/s and applications.

Overall, it seems to be coming together nicely. I had some ideas for "future enhancements" which I hope I've posted in the right place?


I look forward to the next release, well done! Smile

JiveTalker

Not sure why the buttons don't have labels, make sure you have .net framework 2.0 service pack 1 installed. Try the new conversion app and see if those buttons do or do not show correctly, it might be an issue with the toolkit I used for the look and feel of the application, which i did not embed into the smaller conversion utility, or a video driver issue.

The image corruption may be in the way I was loading them before, this changed in the latest beta version to download it first and not stream it into the picture box.

A note on cached data, all cached XML changed in build 1500 and higher, making the older versions invalid. Images are still fine, so those could be copied out, but all old xml's must be removed or the app will not work correctly. The readme says delete everything, but you could get away with deleting *.xml from the c:\program files\movieinfoplus\ directory. The config needs to be removed for it to generate the default xml's that are embedded.

The xml cache takes up a ton of disk space depending on the block size used for the drive, the default size will waste alot of space (30megs takes 1GB of disk space), I have a partition configured with a small block size for xmls that I use alot.


The next release will allow you to modify the default folders, while they can be modified by manually editing the config.xml file now, it doesn't work as I originally intended, so that's been added to the todo list.
The trailing "\" is required for any folder defined in the config..
Correct .. c:\program files\movieinfoplus\example\
Incorrect .. c:\program files\movieinfoplus\example

I put together a conversion utility for the my movies list on imdb and uploaded it to sourceforge. I'm still coding the TV Shows part of movieinfoplus, the core is done, I'm still working on the update timeframe part and then have to tie it back into the gui. I'll prob modify the simple app to handle tv shows better. I think that's best as an add-on application then adding it back into the main program, but i haven't ruled it out. One thing at a time Big Grin

Basically you login to your imdb my movies page, make sure it's showing "All Movies" and not a filtered listing of them, view the webpage source and copy that into the text box in the application. Then click on the "Find my movies in HTML" button to parse it out. It should show you the number as well as update the list box with the items. The regex expression is listed in the text box, so if needed you could change / modify it, but that shouldn't be necessary.

The create folder button will create a folder with the moviename (less any invalid char's) and then create a .nfo file with just the imdb id in it. (this is one of the first things that movie info plus checks for, any .nfo with the id in the <id>tt0000000</id> tag.

https://sourceforge.net/project/showfile..._id=241717
(This post was last modified: 2008-11-24 18:59 by fekker.)
find quote
fekker Offline
Posting Freak
Posts: 1,545
Joined: Oct 2008
Reputation: 30
Post: #12
I think I found the issue with the button labels missing text. I'm guessing your running Windows Vista on your PC.

I'll update this post when I have that sorted out and get a new version up.

--UPDATE-- Beta 1 - Build 2116
The button text issue should be fixed now.
The installer is no longer using the One Click Install, now it's just a winrar self extractor that installs to c:\program files\movieinfoplus
It will automatically remove the configuration file, this is required due to the changes.

Old versions should be uninstalled first and at a minimum all XML's must be removed from c:\program files\movieinfoplus

I think i fixed the issues with changing the config.xml file manually to store different data onto different drives, if someone is using that, give it a try.

TV Show data is not yet enabled, I still have some updates and ties into the GUI to work on for that portion.
(This post was last modified: 2008-11-25 00:41 by fekker.)
find quote
JiveTalker Offline
Senior Member
Posts: 114
Joined: Nov 2008
Reputation: 0
Location: Bristol, UK
Smile  Thanks
Post: #13
fekker Wrote:I think I found the issue with the button labels missing text. I'm guessing your running Windows Vista on your PC.

Nope. I'm running XP Media Center Edition. I have Visual Studio 2008 installed with DotNet 3.5. After uninstalling and instaling the beta the buttons now all have labels. Smile

fekker Wrote:The xml cache takes up a ton of disk space depending on the block size used for the drive, the default size will waste alot of space (30megs takes 1GB of disk space), I have a partition configured with a small block size for xmls that I use alot.

The small xml files did waste a bit of disk space but nearly all the data I had was image data so the wasted space was well under 5% which is quite acceptable. Windows took absolutley ages to delete the XML files though, possibly because Norton Anti-virus was snooping on the content.


fekker Wrote:I put together a conversion utility for the my movies list on imdb and uploaded it to sourceforge.

Thanks very much for that. It worked beautifully! I tested it with a list of James Bond movies and it generated all the folders and NFO files. The new beta of MovieInfoPlus then successfully expanded the XML to include plot summaries etc.

I am now having some difficulty now getting the "Precache" to get the images in though. I think that I'll try a re-boot...

Jive talkin, just isnt a crime
find quote
fekker Offline
Posting Freak
Posts: 1,545
Joined: Oct 2008
Reputation: 30
Post: #14
Your welcome, it's good to have some feedback on things.

I found an issue that you may be seeing with pre-cache.

With pre-cache it loops through and downloads the icons, up to the configured max per style (max icons to cache in the settings)
However, when displaying the icons it should be using the max to display as the counter. In changing the way the icons are loaded (i.e. download first, then set for the display), I ended up bypassing the max icon check and it downloads all icons for that movie. I'll have that fixed up in the next release so it uses the max icon to display value and doesn't just grab everything.

An example is the movie 300, that one has 32 box shot icons available, the default precache is 8 icons, and the default display is 8. With the max check bypassed, when first viewing the movie it downloaded the remaining 24 icons.
The max icons that will display in the gui is currently set to 24. The limit was added for gui speed 8styles*24icons = 192 icons per movie max, i'll see about bumping that up later.
find quote
JiveTalker Offline
Senior Member
Posts: 114
Joined: Nov 2008
Reputation: 0
Location: Bristol, UK
Post: #15
fekker Wrote:Your welcome, it's good to have some feedback on things.

I found an issue that you may be seeing with pre-cache...the max icons that will display in the gui is currently set to 24. The limit was added for gui speed 8styles*24icons = 192 icons per movie max, i'll see about bumping that up later.

Re-booting seemed to fix my main problem and all seems to be working okay now. I've been trying to get all my James Bond films to have similarly styled "Wide icons". They're all fine except for Dr No, for which most of the icons displayed were for Doctor Who etc. I tried increasing the maximum icons to 24 and now 12 are displayed, only one of which is for Dr No. I guess that for some reason no other genuine Dr No wide icons could be found. Could that be because the title is sometimes "Dr. No" rather than "Dr No"?

I have wanted to have a decent interface to my tv and movies for so long but have never quite managed to find the time to rip the IMDb data so your tools are a real god send! I'm going to have a play with the XBMC interface tomorrow and see if it ticks most of my boxes.

Thanks again for all your efforts and I'll let you know of any other issues that I come across.

Cheers
JiveTalker

Jive talkin, just isnt a crime
find quote
Post Reply